aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-period
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-15 15:59:39 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-15 15:59:39 +0800
commitd5648e8169bc1ffff70e52af31275d5c9c8eb8b2 (patch)
tree1988c251cf9d74f7c12da0654a4ed8dc4c35911d /devel/py-period
parent5d72fc419d7eb88533d0cf657640c27defb9bc43 (diff)
downloadfreebsd-ports-gnome-d5648e8169bc1ffff70e52af31275d5c9c8eb8b2.tar.gz
freebsd-ports-gnome-d5648e8169bc1ffff70e52af31275d5c9c8eb8b2.tar.zst
freebsd-ports-gnome-d5648e8169bc1ffff70e52af31275d5c9c8eb8b2.zip
add py-period 0.5
A basic time period checking libary
Diffstat (limited to 'devel/py-period')
-rw-r--r--devel/py-period/Makefile29
-rw-r--r--devel/py-period/distinfo1
-rw-r--r--devel/py-period/pkg-comment1
-rw-r--r--devel/py-period/pkg-descr5
-rw-r--r--devel/py-period/pkg-plist4
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/py-period/Makefile b/devel/py-period/Makefile
new file mode 100644
index 000000000000..b83841676fad
--- /dev/null
+++ b/devel/py-period/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: py-period
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= period
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= http://www.biostat.wisc.edu/~annis/creations/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@geeksrus.net
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/period.py ${PYTHON_SITELIBDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for ex in html txt
+ ${INSTALL_DATA} ${WRKSRC}/period.${ex} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-period/distinfo b/devel/py-period/distinfo
new file mode 100644
index 000000000000..3e56eea60ebc
--- /dev/null
+++ b/devel/py-period/distinfo
@@ -0,0 +1 @@
+MD5 (period-0.5.tar.gz) = 89d0fd410eecf54b702837ce61a0d8f0
diff --git a/devel/py-period/pkg-comment b/devel/py-period/pkg-comment
new file mode 100644
index 000000000000..f80357eb7b4e
--- /dev/null
+++ b/devel/py-period/pkg-comment
@@ -0,0 +1 @@
+A basic time period checking libary
diff --git a/devel/py-period/pkg-descr b/devel/py-period/pkg-descr
new file mode 100644
index 000000000000..793881b02d1e
--- /dev/null
+++ b/devel/py-period/pkg-descr
@@ -0,0 +1,5 @@
+This is an early version of a basic time period checking libary for Python.
+It is in part inspired by perl's Time::Period module and the time class
+mechanism of Cfengine.
+
+WWW: http://www.biostat.wisc.edu/~annis/creations/period.py.html
diff --git a/devel/py-period/pkg-plist b/devel/py-period/pkg-plist
new file mode 100644
index 000000000000..fe3cbb896adb
--- /dev/null
+++ b/devel/py-period/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/period.py
+%%PORTDOCS%%share/doc/period/period.html
+%%PORTDOCS%%share/doc/period/period.txt
+%%PORTDOCS%%@dirrm share/doc/period