aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-rauth
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-11-25 03:17:23 +0800
committerwxs <wxs@FreeBSD.org>2012-11-25 03:17:23 +0800
commit533418e7ba6f10ee82e7f839d3aea00737820441 (patch)
tree0fc26d3607d2f071dcb4a322e30041f4c9f412b9 /devel/py-rauth
parentc686ccaaf473bf3f12042c192932dbc33bdddd7d (diff)
downloadfreebsd-ports-gnome-533418e7ba6f10ee82e7f839d3aea00737820441.tar.gz
freebsd-ports-gnome-533418e7ba6f10ee82e7f839d3aea00737820441.tar.zst
freebsd-ports-gnome-533418e7ba6f10ee82e7f839d3aea00737820441.zip
Update to 0.4.17.
Switch to github. Add tests. PR: ports/173855 Submitted by: Kubilay Kocak <koobs.freebsd@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'devel/py-rauth')
-rw-r--r--devel/py-rauth/Makefile28
-rw-r--r--devel/py-rauth/distinfo4
-rw-r--r--devel/py-rauth/pkg-descr2
3 files changed, 27 insertions, 7 deletions
diff --git a/devel/py-rauth/Makefile b/devel/py-rauth/Makefile
index 8eddf1e0c31d..0cfebbb2e32e 100644
--- a/devel/py-rauth/Makefile
+++ b/devel/py-rauth/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= rauth
-PORTVERSION= 0.4.15
+PORTVERSION= 0.4.17
CATEGORIES= devel www python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs.freebsd@gmail.com
@@ -18,8 +17,29 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0.12.0:${PORTSDIR}/www/py-requests
+USE_GITHUB= yes
+GH_ACCOUNT= litl
+GH_COMMIT= 219d35f
+
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install tools for unit testing
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTESTS}
+BUILD_DEPENDS:= ${TEST_DEPENDS}
+.endif
+
# Python3 ready
-USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+TEST_DEPENDS:= ${RUN_DEPENDS} \
+ nosetests:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+
+regression-test: build
+ @cd ${WRKSRC} && nosetests
.include <bsd.port.mk>
diff --git a/devel/py-rauth/distinfo b/devel/py-rauth/distinfo
index 9b3dc6e5f021..860cecbccaf7 100644
--- a/devel/py-rauth/distinfo
+++ b/devel/py-rauth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rauth-0.4.15.tar.gz) = cf33e9def3754a61cb7f0d97ba7c19f2194f581f2bf0ad91c84d37dd9e7aecdd
-SIZE (rauth-0.4.15.tar.gz) = 13622
+SHA256 (rauth-0.4.17.tar.gz) = c3fcfa6e9f0366074806dfc6346511ec664bde5a30a85108c037ecfe70bdded6
+SIZE (rauth-0.4.17.tar.gz) = 214637
diff --git a/devel/py-rauth/pkg-descr b/devel/py-rauth/pkg-descr
index f4cd873c8220..6531a03cf444 100644
--- a/devel/py-rauth/pkg-descr
+++ b/devel/py-rauth/pkg-descr
@@ -6,4 +6,4 @@ package is wrapped around the superb Python Requests.
- Service wrappers for convenient connection initialization
- Well tested (100% coverage)
-WWW: https://github.com/litl/rauth
+WWW: https://github.com/litl/rauth