aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-simpletal
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-15 16:27:54 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-15 16:27:54 +0800
commit5febcb79f67ef405a2715aedb8f8e237817d8b1b (patch)
tree7c352042e582dce493e4907f3a357fcb162b824c /devel/py-simpletal
parentba1d7ded9eba43d5f0c6ef595bcf33348446139b (diff)
downloadfreebsd-ports-gnome-5febcb79f67ef405a2715aedb8f8e237817d8b1b.tar.gz
freebsd-ports-gnome-5febcb79f67ef405a2715aedb8f8e237817d8b1b.tar.zst
freebsd-ports-gnome-5febcb79f67ef405a2715aedb8f8e237817d8b1b.zip
SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL
specifications used in Zope to power HTML and XML templates. SimpleTAL is an idependent implementation of TAL; there are no dependencies on Zope nor is any of the Zope work re-used. WWW: http://www.owlfish.com/software/simpleTAL/ PR: ports/99489 Submitted by: Jordi Haarman
Diffstat (limited to 'devel/py-simpletal')
-rw-r--r--devel/py-simpletal/Makefile21
-rw-r--r--devel/py-simpletal/distinfo3
-rw-r--r--devel/py-simpletal/pkg-descr6
-rw-r--r--devel/py-simpletal/pkg-plist25
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/py-simpletal/Makefile b/devel/py-simpletal/Makefile
new file mode 100644
index 000000000000..0da21c60397c
--- /dev/null
+++ b/devel/py-simpletal/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-simpletal
+# Date created: 26 June 2006
+# Whom: Jordi Haarman
+#
+# $FreeBSD$
+#
+
+PORTNAME= simpletal
+PORTVERSION= 4.1
+CATEGORIES= devel textproc www python
+MASTER_SITES= http://www.owlfish.com/software/simpleTAL/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= SimpleTAL-${PORTVERSION}
+
+MAINTAINER= j.haarman@synantics.com
+COMMENT= Stand alone TAL Python implementation to power HTML & XML templates
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-simpletal/distinfo b/devel/py-simpletal/distinfo
new file mode 100644
index 000000000000..cf790e57d1b5
--- /dev/null
+++ b/devel/py-simpletal/distinfo
@@ -0,0 +1,3 @@
+MD5 (SimpleTAL-4.1.tar.gz) = 16c5673382967310b336c68591ae6786
+SHA256 (SimpleTAL-4.1.tar.gz) = b613282c0b5690cd038a6a4c2bac02f4bf0130f4002e64c7c7f414e3a9340b55
+SIZE (SimpleTAL-4.1.tar.gz) = 95813
diff --git a/devel/py-simpletal/pkg-descr b/devel/py-simpletal/pkg-descr
new file mode 100644
index 000000000000..3abdd6b57cbe
--- /dev/null
+++ b/devel/py-simpletal/pkg-descr
@@ -0,0 +1,6 @@
+SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL
+specifications used in Zope to power HTML and XML templates. SimpleTAL is an
+idependent implementation of TAL; there are no dependencies on Zope nor is any
+of the Zope work re-used.
+
+WWW: http://www.owlfish.com/software/simpleTAL/
diff --git a/devel/py-simpletal/pkg-plist b/devel/py-simpletal/pkg-plist
new file mode 100644
index 000000000000..9c465a22eeea
--- /dev/null
+++ b/devel/py-simpletal/pkg-plist
@@ -0,0 +1,25 @@
+%%PYTHON_SITELIBDIR%%/simpletal/DummyLogger.py
+%%PYTHON_SITELIBDIR%%/simpletal/DummyLogger.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/DummyLogger.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/FixedHTMLParser.py
+%%PYTHON_SITELIBDIR%%/simpletal/FixedHTMLParser.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/FixedHTMLParser.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/__init__.py
+%%PYTHON_SITELIBDIR%%/simpletal/__init__.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/__init__.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/sgmlentitynames.py
+%%PYTHON_SITELIBDIR%%/simpletal/sgmlentitynames.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/sgmlentitynames.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/simpleElementTree.py
+%%PYTHON_SITELIBDIR%%/simpletal/simpleElementTree.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/simpleElementTree.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTAL.py
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTAL.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTAL.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALES.py
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALES.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALES.pyo
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALUtils.py
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALUtils.pyc
+%%PYTHON_SITELIBDIR%%/simpletal/simpleTALUtils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/simpletal/