aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-sip
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2002-10-08 16:13:59 +0800
committernbm <nbm@FreeBSD.org>2002-10-08 16:13:59 +0800
commit750a34112b152ce9cc91cf51bb3a10c52ca5e8c6 (patch)
tree389e69077e9c316994e101f230de630a7a593d32 /devel/py-sip
parent0ffbfa60c6e43431a7aa0c655d915d30abc6cb39 (diff)
downloadfreebsd-ports-gnome-750a34112b152ce9cc91cf51bb3a10c52ca5e8c6.tar.gz
freebsd-ports-gnome-750a34112b152ce9cc91cf51bb3a10c52ca5e8c6.tar.zst
freebsd-ports-gnome-750a34112b152ce9cc91cf51bb3a10c52ca5e8c6.zip
Add py-sip 3.4, python convenience link to sip library.
Diffstat (limited to 'devel/py-sip')
-rw-r--r--devel/py-sip/Makefile23
-rw-r--r--devel/py-sip/pkg-comment1
-rw-r--r--devel/py-sip/pkg-descr1
-rw-r--r--devel/py-sip/pkg-plist1
4 files changed, 26 insertions, 0 deletions
diff --git a/devel/py-sip/Makefile b/devel/py-sip/Makefile
new file mode 100644
index 000000000000..52ec0eaeeed9
--- /dev/null
+++ b/devel/py-sip/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-sip
+# Date created: Tue Oct 8 09:51:22 SAST 2002
+# Whom: nbm
+#
+# $FreeBSD$
+
+PORTNAME= sip
+PORTVERSION= 3.4
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES=
+
+MAINTAINER= nbm@FreeBSD.org
+
+LIB_DEPENDS= sip.9:${PORTSDIR}/devel/sip
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${LN} -s ${LOCALBASE}/lib/libsip.so ${PYTHONPREFIX_SITELIBDIR}/libsip.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-sip/pkg-comment b/devel/py-sip/pkg-comment
new file mode 100644
index 000000000000..1bbe1cff9ebc
--- /dev/null
+++ b/devel/py-sip/pkg-comment
@@ -0,0 +1 @@
+Python convenience link to sip library
diff --git a/devel/py-sip/pkg-descr b/devel/py-sip/pkg-descr
new file mode 100644
index 000000000000..1bbe1cff9ebc
--- /dev/null
+++ b/devel/py-sip/pkg-descr
@@ -0,0 +1 @@
+Python convenience link to sip library
diff --git a/devel/py-sip/pkg-plist b/devel/py-sip/pkg-plist
new file mode 100644
index 000000000000..7fbbfde85824
--- /dev/null
+++ b/devel/py-sip/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/libsip.so