aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-tables
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
committermat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
commitb2012f72500300ecbba6933c68717ba52c454563 (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /devel/py-tables
parente02e32ae84bd96a47a379dcd2c109efc58b41400 (diff)
downloadfreebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.gz
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.zst
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Diffstat (limited to 'devel/py-tables')
-rw-r--r--devel/py-tables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index fb11e3586201..b4ac02f9d85b 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -13,7 +13,7 @@ COMMENT= Hierarchical database for Python
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}numexpr>=1.4.1:math/py-numexpr@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}numexpr>=1.4.1:math/py-numexpr@${PY_FLAVOR}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
liblzo2.so:archivers/lzo2 \
libucl.so:archivers/ucl
@@ -26,7 +26,7 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= PYREX EXAMPLES
PYREX_DESC= Use code generated by Pyrex to build
-PYREX_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyrex>0:devel/pyrex@${FLAVOR}
+PYREX_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyrex>0:devel/pyrex@${PY_FLAVOR}
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/setup.py