aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-turbojson
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-01-27 08:40:34 +0800
committernivit <nivit@FreeBSD.org>2007-01-27 08:40:34 +0800
commit63a06ae307a58cf05b4951c61ddb3f716a77e307 (patch)
tree5d8464648e0b9572a32826275d8fdae8ddd8ddf3 /devel/py-turbojson
parentc90cc5c124b586fe346255206c45e47cf533c848 (diff)
downloadfreebsd-ports-gnome-63a06ae307a58cf05b4951c61ddb3f716a77e307.tar.gz
freebsd-ports-gnome-63a06ae307a58cf05b4951c61ddb3f716a77e307.tar.zst
freebsd-ports-gnome-63a06ae307a58cf05b4951c61ddb3f716a77e307.zip
- Fixed RUN_DEPENDS (use PYSIMPLEJSON_EGG)
Approved by: alexbl (mentor, implicit)
Diffstat (limited to 'devel/py-turbojson')
-rw-r--r--devel/py-turbojson/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/py-turbojson/Makefile b/devel/py-turbojson/Makefile
index 262a7a92acce..30e6f0ebd0bb 100644
--- a/devel/py-turbojson/Makefile
+++ b/devel/py-turbojson/Makefile
@@ -20,8 +20,8 @@ COMMENT= Python template plugin for TurboGears that supports json
BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS= ${BUILD_DEPENDS}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${PYRULEDISPATCH_EGG}:${PORTSDIR}/devel/py-ruledispatch \
- ${PYTHON_SITELIBDIR}/${PYSQLOBJECT_EGG}/sqlobject/__init__.py:${PORTSDIR}/databases/py-sqlobject \
- ${PYTHON_SITELIBDIR}/simplejson-1.4.egg:${PORTSDIR}/devel/py-simplejson
+ ${PYTHON_SITELIBDIR}/${PYSIMPLEJSON_EGG}:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_SITELIBDIR}/${PYSQLOBJECT_EGG}/sqlobject/__init__.py:${PORTSDIR}/databases/py-sqlobject
NO_BUILD= yes
@@ -44,4 +44,10 @@ do-extract:
do-install:
${EASY_INSTALL} ${EASY_INSTALL_ARGS} ${DISTDIR}/${DISTFILES}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+PYRULEDISPATCH_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-ruledispatch/Makefile -V PYRULEDISPATCH_EGG
+PYSIMPLEJSON_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-simplejson/Makefile -V PYSIMPLEJSON_EGG
+PYSQLOBJECT_EGG!= ${MAKE} -f ${PORTSDIR}/databases/py-sqlobject/Makefile -V PYSQLBOJECT_EGG
+
+.include <bsd.port.post.mk>