aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-turbokid/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2008-03-04 00:40:03 +0800
committernivit <nivit@FreeBSD.org>2008-03-04 00:40:03 +0800
commitb5c9ce5971e5a8eab531d82a1c1e4f1e7383dddd (patch)
treecbe444d0ea48cba6a2602d3a25cc0013ed462877 /devel/py-turbokid/Makefile
parentec0aa05c074fd8e162b9c72635c0e128179a8677 (diff)
downloadfreebsd-ports-gnome-b5c9ce5971e5a8eab531d82a1c1e4f1e7383dddd.tar.gz
freebsd-ports-gnome-b5c9ce5971e5a8eab531d82a1c1e4f1e7383dddd.tar.zst
freebsd-ports-gnome-b5c9ce5971e5a8eab531d82a1c1e4f1e7383dddd.zip
- Update to 1.0.4
- Convert easy_install support to bsd.python.mk - Fix download site - Remove files/pkg-install.in, files/pkg-deinstall.in
Diffstat (limited to 'devel/py-turbokid/Makefile')
-rw-r--r--devel/py-turbokid/Makefile30
1 files changed, 4 insertions, 26 deletions
diff --git a/devel/py-turbokid/Makefile b/devel/py-turbokid/Makefile
index fc594faa2653..6525a239541e 100644
--- a/devel/py-turbokid/Makefile
+++ b/devel/py-turbokid/Makefile
@@ -6,40 +6,18 @@
#
PORTNAME= TurboKid
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.4
CATEGORIES= devel python
-MASTER_SITES= http://cheeseshop.python.org/packages/${PYTHON_VER}/T/TurboKid/ \
+MASTER_SITES= CHEESESHOP \
http://nivi.interfree.it/distfiles/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PYTURBOKID_EGG}
-EXTRACT_SUFX=
MAINTAINER= nivit@FreeBSD.org
COMMENT= Python template plugin that supports Kid templates
-BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${BUILD_DEPENDS}
-RUN_DEPENDS+= kid:${PORTSDIR}/devel/py-kid
+RUN_DEPENDS= kid:${PORTSDIR}/devel/py-kid
USE_PYTHON= 2.4+
-
-NO_BUILD= yes
-
-PLIST_SUB+= PYTURBOKID_EGG=${PYTURBOKID_EGG}
-
-SUB_FILES+= pkg-deinstall pkg-install
-SUB_LIST+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
- EGG="${PORTNAME}==${PORTVERSION}"
-
-EASY_INSTALL= ${LOCALBASE}/bin/easy_install
-EASY_INSTALL_ARGS= -N -b ${WRKSRC} -d ${PYTHON_SITELIBDIR} -s ${PREFIX}/bin
-
-PYTURBOKID_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
-
-do-extract:
- ${MKDIR} ${WRKSRC}
-
-do-install:
- ${EASY_INSTALL} ${EASY_INSTALL_ARGS} ${DISTDIR}/${DISTFILES}
+USE_PYDISTUTILS= easy_install
.include <bsd.port.mk>