aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-utils
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /devel/py-utils
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'devel/py-utils')
-rw-r--r--devel/py-utils/Makefile2
-rw-r--r--devel/py-utils/files/patch-python2535
2 files changed, 37 insertions, 0 deletions
diff --git a/devel/py-utils/Makefile b/devel/py-utils/Makefile
index 7d6bd0a132af..320ee06dd47f 100644
--- a/devel/py-utils/Makefile
+++ b/devel/py-utils/Makefile
@@ -17,6 +17,8 @@ COMMENT= General utility modules that simplify common programming in Python
USE_PYTHON= 2.2+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= pythonutils
+PYDISTUTILS_EGGINFODIR= ${PYTHONPREFIX_SITELIBDIR}/pythonutils
WRKSRC= ${WRKDIR}/pythonutils-${PORTVERSION}
USE_ZIP= yes
diff --git a/devel/py-utils/files/patch-python25 b/devel/py-utils/files/patch-python25
new file mode 100644
index 000000000000..f87e7c74aaec
--- /dev/null
+++ b/devel/py-utils/files/patch-python25
@@ -0,0 +1,35 @@
+--- pythonutils/pathutils.py.orig Fri Mar 30 06:39:37 2007
++++ pythonutils/pathutils.py Fri Mar 30 06:39:49 2007
+@@ -14,13 +14,13 @@
+ # Scripts maintained at http://www.voidspace.org.uk/python/index.shtml
+ # E-mail fuzzyman@voidspace.org.uk
+
++from __future__ import generators
+ """
+ This module contains convenience functions for working with files and paths.
+ """
+
+ __version__ = '0.2.4'
+
+-from __future__ import generators
+ import os
+ import sys
+ import time
+--- pythonutils/odict.py.orig Fri Mar 30 06:41:25 2007
++++ pythonutils/odict.py Fri Mar 30 06:41:35 2007
+@@ -14,6 +14,7 @@
+ # http://groups.google.com/group/pythonutils/
+ # Comments, suggestions and bug reports welcome.
+
++from __future__ import generators
+ """A dict that keeps keys in insertion order"""
+
+ __author__ = ('Nicola Larosa <nico-NoSp@m-tekNico.net>,'
+@@ -27,7 +28,6 @@
+
+ __all__ = ['OrderedDict', 'SequenceOrderedDict']
+
+-from __future__ import generators
+ from warnings import warn
+ from types import SliceType
+