aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-uuid
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-20 04:05:56 +0800
committermiwi <miwi@FreeBSD.org>2008-07-20 04:05:56 +0800
commit3e740c6f7943bf63f3fe6ea52e7b7c5fab392b1a (patch)
tree2380e1b5ea5f6b700c0af7084fe8f14721d679e6 /devel/py-uuid
parent0dacdad0c074408ce8435a04f45387f24af86693 (diff)
downloadfreebsd-ports-gnome-3e740c6f7943bf63f3fe6ea52e7b7c5fab392b1a.tar.gz
freebsd-ports-gnome-3e740c6f7943bf63f3fe6ea52e7b7c5fab392b1a.tar.zst
freebsd-ports-gnome-3e740c6f7943bf63f3fe6ea52e7b7c5fab392b1a.zip
UUID object and generation functions for Python.
The uuid module here is part of the standard library for Python 2.5, distributed under the Python software license. WWW: http://pypi.python.org/pypi/uuid/ PR: ports/125408 Submitted by: Junji NAKANISHI <jun-g at daemonfreaks.com>
Diffstat (limited to 'devel/py-uuid')
-rw-r--r--devel/py-uuid/Makefile25
-rw-r--r--devel/py-uuid/distinfo3
-rw-r--r--devel/py-uuid/pkg-descr7
-rw-r--r--devel/py-uuid/pkg-plist3
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/py-uuid/Makefile b/devel/py-uuid/Makefile
new file mode 100644
index 000000000000..d9dd909316fd
--- /dev/null
+++ b/devel/py-uuid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-uuid
+# Date created: 6 July 2008
+# Whom: Junji NAKANISHI <jun-g@daemonfreaks.com>
+#
+# $FreeBSD$
+
+PORTNAME= uuid
+PORTVERSION= 1.30
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jun-g@daemonfreaks.com
+COMMENT= UUID object and generation functions for Python
+
+USE_PYTHON= 2.4
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.pre.mk>
+
+#.if ${PYTHON_REL} >= 250
+#IGNORE= uuid ships with Python 2.5.x
+#.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-uuid/distinfo b/devel/py-uuid/distinfo
new file mode 100644
index 000000000000..7165c538b306
--- /dev/null
+++ b/devel/py-uuid/distinfo
@@ -0,0 +1,3 @@
+MD5 (uuid-1.30.tar.gz) = 639b310f1fe6800e4bf8aa1dd9333117
+SHA256 (uuid-1.30.tar.gz) = 1f87cc004ac5120466f36c5beae48b4c48cc411968eed0eaecd3da82aa96193f
+SIZE (uuid-1.30.tar.gz) = 5811
diff --git a/devel/py-uuid/pkg-descr b/devel/py-uuid/pkg-descr
new file mode 100644
index 000000000000..95f4e6594044
--- /dev/null
+++ b/devel/py-uuid/pkg-descr
@@ -0,0 +1,7 @@
+UUID object and generation functions for Python.
+
+The uuid module here is part of the standard library for
+Python 2.5, distributed under the Python software license.
+
+
+WWW: http://pypi.python.org/pypi/uuid/
diff --git a/devel/py-uuid/pkg-plist b/devel/py-uuid/pkg-plist
new file mode 100644
index 000000000000..491682fde4b8
--- /dev/null
+++ b/devel/py-uuid/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/uuid.py
+%%PYTHON_SITELIBDIR%%/uuid.pyc
+%%PYTHON_SITELIBDIR%%/uuid.pyo