aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-wsgiutils
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-15 16:35:58 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-15 16:35:58 +0800
commite4690afbfa78449a0669db2cb9348ac8f4f30157 (patch)
treed77f3e5f2a4296470bc8e3cae1255df52fed39b6 /devel/py-wsgiutils
parent59d581a073098ea36d28295a139d7b943904bdbb (diff)
downloadfreebsd-ports-gnome-e4690afbfa78449a0669db2cb9348ac8f4f30157.tar.gz
freebsd-ports-gnome-e4690afbfa78449a0669db2cb9348ac8f4f30157.tar.zst
freebsd-ports-gnome-e4690afbfa78449a0669db2cb9348ac8f4f30157.zip
WSGIUtils is a package of standalone utility libraries that ease the development
of simple WSGI programs. The package is divided into two main components which can be used individualy or in combination. wsgiServer is a multi-threaded WSGI web server based on SimpleHTTPServer. wsgiAdaptor is a simple WSGI application that provides basic authentication, signed cookies and persistent sessions. WWW: http://www.owlfish.com/software/wsgiutils/ PR: ports/99488 Submitted by: Jordi Haarman
Diffstat (limited to 'devel/py-wsgiutils')
-rw-r--r--devel/py-wsgiutils/Makefile24
-rw-r--r--devel/py-wsgiutils/distinfo3
-rw-r--r--devel/py-wsgiutils/pkg-descr13
-rw-r--r--devel/py-wsgiutils/pkg-plist16
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/py-wsgiutils/Makefile b/devel/py-wsgiutils/Makefile
new file mode 100644
index 000000000000..435f0198eee9
--- /dev/null
+++ b/devel/py-wsgiutils/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-wsgiutils
+# Date created: 25 June 2006
+# Whom: Jordi Haarman
+#
+# $FreeBSD$
+#
+
+PORTNAME= wsgiutils
+PORTVERSION= 0.7
+CATEGORIES= devel textproc www python
+MASTER_SITES= http://www.owlfish.com/software/wsgiutils/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= WSGIUtils-${PORTVERSION}
+
+MAINTAINER= j.haarman@synantics.com
+COMMENT= Utility libraries for development of simple WSGI programs
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ PYTHON_VERSION_NR=${_PYTHON_PORTBRANCH}
+
+.include <bsd.port.mk>
diff --git a/devel/py-wsgiutils/distinfo b/devel/py-wsgiutils/distinfo
new file mode 100644
index 000000000000..5f1abd856b9c
--- /dev/null
+++ b/devel/py-wsgiutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (WSGIUtils-0.7.tar.gz) = bcb0bc3cc3a4d2be2d237ab532b1d5b8
+SHA256 (WSGIUtils-0.7.tar.gz) = 5f0fb822e8c100416edc1f75f2fd4a28dcfd2b3a046aeb39ac1c761101f0a9d1
+SIZE (WSGIUtils-0.7.tar.gz) = 17996
diff --git a/devel/py-wsgiutils/pkg-descr b/devel/py-wsgiutils/pkg-descr
new file mode 100644
index 000000000000..7dbb408c397f
--- /dev/null
+++ b/devel/py-wsgiutils/pkg-descr
@@ -0,0 +1,13 @@
+WSGIUtils is a package of standalone utility libraries that ease the development
+of simple WSGI programs.
+
+The package is divided into two main components which can be used individualy or
+in combination.
+
+wsgiServer is a multi-threaded WSGI web server based on SimpleHTTPServer.
+
+wsgiAdaptor is a simple WSGI application that provides basic authentication,
+signed cookies and persistent sessions.
+
+
+WWW: http://www.owlfish.com/software/wsgiutils/
diff --git a/devel/py-wsgiutils/pkg-plist b/devel/py-wsgiutils/pkg-plist
new file mode 100644
index 000000000000..f71c7da80d8e
--- /dev/null
+++ b/devel/py-wsgiutils/pkg-plist
@@ -0,0 +1,16 @@
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/wsgiutils/