aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pyrex
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-05-03 11:12:47 +0800
committerperky <perky@FreeBSD.org>2004-05-03 11:12:47 +0800
commitccec89988163a7125ff692cb19bfa31d26e61939 (patch)
tree0a64d440b272beb767ea962a6f2c68c63c5a767d /devel/pyrex
parentbafdcb1c69d0a8f8eca0680c362cf6a8c87f7592 (diff)
downloadfreebsd-ports-gnome-ccec89988163a7125ff692cb19bfa31d26e61939.tar.gz
freebsd-ports-gnome-ccec89988163a7125ff692cb19bfa31d26e61939.tar.zst
freebsd-ports-gnome-ccec89988163a7125ff692cb19bfa31d26e61939.zip
Update to 0.9.1.1 and fix build
Diffstat (limited to 'devel/pyrex')
-rw-r--r--devel/pyrex/Makefile7
-rw-r--r--devel/pyrex/distinfo4
-rw-r--r--devel/pyrex/pkg-plist1
3 files changed, 8 insertions, 4 deletions
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
index 1f0369c4fa30..1cfbe02482a6 100644
--- a/devel/pyrex/Makefile
+++ b/devel/pyrex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pyrex
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.1.1
CATEGORIES= devel lang python
MASTER_SITES= http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
@@ -22,8 +22,11 @@ USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^PYINCLUDE =.*|PYINCLUDE=${PYTHON_INCLUDEDIR}|g' \
-e 's|\.\./py|${PREFIX}/bin/py|g' ${WRKSRC}/Demos/Makefile
+ @${REINPLACE_CMD} -e 's|sys.platform in ("unix", "darwin")|1|g'\
+ ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|from Plex|from Pyrex.Plex|g' \
+ ${WRKSRC}/Pyrex/Compiler/Lexicon.py
@${RM} -f ${WRKSRC}/Demos/Makefile.bak
- @${LN} ${WRKSRC}/pyrexc.py ${WRKSRC}/pyrexc
@${FIND} ${WRKSRC} -name .DS_Store | ${XARGS} ${RM} -f
post-install:
diff --git a/devel/pyrex/distinfo b/devel/pyrex/distinfo
index 19fc59cedc8d..e7e3f6cdfa1e 100644
--- a/devel/pyrex/distinfo
+++ b/devel/pyrex/distinfo
@@ -1,2 +1,2 @@
-MD5 (Pyrex-0.9.1.tar.gz) = 9e0e59beaf96f7d8456d2d49da6d47a3
-SIZE (Pyrex-0.9.1.tar.gz) = 173460
+MD5 (Pyrex-0.9.1.1.tar.gz) = 2f9eebe796e10a9da46f3d6a7a4df1b3
+SIZE (Pyrex-0.9.1.1.tar.gz) = 178902
diff --git a/devel/pyrex/pkg-plist b/devel/pyrex/pkg-plist
index a66e0394833f..ebee386f1154 100644
--- a/devel/pyrex/pkg-plist
+++ b/devel/pyrex/pkg-plist
@@ -147,6 +147,7 @@ bin/pyrexc
%%PORTDOCS%%share/examples/pyrex/callback/README.txt
%%PORTDOCS%%share/examples/pyrex/callback/Setup.py
%%PORTDOCS%%share/examples/pyrex/callback/cheese.pyx
+%%PORTDOCS%%share/examples/pyrex/callback/cheesefinder.c
%%PORTDOCS%%share/examples/pyrex/callback/cheesefinder.h
%%PORTDOCS%%share/examples/pyrex/callback/run_cheese.py
%%PORTDOCS%%share/examples/pyrex/embed/Makefile