aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qct
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-07 19:22:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-07 19:22:59 +0800
commit682a86db34bb00486ff86411cf0cd9781f9a2f04 (patch)
tree08b17438e1a60ad22d1968d6f22afa03d8568c8e /devel/qct
parentb202f01b774e1dbfb340e1347107ea85717765db (diff)
downloadfreebsd-ports-gnome-682a86db34bb00486ff86411cf0cd9781f9a2f04.tar.gz
freebsd-ports-gnome-682a86db34bb00486ff86411cf0cd9781f9a2f04.tar.zst
freebsd-ports-gnome-682a86db34bb00486ff86411cf0cd9781f9a2f04.zip
- Add LICENSE_FILE
- Switch to options helpers - Fix docfile installation - Regenerate patches with `make makepatch`
Diffstat (limited to 'devel/qct')
-rw-r--r--devel/qct/Makefile6
-rw-r--r--devel/qct/files/patch-qctlib_vcs_svn.py9
-rw-r--r--devel/qct/files/patch-setup.py6
3 files changed, 12 insertions, 9 deletions
diff --git a/devel/qct/Makefile b/devel/qct/Makefile
index d4b60c0f11bd..6d0858b97dac 100644
--- a/devel/qct/Makefile
+++ b/devel/qct/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= QCT GUI commit tool
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-gui
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-gui
@@ -18,10 +19,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-g
USES= python
USE_PYTHON= distutils
WRKSRC= ${WRKDIR}/qct
+
OPTIONS_DEFINE= DOCS
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/qct.1.txt ${STAGEDIR}${DOCSDIR}/qct.1.txt
+ ${INSTALL_DATA} ${WRKSRC}/doc/qct.1.txt ${STAGEDIR}${DOCSDIR}/qct.1.txt
.include <bsd.port.mk>
diff --git a/devel/qct/files/patch-qctlib_vcs_svn.py b/devel/qct/files/patch-qctlib_vcs_svn.py
index ce824a53fc29..9bfc3c154361 100644
--- a/devel/qct/files/patch-qctlib_vcs_svn.py
+++ b/devel/qct/files/patch-qctlib_vcs_svn.py
@@ -1,7 +1,7 @@
---- qctlib/vcs/svn.py.orig 2009-02-15 23:49:32.000000000 +0100
-+++ qctlib/vcs/svn.py 2009-07-22 17:58:33.000000000 +0200
+--- qctlib/vcs/svn.py.orig 2009-02-15 22:49:32 UTC
++++ qctlib/vcs/svn.py
@@ -84,6 +84,8 @@ class qctVcsSvn:
-
+
if showIgnored: extra = ['--no-ignore']
else: extra = []
+ versionOutput = runProgram([self.svn_exe, '--version', '--quiet'])
@@ -11,7 +11,7 @@
recs.pop() # remove last entry (which is '')
@@ -91,11 +93,19 @@ class qctVcsSvn:
if pb: pb.setValue(2)
-
+
for line in recs:
- if len(line) < 7:
- continue
@@ -33,3 +33,4 @@
+ self.fileStatus[ fname ] = line[0:6]
if status == 'M': # modified
itemList.append('M ' + fname)
+ elif status == 'A': # added
diff --git a/devel/qct/files/patch-setup.py b/devel/qct/files/patch-setup.py
index 42ffdebe524b..e6c4ba6b0ed8 100644
--- a/devel/qct/files/patch-setup.py
+++ b/devel/qct/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2009-02-16 01:49:32.000000000 +0300
-+++ setup.py 2012-01-18 19:01:41.000000000 +0400
-@@ -10,20 +10,8 @@
+--- setup.py.orig 2009-02-15 22:49:32 UTC
++++ setup.py
+@@ -10,20 +10,8 @@ if not hasattr(sys, 'version_info') or s
raise SystemExit, "Qct requires python 2.4 or later."
extra = {}