aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qdevelop
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-26 20:58:55 +0800
committermakc <makc@FreeBSD.org>2013-11-26 20:58:55 +0800
commit33f63d154e2982f6506fd696bc83d6e1a75db27e (patch)
tree74685dca100b283681ff177d5e71b64b5e8c2867 /devel/qdevelop
parent8b47aedf6ad4a71aa6c69df6d1813699e913657f (diff)
downloadfreebsd-ports-gnome-33f63d154e2982f6506fd696bc83d6e1a75db27e.tar.gz
freebsd-ports-gnome-33f63d154e2982f6506fd696bc83d6e1a75db27e.tar.zst
freebsd-ports-gnome-33f63d154e2982f6506fd696bc83d6e1a75db27e.zip
- Clean up after conversion to USES=qmake
- Use options helpels
Diffstat (limited to 'devel/qdevelop')
-rw-r--r--devel/qdevelop/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index 1fe7de24738e..e1ec1bbd6a0b 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://biord-software.org/downloads/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
-COMMENT= Development environment entirely dedicated to Qt4
+COMMENT= Development environment entirely dedicated to Qt 4
RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags
@@ -17,11 +17,10 @@ USE_QT4= gui sql network xml designer sql-sqlite3_run \
moc_build uic_build rcc_build
USES= qmake
-QMAKE_PRO= QDevelop.pro
STRIP_FILES= bin/${PORTNAME}
DESKTOP_ENTRIES= "QDevelop" \
- "Qt4 development environment" \
+ "Qt 4 development environment" \
"${PREFIX}/share/pixmaps/qdevelop.png" \
"qdevelop" \
"Development;IDE;Qt;" \
@@ -29,22 +28,14 @@ DESKTOP_ENTRIES= "QDevelop" \
OPTIONS_DEFINE= TOOLS DOCS NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-TOOLS_DESC= Install Qt4 dev. tools (qmake, moc, etc.)
+OPTIONS_SUB= yes
+NLS_USE= QT4=linguist_build
+TOOLS_DESC= Install Qt 4 development tools (qmake, moc, etc.)
+TOOLS_USE= ${_TOOLS:C|.*|QT4=&_run|}
+_TOOLS= assistant linguist moc qmake rcc uic
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USE_QT4+= linguist_build
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTOOLS}
-USE_QT4+= assistant_run linguist_run \
- qmake_run moc_run uic_run rcc_run
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|\"qmake\"|\"qmake-qt4\"|g" \
-e "s|\"linguist\"|\"linguist-qt4\"|g" \
@@ -56,7 +47,7 @@ post-patch:
-e "s|\"/usr/bin/ctags\"|\"${LOCALBASE}/bin/exctags\"|g" \
${WRKSRC}/src/toolscontrolimpl.cpp
${REINPLACE_CMD} -e "/target.path/s|/usr/bin/|${PREFIX}/bin|g" \
- ${WRKSRC}/${QMAKE_PRO}
+ ${WRKSRC}/QDevelop.pro
${REINPLACE_CMD} -e "s,lib/qdevelop/translations,${DATADIR_REL}/translations,g" \
${WRKSRC}/src/main.cpp \
${WRKSRC}/plugins/tools-regexp-planner/replugin.cpp \
@@ -64,7 +55,7 @@ post-patch:
post-configure:
.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC} && ${LRELEASE} ${QMAKE_PRO}
+ ${LRELEASE} ${WRKSRC}/QDevelop.pro
.endif
post-install: