aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qmake4
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-02-06 04:56:24 +0800
committerlofi <lofi@FreeBSD.org>2007-02-06 04:56:24 +0800
commite66bdb544bf6fe96d5a45c95518a6422775271b4 (patch)
treefb8cebf6a9ce568966bd68c924e5e2d54e27be82 /devel/qmake4
parent1ceef0896292eb830cc1ce993a41b8fea4d719f8 (diff)
downloadfreebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.tar.gz
freebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.tar.zst
freebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.zip
Add qt4, a multiplatform C++ application framework
Diffstat (limited to 'devel/qmake4')
-rw-r--r--devel/qmake4/Makefile77
-rw-r--r--devel/qmake4/distinfo3
-rw-r--r--devel/qmake4/files/Makefile.bsd47
-rw-r--r--devel/qmake4/files/qconfig.cpp19
-rw-r--r--devel/qmake4/pkg-descr8
-rw-r--r--devel/qmake4/pkg-plist284
6 files changed, 438 insertions, 0 deletions
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
new file mode 100644
index 000000000000..4bf64ac496e1
--- /dev/null
+++ b/devel/qmake4/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: qmake-4
+# Date created: Tue Jul 12 16:04:29 UTC 2005
+# Whom: lofi@freebsd.org,
+# mi@aldan.algebra.com
+#
+# $FreeBSD$
+
+PORTNAME= qmake
+PORTVERSION= 4.2.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_QT}
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@freebsd.org
+COMMENT= The build utility of the Qt project
+
+REINPLACE_ARGS= -i ""
+WRKSRC= ${WRKDIR}/${DISTNAME}/qmake
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+MAKE_ENV+= FILESDIR="${FILESDIR}"
+#USE_BZIP2= yes
+
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ '${DISTNAME}/config.tests/unix/padstring' \
+ '${DISTNAME}/mkspecs' \
+ '${DISTNAME}/include/*/*' \
+ '${DISTNAME}/src/*/*.h' '${DISTNAME}/qmake' \
+ '${DISTNAME}/src/corelib/tools' \
+ '${DISTNAME}/src/corelib/io' \
+ '${DISTNAME}/src/corelib/global' \
+ '${DISTNAME}/src/corelib/plugin' \
+ '${DISTNAME}/src/corelib/kernel' \
+ '${DISTNAME}/src/3rdparty/md5'
+
+.if !defined(NOPORTDOCS)
+EXTRACT_AFTER_ARGS+='${DISTNAME}/doc/html/qmake*'
+DOCSDIR=${PREFIX}/share/doc/qt4
+post-install:
+ ${MKDIR} '${DOCSDIR}'
+ ${CP} -Rp '${WRKSRC:H}/doc/html' '${DOCSDIR}'
+.endif
+
+post-patch:
+ @${RM} -fr ${WRKSRC}/examples ${WRKSRC}/tutorial
+ @${REINPLACE_CMD} -e 's|-O2|${CXXFLAGS}|' \
+ -e 's|gcc.*|${CC}|' \
+ -e 's|g++.*|${CXX}|' \
+ -e 's|/usr/local|${LOCALBASE}|' \
+ -e 's|/usr/X11R6|${X11BASE}|' \
+ -e 's|release|release thread|' \
+ -e 's|-pthread -D_THREAD_SAFE|${PTHREAD_CFLAGS}|' \
+ -e 's|-pthread|${PTHREAD_LIBS}|' \
+ -e 's|uic|uic4|' \
+ -e 's|moc|moc4|' \
+ ${WRKSRC}/../mkspecs/freebsd-g++/qmake.conf \
+ ${WRKSRC}/../mkspecs/freebsd-g++34/qmake.conf
+ @${REINPLACE_CMD} -e 's|@QMAKE_QTOBJS@||g' ${WRKSRC}/Makefile.unix
+
+do-configure:
+ ${SED} -e 's|/usr/local|${PREFIX}|g' \
+ < ${FILESDIR}/qconfig.cpp \
+ > ${WRKSRC:H}/src/corelib/global/qconfig.cpp
+ ${ECHO} '/* empty */' > ${WRKSRC}/qconfig.h
+ ${LN} ${WRKSRC}/qconfig.h ${WRKSRC}/../include/QtCore/qconfig.h
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+USE_GCC= 3.4+
+.endif
+
+.if ${ARCH} == "alpha"
+CXXFLAGS+= -mieee
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qmake4/distinfo b/devel/qmake4/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/devel/qmake4/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/devel/qmake4/files/Makefile.bsd b/devel/qmake4/files/Makefile.bsd
new file mode 100644
index 000000000000..dd4e48c651bf
--- /dev/null
+++ b/devel/qmake4/files/Makefile.bsd
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+_OBJS!= ${MAKE} -f Makefile.unix -V OBJS -V QOBJS
+# We'd like to avoid using qconfig.cpp, but can't -- see the comment
+# next to -DHAVE_CONFIG_CPP below:
+#_OBJS:= ${_OBJS:S/qconfig.o//}
+SRCS:= ${_OBJS:.o=.cpp}
+NOMAN= true # qmake.1 anyone?
+
+.PATH: ${.CURDIR} ${.CURDIR:H}/src/corelib/tools ${.CURDIR:H}/src/corelib/io \
+ ${.CURDIR:H}/src/corelib/global ${.CURDIR:H}/src/corelib/plugin \
+ ${.CURDIR:H}/src/corelib/kernel ${.CURDIR:H}/src/3rdparty/md5
+CXXFLAGS+=-I${.CURDIR:H}/mkspecs/freebsd-g++
+
+.for s in src/corelib/arch/generic src/global src/tools src/kernel src/codecs \
+ src/3rdparty/md5 include/QtCore include
+CXXFLAGS+=-I${.CURDIR:H}/$s
+.endfor
+
+.for g in /. /unix /win32 /mac
+.PATH: ${.CURDIR}/generators$g
+CXXFLAGS+=-I${.CURDIR}/generators$g
+.endfor
+
+CXXFLAGS+=-I. -I"${FILESDIR}"
+
+CXXFLAGS+=-DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT \
+ -DQT_NO_STL -DQT_BUILD_QMAKE -DQT_NO_COMPRESS -DHAVE_QCONFIG_CPP \
+ -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQMAKE_OPENSOURCE_EDITION
+
+# I guess, qconfig.cpp used to be optional, but no longer is -- due to
+# bit-rot in Qt sources. So we still have to compile it, but, by not
+# adding the following define, we reduce the seemingly needless usage of
+# it:
+# -DHAVE_QCONFIG_CPP
+
+PROG_CXX= qmake-qt4
+BINDIR= ${PREFIX}/bin
+SHAREDIR=${PREFIX}/share/qt4
+
+${SHAREDIR}:
+ mkdir -p "$@"
+
+beforeinstall: ${SHAREDIR}
+ cp -Rp ${.CURDIR:H}/mkspecs ${SHAREDIR}
+
+.include <bsd.prog.mk>
diff --git a/devel/qmake4/files/qconfig.cpp b/devel/qmake4/files/qconfig.cpp
new file mode 100644
index 000000000000..3bf44c9a3582
--- /dev/null
+++ b/devel/qmake4/files/qconfig.cpp
@@ -0,0 +1,19 @@
+/*
+ * $FreeBSD$
+ * Hand-crafted...
+ * The default prefix (/ usr / local) is dynamicly replaced
+ * at configure time.
+ */
+#define QT_CONFIGURE_LICENSEE "Open Source";
+#define QT_CONFIGURE_LICENSED_PRODUCTS "OpenSourceDesktop";
+#define QT_CONFIGURE_PREFIX_PATH "/usr/local";
+#define QT_CONFIGURE_DOCUMENTATION_PATH "/usr/local/share/doc/qt4";
+#define QT_CONFIGURE_HEADERS_PATH "/usr/local/include";
+#define QT_CONFIGURE_LIBRARIES_PATH "/usr/local/lib";
+#define QT_CONFIGURE_BINARIES_PATH "/usr/local/bin";
+#define QT_CONFIGURE_PLUGINS_PATH "/usr/local/lib/plugins";
+#define QT_CONFIGURE_DATA_PATH "/usr/local/share/qt4";
+#define QT_CONFIGURE_TRANSLATIONS_PATH "/usr/local/share/qt4/translations";
+#define QT_CONFIGURE_SETTINGS_PATH "/usr/local/etc/xdg";
+#define QT_CONFIGURE_EXAMPLES_PATH "/usr/local/share/qt4/examples";
+#define QT_CONFIGURE_DEMOS_PATH "/usr/local/share/qt4/demos/";
diff --git a/devel/qmake4/pkg-descr b/devel/qmake4/pkg-descr
new file mode 100644
index 000000000000..eccbc5d9c1e0
--- /dev/null
+++ b/devel/qmake4/pkg-descr
@@ -0,0 +1,8 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qmake is a project and makefile creating utility, that is part of Qt.
+For ease of maintainance it is split out into a port of its own.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qmake4/pkg-plist b/devel/qmake4/pkg-plist
new file mode 100644
index 000000000000..7f00b8484c24
--- /dev/null
+++ b/devel/qmake4/pkg-plist
@@ -0,0 +1,284 @@
+bin/qmake-qt4
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-advanced-usage.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-common-projects.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-environment-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-function-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-manual.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-platform-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-precompiledheaders.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-project-files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-running.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-using.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake-variable-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qmake.dcf
+share/qt4/mkspecs/aix-g++-64/qmake.conf
+share/qt4/mkspecs/aix-g++-64/qplatformdefs.h
+share/qt4/mkspecs/aix-g++/qmake.conf
+share/qt4/mkspecs/aix-g++/qplatformdefs.h
+share/qt4/mkspecs/aix-xlc-64/qmake.conf
+share/qt4/mkspecs/aix-xlc-64/qplatformdefs.h
+share/qt4/mkspecs/aix-xlc/qmake.conf
+share/qt4/mkspecs/aix-xlc/qplatformdefs.h
+share/qt4/mkspecs/common/g++.conf
+share/qt4/mkspecs/common/linux.conf
+share/qt4/mkspecs/common/unix.conf
+share/qt4/mkspecs/darwin-g++/qmake.conf
+share/qt4/mkspecs/darwin-g++/qplatformdefs.h
+share/qt4/mkspecs/features/assistant.prf
+share/qt4/mkspecs/features/build_pass.prf
+share/qt4/mkspecs/features/debug.prf
+share/qt4/mkspecs/features/debug_and_release.prf
+share/qt4/mkspecs/features/default_post.prf
+share/qt4/mkspecs/features/default_pre.prf
+share/qt4/mkspecs/features/designer.prf
+share/qt4/mkspecs/features/dll.prf
+share/qt4/mkspecs/features/exclusive_builds.prf
+share/qt4/mkspecs/features/link_pkgconfig.prf
+share/qt4/mkspecs/features/qdbus.prf
+share/qt4/mkspecs/features/qt_functions.prf
+share/qt4/mkspecs/features/mac/ppc.prf
+share/qt4/mkspecs/features/mac/x86.prf
+share/qt4/mkspecs/features/mac/default_post.prf
+share/qt4/mkspecs/features/mac/default_pre.prf
+share/qt4/mkspecs/features/mac/objective_c.prf
+share/qt4/mkspecs/features/mac/rez.prf
+share/qt4/mkspecs/features/mac/sdk.prf
+share/qt4/mkspecs/features/moc.prf
+share/qt4/mkspecs/features/qt.prf
+share/qt4/mkspecs/features/qt_config.prf
+share/qt4/mkspecs/features/qtestlib.prf
+share/qt4/mkspecs/features/qtopia.prf
+share/qt4/mkspecs/features/qtopiainc.prf
+share/qt4/mkspecs/features/qtopialib.prf
+share/qt4/mkspecs/features/release.prf
+share/qt4/mkspecs/features/resources.prf
+share/qt4/mkspecs/features/shared.prf
+share/qt4/mkspecs/features/silent.prf
+share/qt4/mkspecs/features/static.prf
+share/qt4/mkspecs/features/static_and_shared.prf
+share/qt4/mkspecs/features/staticlib.prf
+share/qt4/mkspecs/features/uic.prf
+share/qt4/mkspecs/features/uitools.prf
+share/qt4/mkspecs/features/unix/dylib.prf
+share/qt4/mkspecs/features/unix/hide_symbols.prf
+share/qt4/mkspecs/features/unix/largefile.prf
+share/qt4/mkspecs/features/unix/opengl.prf
+share/qt4/mkspecs/features/unix/separate_debug_info.prf
+share/qt4/mkspecs/features/unix/thread.prf
+share/qt4/mkspecs/features/unix/x11.prf
+share/qt4/mkspecs/features/unix/x11inc.prf
+share/qt4/mkspecs/features/unix/x11lib.prf
+share/qt4/mkspecs/features/unix/x11sm.prf
+share/qt4/mkspecs/features/warn_off.prf
+share/qt4/mkspecs/features/warn_on.prf
+share/qt4/mkspecs/features/win32/console.prf
+share/qt4/mkspecs/features/win32/default_pre.prf
+share/qt4/mkspecs/features/win32/dumpcpp.prf
+share/qt4/mkspecs/features/win32/embed_manifest_dll.prf
+share/qt4/mkspecs/features/win32/embed_manifest_exe.prf
+share/qt4/mkspecs/features/win32/exceptions.prf
+share/qt4/mkspecs/features/win32/exceptions_off.prf
+share/qt4/mkspecs/features/win32/opengl.prf
+share/qt4/mkspecs/features/win32/qaxcontainer.prf
+share/qt4/mkspecs/features/win32/qaxserver.prf
+share/qt4/mkspecs/features/win32/qt_dll.prf
+share/qt4/mkspecs/features/win32/rtti.prf
+share/qt4/mkspecs/features/win32/rtti_off.prf
+share/qt4/mkspecs/features/win32/stl.prf
+share/qt4/mkspecs/features/win32/stl_off.prf
+share/qt4/mkspecs/features/win32/thread.prf
+share/qt4/mkspecs/features/win32/thread_off.prf
+share/qt4/mkspecs/features/win32/windows.prf
+share/qt4/mkspecs/freebsd-g++/qmake.conf
+share/qt4/mkspecs/freebsd-g++/qplatformdefs.h
+share/qt4/mkspecs/freebsd-g++34/qmake.conf
+share/qt4/mkspecs/freebsd-g++34/qplatformdefs.h
+share/qt4/mkspecs/freebsd-g++40/qmake.conf
+share/qt4/mkspecs/freebsd-g++40/qplatformdefs.h
+share/qt4/mkspecs/freebsd-icc/qmake.conf
+share/qt4/mkspecs/freebsd-icc/qplatformdefs.h
+share/qt4/mkspecs/hpux-acc-64/qmake.conf
+share/qt4/mkspecs/hpux-acc-64/qplatformdefs.h
+share/qt4/mkspecs/hpux-acc-o64/qmake.conf
+share/qt4/mkspecs/hpux-acc-o64/qplatformdefs.h
+share/qt4/mkspecs/hpux-acc/qmake.conf
+share/qt4/mkspecs/hpux-acc/qplatformdefs.h
+share/qt4/mkspecs/hpux-g++-64/qmake.conf
+share/qt4/mkspecs/hpux-g++-64/qplatformdefs.h
+share/qt4/mkspecs/hpux-g++/qmake.conf
+share/qt4/mkspecs/hpux-g++/qplatformdefs.h
+share/qt4/mkspecs/hpuxi-acc-64/qmake.conf
+share/qt4/mkspecs/hpuxi-acc-64/qplatformdefs.h
+share/qt4/mkspecs/hpuxi-acc/qmake.conf
+share/qt4/mkspecs/hpuxi-acc/qplatformdefs.h
+share/qt4/mkspecs/hurd-g++/qmake.conf
+share/qt4/mkspecs/hurd-g++/qplatformdefs.h
+share/qt4/mkspecs/irix-cc-64/qmake.conf
+share/qt4/mkspecs/irix-cc-64/qplatformdefs.h
+share/qt4/mkspecs/irix-cc/qmake.conf
+share/qt4/mkspecs/irix-cc/qplatformdefs.h
+share/qt4/mkspecs/irix-g++-64/qmake.conf
+share/qt4/mkspecs/irix-g++-64/qplatformdefs.h
+share/qt4/mkspecs/irix-g++/qmake.conf
+share/qt4/mkspecs/irix-g++/qplatformdefs.h
+share/qt4/mkspecs/linux-cxx/qmake.conf
+share/qt4/mkspecs/linux-cxx/qplatformdefs.h
+share/qt4/mkspecs/linux-ecc-64/qmake.conf
+share/qt4/mkspecs/linux-ecc-64/qplatformdefs.h
+share/qt4/mkspecs/linux-g++-32/qmake.conf
+share/qt4/mkspecs/linux-g++-32/qplatformdefs.h
+share/qt4/mkspecs/linux-g++-64/qmake.conf
+share/qt4/mkspecs/linux-g++-64/qplatformdefs.h
+share/qt4/mkspecs/linux-g++/qmake.conf
+share/qt4/mkspecs/linux-g++/qplatformdefs.h
+share/qt4/mkspecs/linux-icc/qmake.conf
+share/qt4/mkspecs/linux-icc/qplatformdefs.h
+share/qt4/mkspecs/linux-kcc/qmake.conf
+share/qt4/mkspecs/linux-kcc/qplatformdefs.h
+share/qt4/mkspecs/linux-lsb/qmake.conf
+share/qt4/mkspecs/linux-lsb/qplatformdefs.h
+share/qt4/mkspecs/linux-pgcc/qmake.conf
+share/qt4/mkspecs/linux-pgcc/qplatformdefs.h
+share/qt4/mkspecs/lynxos-g++/qmake.conf
+share/qt4/mkspecs/lynxos-g++/qplatformdefs.h
+share/qt4/mkspecs/macx-g++/Info.plist.app
+share/qt4/mkspecs/macx-g++/Info.plist.lib
+share/qt4/mkspecs/macx-g++/qmake.conf
+share/qt4/mkspecs/macx-g++/qplatformdefs.h
+share/qt4/mkspecs/macx-icc/qmake.conf
+share/qt4/mkspecs/macx-icc/qplatformdefs.h
+share/qt4/mkspecs/macx-pbuilder/Info.plist.app
+share/qt4/mkspecs/macx-pbuilder/qmake.conf
+share/qt4/mkspecs/macx-pbuilder/qplatformdefs.h
+share/qt4/mkspecs/macx-xcode/Info.plist.app
+share/qt4/mkspecs/macx-xcode/Info.plist.lib
+share/qt4/mkspecs/macx-xcode/qmake.conf
+share/qt4/mkspecs/macx-xcode/qplatformdefs.h
+share/qt4/mkspecs/macx-xlc/qmake.conf
+share/qt4/mkspecs/macx-xlc/qplatformdefs.h
+share/qt4/mkspecs/netbsd-g++/qmake.conf
+share/qt4/mkspecs/netbsd-g++/qplatformdefs.h
+share/qt4/mkspecs/openbsd-g++/qmake.conf
+share/qt4/mkspecs/openbsd-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/freebsd-generic-g++/qmake.conf
+share/qt4/mkspecs/qws/freebsd-generic-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-arm-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-arm-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-cellon-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-cellon-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-generic-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-generic-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-generic-g++-32/qmake.conf
+share/qt4/mkspecs/qws/linux-generic-g++-32/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-ipaq-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-ipaq-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-mips-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-mips-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-sharp-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-sharp-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-x86-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-x86-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-x86_64-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-x86_64-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/linux-zylonite-g++/qmake.conf
+share/qt4/mkspecs/qws/linux-zylonite-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/macx-generic-g++/qmake.conf
+share/qt4/mkspecs/qws/macx-generic-g++/qplatformdefs.h
+share/qt4/mkspecs/qws/solaris-generic-g++/qmake.conf
+share/qt4/mkspecs/qws/solaris-generic-g++/qplatformdefs.h
+share/qt4/mkspecs/sco-cc/qmake.conf
+share/qt4/mkspecs/sco-cc/qplatformdefs.h
+share/qt4/mkspecs/sco-g++/qmake.conf
+share/qt4/mkspecs/sco-g++/qplatformdefs.h
+share/qt4/mkspecs/solaris-cc-64/qmake.conf
+share/qt4/mkspecs/solaris-cc-64/qplatformdefs.h
+share/qt4/mkspecs/solaris-cc/qmake.conf
+share/qt4/mkspecs/solaris-cc/qplatformdefs.h
+share/qt4/mkspecs/solaris-g++-64/qmake.conf
+share/qt4/mkspecs/solaris-g++-64/qplatformdefs.h
+share/qt4/mkspecs/solaris-g++/qmake.conf
+share/qt4/mkspecs/solaris-g++/qplatformdefs.h
+share/qt4/mkspecs/tru64-cxx/qmake.conf
+share/qt4/mkspecs/tru64-cxx/qplatformdefs.h
+share/qt4/mkspecs/tru64-g++/qmake.conf
+share/qt4/mkspecs/tru64-g++/qplatformdefs.h
+share/qt4/mkspecs/unixware-cc/qmake.conf
+share/qt4/mkspecs/unixware-cc/qplatformdefs.h
+share/qt4/mkspecs/unixware-g++/qmake.conf
+share/qt4/mkspecs/unixware-g++/qplatformdefs.h
+share/qt4/mkspecs/win32-g++/qmake.conf
+share/qt4/mkspecs/win32-g++/qplatformdefs.h
+@dirrm share/qt4/mkspecs/win32-g++
+@dirrm share/qt4/mkspecs/unixware-g++
+@dirrm share/qt4/mkspecs/unixware-cc
+@dirrm share/qt4/mkspecs/tru64-g++
+@dirrm share/qt4/mkspecs/tru64-cxx
+@dirrm share/qt4/mkspecs/solaris-g++-64
+@dirrm share/qt4/mkspecs/solaris-g++
+@dirrm share/qt4/mkspecs/solaris-cc-64
+@dirrm share/qt4/mkspecs/solaris-cc
+@dirrm share/qt4/mkspecs/sco-g++
+@dirrm share/qt4/mkspecs/sco-cc
+@dirrm share/qt4/mkspecs/qws/solaris-generic-g++
+@dirrm share/qt4/mkspecs/qws/macx-generic-g++
+@dirrm share/qt4/mkspecs/qws/linux-zylonite-g++
+@dirrm share/qt4/mkspecs/qws/linux-x86_64-g++
+@dirrm share/qt4/mkspecs/qws/linux-x86-g++
+@dirrm share/qt4/mkspecs/qws/linux-sharp-g++
+@dirrm share/qt4/mkspecs/qws/linux-mips-g++
+@dirrm share/qt4/mkspecs/qws/linux-ipaq-g++
+@dirrm share/qt4/mkspecs/qws/linux-generic-g++
+@dirrm share/qt4/mkspecs/qws/linux-generic-g++-32
+@dirrm share/qt4/mkspecs/qws/linux-cellon-g++
+@dirrm share/qt4/mkspecs/qws/linux-arm-g++
+@dirrm share/qt4/mkspecs/qws/freebsd-generic-g++
+@dirrm share/qt4/mkspecs/qws
+@dirrm share/qt4/mkspecs/openbsd-g++
+@dirrm share/qt4/mkspecs/netbsd-g++
+@dirrm share/qt4/mkspecs/macx-xlc
+@dirrm share/qt4/mkspecs/macx-xcode
+@dirrm share/qt4/mkspecs/macx-pbuilder
+@dirrm share/qt4/mkspecs/macx-g++
+@dirrm share/qt4/mkspecs/macx-icc
+@dirrm share/qt4/mkspecs/lynxos-g++
+@dirrm share/qt4/mkspecs/linux-pgcc
+@dirrm share/qt4/mkspecs/linux-lsb
+@dirrm share/qt4/mkspecs/linux-kcc
+@dirrm share/qt4/mkspecs/linux-icc
+@dirrm share/qt4/mkspecs/linux-g++-64
+@dirrm share/qt4/mkspecs/linux-g++-32
+@dirrm share/qt4/mkspecs/linux-g++
+@dirrm share/qt4/mkspecs/linux-ecc-64
+@dirrm share/qt4/mkspecs/linux-cxx
+@dirrm share/qt4/mkspecs/irix-g++-64
+@dirrm share/qt4/mkspecs/irix-g++
+@dirrm share/qt4/mkspecs/irix-cc-64
+@dirrm share/qt4/mkspecs/irix-cc
+@dirrm share/qt4/mkspecs/hurd-g++
+@dirrm share/qt4/mkspecs/hpuxi-acc-64
+@dirrm share/qt4/mkspecs/hpuxi-acc
+@dirrm share/qt4/mkspecs/hpux-g++-64
+@dirrm share/qt4/mkspecs/hpux-g++
+@dirrm share/qt4/mkspecs/hpux-acc-o64
+@dirrm share/qt4/mkspecs/hpux-acc-64
+@dirrm share/qt4/mkspecs/hpux-acc
+@dirrm share/qt4/mkspecs/freebsd-icc
+@dirrm share/qt4/mkspecs/freebsd-g++40
+@dirrm share/qt4/mkspecs/freebsd-g++34
+@dirrm share/qt4/mkspecs/freebsd-g++
+@dirrm share/qt4/mkspecs/features/win32
+@dirrm share/qt4/mkspecs/features/unix
+@dirrm share/qt4/mkspecs/features/mac
+@dirrm share/qt4/mkspecs/features
+@dirrm share/qt4/mkspecs/darwin-g++
+@dirrm share/qt4/mkspecs/common
+@dirrm share/qt4/mkspecs/aix-xlc-64
+@dirrm share/qt4/mkspecs/aix-xlc
+@dirrm share/qt4/mkspecs/aix-g++-64
+@dirrm share/qt4/mkspecs/aix-g++
+@dirrm share/qt4/mkspecs
+@dirrm share/qt4
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%