aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qt4-assistant-adp
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
committermakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
commit8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5 (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /devel/qt4-assistant-adp
parent5b251e589961b796d7eafa23de894f129f92bf6d (diff)
downloadfreebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.gz
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.zst
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Diffstat (limited to 'devel/qt4-assistant-adp')
-rw-r--r--devel/qt4-assistant-adp/Makefile17
-rw-r--r--devel/qt4-assistant-adp/pkg-descr12
2 files changed, 7 insertions, 22 deletions
diff --git a/devel/qt4-assistant-adp/Makefile b/devel/qt4-assistant-adp/Makefile
index b86856e43d81..82300e650b59 100644
--- a/devel/qt4-assistant-adp/Makefile
+++ b/devel/qt4-assistant-adp/Makefile
@@ -4,7 +4,7 @@
PORTNAME= assistant
PORTVERSION= 4.6.3
PORTREVISION= 1
-CATEGORIES?= devel
+CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_QT}
MASTER_SITE_SUBDIR= archive/qt/${PORTVERSION:R}
PKGNAMEPREFIX= qt4-
@@ -13,15 +13,17 @@ DISTNAME= qt-assistant-qassistantclient-library-compat-src-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt documentation browser, adp compat version
+COMMENT= Qt *.adp-compatible documentation browser
-USE_QT4= qmake_build moc_build rcc_build uic_build corelib \
+USE_QT4= moc_build rcc_build uic_build corelib \
gui network xml doc dbus
+USES= qmake
+QMAKE_ARGS= QT_CONFIG+="dbus" QT_PRODUCT="OpenSource"
-# stage support
-DESTDIRNAME= INSTALL_ROOT
ALL_TARGET= first
+DESCR= ${.CURDIR:H:H}/devel/qt4/pkg-descr
+
WRKSRC= ${WRKDIR}/${DISTNAME:C/src/version/}
PLIST_FILES= bin/assistant_adp
@@ -30,9 +32,4 @@ pre-configure:
${REINPLACE_CMD} -e 's|$$$$\[QT_INSTALL_BINS]|${PREFIX}/bin|g' \
${WRKSRC}/compat.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} -spec ${QMAKESPEC} QT_CONFIG+="dbus" \
- QT_PRODUCT="OpenSource" ${QMAKEFLAGS}
-
.include <bsd.port.mk>
diff --git a/devel/qt4-assistant-adp/pkg-descr b/devel/qt4-assistant-adp/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/devel/qt4-assistant-adp/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html