aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qt4-assistant
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2008-03-14 01:57:19 +0800
committerlofi <lofi@FreeBSD.org>2008-03-14 01:57:19 +0800
commitb34f1dd1a8102c0f0750f0fe0381495064f9c2be (patch)
tree76ba9ea6482e72068c64ec0d1008eb470c9e716f /devel/qt4-assistant
parent7e59b3c8f3364f8e9916c8d219894da2c3941f44 (diff)
downloadfreebsd-ports-gnome-b34f1dd1a8102c0f0750f0fe0381495064f9c2be.tar.gz
freebsd-ports-gnome-b34f1dd1a8102c0f0750f0fe0381495064f9c2be.tar.zst
freebsd-ports-gnome-b34f1dd1a8102c0f0750f0fe0381495064f9c2be.zip
Update to Qt 4.3.4
Diffstat (limited to 'devel/qt4-assistant')
-rw-r--r--devel/qt4-assistant/Makefile2
-rw-r--r--devel/qt4-assistant/distinfo6
-rw-r--r--devel/qt4-assistant/files/patch-0185-fix-format-strings.diff55
3 files changed, 4 insertions, 59 deletions
diff --git a/devel/qt4-assistant/Makefile b/devel/qt4-assistant/Makefile
index b05bb67c85d8..45d05b5b2b71 100644
--- a/devel/qt4-assistant/Makefile
+++ b/devel/qt4-assistant/Makefile
@@ -20,7 +20,7 @@ COMMENT= Qt documentation browser
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build uic_build qt3support corelib \
- gui network sql xml doc
+ gui network sql xml doc dbus
QT_NONSTANDARD= yes
QT_DIST= yes
diff --git a/devel/qt4-assistant/distinfo b/devel/qt4-assistant/distinfo
index 8fbd772f627d..9451a68b5c02 100644
--- a/devel/qt4-assistant/distinfo
+++ b/devel/qt4-assistant/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.3.1.tar.gz) = ec255dcc2b30f5efe0ded85ae8a75e13
-SHA256 (KDE/qt-x11-opensource-src-4.3.1.tar.gz) = 4d59d0c74e4358ed59f11542403248687b04aa0c1bc06ea35b4b9e2cfc55e661
-SIZE (KDE/qt-x11-opensource-src-4.3.1.tar.gz) = 43118858
+MD5 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 9499101ec54eb7b0de195b3c5e3ffa93
+SHA256 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 8864dd80f3456be70a3be60364502a0ca3f46125b2f156860ad880ff55fcabd2
+SIZE (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 43988710
diff --git a/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff b/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff
deleted file mode 100644
index 43f4e0a9aaec..000000000000
--- a/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff
+++ /dev/null
@@ -1,55 +0,0 @@
---- tools/assistant/config.cpp
-+++ tools/assistant/config.cpp
-@@ -73,12 +73,12 @@ Config *Config::loadConfig(const QString
-
- QFile file(profileFileName);
- if (!file.exists()) {
-- qWarning( (QLatin1String("File does not exist: ") + profileFileName).toAscii().constData() );
-+ qWarning( "File does not exist: %s", qPrintable(profileFileName) );
- return 0;
- }
- DocuParser *parser = DocuParser::createParser( profileFileName );
- if (!parser) {
-- qWarning( (QLatin1String("Failed to create parser for file: ") + profileFileName).toAscii().constData() );
-+ qWarning( "Failed to create parser for file: %s", qPrintable(profileFileName) );
- return 0;
- }
- if (parser->parserVersion() < DocuParser::Qt320) {
-@@ -89,7 +89,7 @@ Config *Config::loadConfig(const QString
- parser->parse(&file);
- config->profil = profileParser->profile();
- if (!config->profil) {
-- qWarning( (QLatin1String("Config::loadConfig(), no profile in: ") + profileFileName).toAscii().constData() );
-+ qWarning( "Config::loadConfig(), no profile in: %s", qPrintable(profileFileName) );
- return 0;
- }
- config->profil->setProfileType(Profile::UserProfile);
---- tools/assistant/index.cpp
-+++ tools/assistant/index.cpp
-@@ -180,7 +180,7 @@ void Index::parseDocument( const QString
- {
- QFile file( filename );
- if ( !file.open(QFile::ReadOnly) ) {
-- qWarning( (QLatin1String("can not open file ") + filename).toAscii().constData() );
-+ qWarning( "can not open file %s", qPrintable(filename) );
- return;
- }
-
-@@ -352,7 +352,7 @@ QString Index::getDocumentTitle( const Q
-
- QFile file( fileName );
- if ( !file.open( QFile::ReadOnly ) ) {
-- qWarning( (QLatin1String("cannot open file ") + fileName).toAscii().constData() );
-+ qWarning( "cannot open file %s", qPrintable(fileName) );
- return fileName;
- }
- QTextStream s( &file );
-@@ -474,7 +474,7 @@ bool Index::searchForPattern( const QStr
- QString fName = url.toLocalFile();
- QFile file( fName );
- if ( !file.open( QFile::ReadOnly ) ) {
-- qWarning( (QLatin1String("cannot open file ") + fName).toAscii().constData() );
-+ qWarning( "cannot open file %s", qPrintable(fName) );
- return false;
- }
- \ No newline at end of file