aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qt4-assistant
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-07-31 05:53:10 +0800
committerlofi <lofi@FreeBSD.org>2007-07-31 05:53:10 +0800
commitce63eafe1e493850dfc6e2e4cac9c8ab0ca90864 (patch)
tree9698baa7a807c0adca8db2e689761ccbbdbe00a7 /devel/qt4-assistant
parentd64e61779e5c89be31f24a605ba762899ebd5b9b (diff)
downloadfreebsd-ports-gnome-ce63eafe1e493850dfc6e2e4cac9c8ab0ca90864.tar.gz
freebsd-ports-gnome-ce63eafe1e493850dfc6e2e4cac9c8ab0ca90864.tar.zst
freebsd-ports-gnome-ce63eafe1e493850dfc6e2e4cac9c8ab0ca90864.zip
Fix various format string vulnerabilities in Qt3 and Qt4.
Security: http://trolltech.com/company/newsroom/announcements/press.2007-07-27.750375 Security: CVE-2007-3388
Diffstat (limited to 'devel/qt4-assistant')
-rw-r--r--devel/qt4-assistant/Makefile3
-rw-r--r--devel/qt4-assistant/files/patch-0185-fix-format-strings.diff55
2 files changed, 57 insertions, 1 deletions
diff --git a/devel/qt4-assistant/Makefile b/devel/qt4-assistant/Makefile
index 2d7a925fdf79..023e78e550fe 100644
--- a/devel/qt4-assistant/Makefile
+++ b/devel/qt4-assistant/Makefile
@@ -8,7 +8,7 @@
PORTNAME= assistant
PORTVERSION= ${QT4_VERSION}
-PORTREVISION=0
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -42,6 +42,7 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
WRKSRC= ${WRKDIR}/${DISTNAME}/tools/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
+PATCH_WRKSRC=${CONFIGURE_WRKSRC}
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
diff --git a/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff b/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff
new file mode 100644
index 000000000000..43f4e0a9aaec
--- /dev/null
+++ b/devel/qt4-assistant/files/patch-0185-fix-format-strings.diff
@@ -0,0 +1,55 @@
+--- tools/assistant/config.cpp
++++ tools/assistant/config.cpp
+@@ -73,12 +73,12 @@ Config *Config::loadConfig(const QString
+
+ QFile file(profileFileName);
+ if (!file.exists()) {
+- qWarning( (QLatin1String("File does not exist: ") + profileFileName).toAscii().constData() );
++ qWarning( "File does not exist: %s", qPrintable(profileFileName) );
+ return 0;
+ }
+ DocuParser *parser = DocuParser::createParser( profileFileName );
+ if (!parser) {
+- qWarning( (QLatin1String("Failed to create parser for file: ") + profileFileName).toAscii().constData() );
++ qWarning( "Failed to create parser for file: %s", qPrintable(profileFileName) );
+ return 0;
+ }
+ if (parser->parserVersion() < DocuParser::Qt320) {
+@@ -89,7 +89,7 @@ Config *Config::loadConfig(const QString
+ parser->parse(&file);
+ config->profil = profileParser->profile();
+ if (!config->profil) {
+- qWarning( (QLatin1String("Config::loadConfig(), no profile in: ") + profileFileName).toAscii().constData() );
++ qWarning( "Config::loadConfig(), no profile in: %s", qPrintable(profileFileName) );
+ return 0;
+ }
+ config->profil->setProfileType(Profile::UserProfile);
+--- tools/assistant/index.cpp
++++ tools/assistant/index.cpp
+@@ -180,7 +180,7 @@ void Index::parseDocument( const QString
+ {
+ QFile file( filename );
+ if ( !file.open(QFile::ReadOnly) ) {
+- qWarning( (QLatin1String("can not open file ") + filename).toAscii().constData() );
++ qWarning( "can not open file %s", qPrintable(filename) );
+ return;
+ }
+
+@@ -352,7 +352,7 @@ QString Index::getDocumentTitle( const Q
+
+ QFile file( fileName );
+ if ( !file.open( QFile::ReadOnly ) ) {
+- qWarning( (QLatin1String("cannot open file ") + fileName).toAscii().constData() );
++ qWarning( "cannot open file %s", qPrintable(fileName) );
+ return fileName;
+ }
+ QTextStream s( &file );
+@@ -474,7 +474,7 @@ bool Index::searchForPattern( const QStr
+ QString fName = url.toLocalFile();
+ QFile file( fName );
+ if ( !file.open( QFile::ReadOnly ) ) {
+- qWarning( (QLatin1String("cannot open file ") + fName).toAscii().constData() );
++ qWarning( "cannot open file %s", qPrintable(fName) );
+ return false;
+ }
+ \ No newline at end of file