aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qt4-qvfb
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
committermakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
commit8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5 (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /devel/qt4-qvfb
parent5b251e589961b796d7eafa23de894f129f92bf6d (diff)
downloadfreebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.gz
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.zst
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Diffstat (limited to 'devel/qt4-qvfb')
-rw-r--r--devel/qt4-qvfb/Makefile25
-rw-r--r--devel/qt4-qvfb/pkg-descr12
-rw-r--r--devel/qt4-qvfb/pkg-plist4
3 files changed, 14 insertions, 27 deletions
diff --git a/devel/qt4-qvfb/Makefile b/devel/qt4-qvfb/Makefile
index c93b11156490..88c0837d78f7 100644
--- a/devel/qt4-qvfb/Makefile
+++ b/devel/qt4-qvfb/Makefile
@@ -3,14 +3,14 @@
PORTNAME= qvfb
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= devel
+PORTREVISION= 1
+CATEGORIES= devel
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt virtual framebuffer utility
+COMMENT= Qt 4 virtual framebuffer utility
USE_QT4= qmake_build moc_build rcc_build uic_build corelib gui opengl
-QT_NONSTANDARD= yes
QT_DIST= yes
USE_XORG= xtst
@@ -21,9 +21,10 @@ CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
-DESKTOP_ENTRIES="Qt Virtual Framebuffer" "${COMMENT}" \
+DESKTOP_ENTRIES="Qt 4 Virtual Framebuffer" "" \
"${PREFIX}/share/pixmaps/qvfb-qt4.png" \
- "${PREFIX}/bin/qvfb-qt4" "Development;Qt;" true
+ "${PREFIX}/${QT_BINDIR_REL}/qvfb${_QT_BINSUFX}" \
+ "Development;Qt;" true
DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/activeqt src/dbus src/multimedia src/network src/opengl \
@@ -42,19 +43,17 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
CONFIGURE_ARGS+= -I../../include/Qt -I../../include
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
- ${REINPLACE_CMD} -e 's|^TARGET.*|TARGET=qvfb-qt4|g' \
+ ${REINPLACE_CMD} -e 's|^TARGET.*|TARGET=qvfb${_QT_BINSUFX}|g' \
${BUILD_WRKSRC}/qvfb.pro
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+ ${LN} -sf ${MOC} ${WRKSRC}/bin/moc
+ ${LN} -sf ${UIC} ${WRKSRC}/bin/uic
+ ${LN} -sf ${RCC} ${WRKSRC}/bin/rcc
post-install:
- ${INSTALL_DATA} ${BUILD_WRKSRC}/images/logo.png \
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/images/logo.png \
${STAGEDIR}${PREFIX}/share/pixmaps/qvfb-qt4.png
.include <bsd.port.mk>
diff --git a/devel/qt4-qvfb/pkg-descr b/devel/qt4-qvfb/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/devel/qt4-qvfb/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/devel/qt4-qvfb/pkg-plist b/devel/qt4-qvfb/pkg-plist
index 82a3c289ac7d..63d627ba7965 100644
--- a/devel/qt4-qvfb/pkg-plist
+++ b/devel/qt4-qvfb/pkg-plist
@@ -1,3 +1,3 @@
-bin/qvfb-qt4
-%%DEBUG%%bin/qvfb-qt4.debug
+%%QT_BINDIR%%/qvfb-qt4
+%%DEBUG%%%%QT_BINDIR%%/qvfb-qt4.debug
share/pixmaps/qvfb-qt4.png