aboutsummaryrefslogtreecommitdiffstats
path: root/devel/renpy
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-10-31 03:22:19 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:51:00 +0800
commit0857f885022e6dc0b6e2b102f8b0d6b44b04f21c (patch)
tree0da376c60e6ae1334b31df57c7c629c649d78766 /devel/renpy
parente672f85886e0b7faa42cc348d79f18a428cc41b0 (diff)
downloadfreebsd-ports-gnome-0857f885022e6dc0b6e2b102f8b0d6b44b04f21c.tar.gz
freebsd-ports-gnome-0857f885022e6dc0b6e2b102f8b0d6b44b04f21c.tar.zst
freebsd-ports-gnome-0857f885022e6dc0b6e2b102f8b0d6b44b04f21c.zip
devel/renpy6: unbreak after r453203
find: tutorial/recrop.py: No such file or directory find: oldtutorial: No such file or directory
Diffstat (limited to 'devel/renpy')
-rw-r--r--devel/renpy/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/renpy/Makefile b/devel/renpy/Makefile
index 6d7ac47b127e..d5d29ab73a53 100644
--- a/devel/renpy/Makefile
+++ b/devel/renpy/Makefile
@@ -35,9 +35,12 @@ USE_PYTHON= autoplist distutils
USE_SDL?= sdl2
EXCLUDE= gen 'module/*.py[co]' 'renpy/*.py[co]'
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
+SHEBANG_FILES= renpy.py launcher/game/tkaskdir.py
+.ifndef PKGNAMESUFFIX
python3_CMD?= ${PYTHON_CMD}
SHEBANG_LANG= python3
-SHEBANG_FILES= renpy.py launcher/game/tkaskdir.py tutorial/recrop.py
+SHEBANG_FILES+= tutorial/recrop.py
+.endif
TARGET_ORDER_OVERRIDE=610:fix-shebang
BUILD_WRKSRC= ${WRKSRC}/module
INSTALL_WRKSRC= ${BUILD_WRKSRC}
@@ -59,7 +62,10 @@ OPTIONS_DEFINE= DOCS DIST EXAMPLES TKINTER
DIST_DESC= Distribution runtimes for Windows, OS X, Linux
DIST_VARS= LICENSE+="ART20 PSFL" \
PORTDATA+="lib renpy.app renpy.exe renpy.sh"
-EXAMPLES_VARS= PORTDATA+="oldtutorial the_question tutorial"
+EXAMPLES_VARS= PORTDATA+="the_question tutorial"
+.ifndef PKGNAMESUFFIX
+EXAMPLES_VARS+= PORTDATA+="oldtutorial"
+.endif
TKINTER_DESC= Install Tkinter to allow choosing Projects Directory
TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter