aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-cvs/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
committerknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
commit9c46f078394d114e50ad01ff921a88b74dda7eb1 (patch)
tree4810246f6e2ebdc6787c76cd4552ffabb88ae682 /devel/ruby-cvs/Makefile
parent1900d9b4804ade641a7bbef2252af134e5f2ba8f (diff)
downloadfreebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.gz
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.zst
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.zip
Introduce a knob RUBY_NO_RD_HTML and enable it by default on alpha. This
replaces the non-working NOPORTDOCS workaround and fixes build on the alpha, where rd2 coredumps. Tested on: the axp cluster Approved by: kris
Diffstat (limited to 'devel/ruby-cvs/Makefile')
-rw-r--r--devel/ruby-cvs/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/devel/ruby-cvs/Makefile b/devel/ruby-cvs/Makefile
index 262ad66b8706..25b07fcd6b1f 100644
--- a/devel/ruby-cvs/Makefile
+++ b/devel/ruby-cvs/Makefile
@@ -19,23 +19,29 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/flex.so:${PORTSDIR}/devel/ruby-flex_rb
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+NO_BUILD= yes
+
+RUBY_RD_FILES= cvs.rb diff.rb tempdir.rb
RUBY_SHEBANG_FILES= ${WRKSRC}/viztree ${WRKSRC}/reviz/reviz
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
-DOCS= README TODO cvs.html diff.html tempdir.html
+DOCS= README TODO ${RUBY_RD_HTML_FILES}
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} lib/cvs.rb > cvs.html
- cd ${WRKSRC}; ${RUBY_RD2} lib/diff.rb > diff.html
- cd ${WRKSRC}; ${RUBY_RD2} lib/tempdir.rb > tempdir.html
-.endif
+post-extract:
+.for f in ${RUBY_RD_FILES}
+ cd ${WRKSRC}; ${LN} -sf lib/${f}
+.endfor
do-install:
${CP} -R ${WRKSRC}/lib/* ${RUBY_SITELIBDIR}/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}/reviz
${INSTALL_DATA} ${WRKSRC}/viztree ${RUBY_MODEXAMPLESDIR}/
@@ -45,5 +51,3 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>