aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-gems
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-20 21:49:01 +0800
committerpav <pav@FreeBSD.org>2005-07-20 21:49:01 +0800
commit8c50c53120baa0ed30f72e3814133de9adde8de7 (patch)
treecb1a76424ce79e7463fc93385ba37535810951ff /devel/ruby-gems
parentb0901213a816f45b1a496d30d8074fd20742d396 (diff)
downloadfreebsd-ports-gnome-8c50c53120baa0ed30f72e3814133de9adde8de7.tar.gz
freebsd-ports-gnome-8c50c53120baa0ed30f72e3814133de9adde8de7.tar.zst
freebsd-ports-gnome-8c50c53120baa0ed30f72e3814133de9adde8de7.zip
- Add a common infrastructure for porting rubygems. It can be used by
including this file between bsd.port.pre.mk and bsd.port.post.mk in similar way PEAR modules are ported now. PR: ports/82397 Submitted by: Jonathan Weiss <jw@innerewut.de>
Diffstat (limited to 'devel/ruby-gems')
-rw-r--r--devel/ruby-gems/Makefile.common37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
new file mode 100644
index 000000000000..927d1583c65c
--- /dev/null
+++ b/devel/ruby-gems/Makefile.common
@@ -0,0 +1,37 @@
+# $FreeBSD$
+# Ruby gem module common settings
+
+
+BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+PKGNAMEPREFIX= rubygem-
+EXTRACT_SUFX= .gem
+NO_EXTRACT= YES
+DIST_SUBDIR= rubygem
+
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+REV= 1.8
+GEMS_BASE_DIR= lib/ruby/gems/${REV}
+GEMS_DIR= ${GEMS_BASE_DIR}/gems
+DOC_DIR= ${GEMS_BASE_DIR}/doc
+CACHE_DIR= ${GEMS_BASE_DIR}/cache
+SPEC_DIR= ${GEMS_BASE_DIR}/specifications
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
+ REV="${REV}" \
+ GEMS_BASE_DIR="lib/ruby/gems/${REV}" \
+ GEMS_DIR="${GEMS_BASE_DIR}/gems" \
+ DOC_DIR="${GEMS_BASE_DIR}/doc" \
+ CACHE_DIR="${GEMS_BASE_DIR}/cache" \
+ SPEC_DIR="${GEMS_BASE_DIR}/specifications" \
+ PORT="${PORTNAME}-${PORTVERSION}" \
+ EXTRACT_SUFX="${EXTRACT_SUFX}"
+
+RUBYGEMBIN= ${LOCALBASE}/bin/gem
+
+do-install:
+ ${RUBYGEMBIN} install --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}