aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-glib2
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-11-28 04:12:16 +0800
committerknu <knu@FreeBSD.org>2002-11-28 04:12:16 +0800
commit1aa18cd213323b9463cad2ddbcc0b3532575f4a8 (patch)
treebb8d9057e28867f7402e8c9d6290c2d636d5f4c0 /devel/ruby-glib2
parentbd88ec32ce494cefd0e13084bc1d2a678f286e06 (diff)
downloadfreebsd-ports-gnome-1aa18cd213323b9463cad2ddbcc0b3532575f4a8.tar.gz
freebsd-ports-gnome-1aa18cd213323b9463cad2ddbcc0b3532575f4a8.tar.zst
freebsd-ports-gnome-1aa18cd213323b9463cad2ddbcc0b3532575f4a8.zip
Import Ruby/GNOME2 0.1 ports.
Newly added are devel/ruby-glib2 and graphics/ruby-gnomecanvas2, the rest are updated after repocopy. Approved by: portmgr (implicitly)
Diffstat (limited to 'devel/ruby-glib2')
-rw-r--r--devel/ruby-glib2/Makefile40
-rw-r--r--devel/ruby-glib2/pkg-comment1
-rw-r--r--devel/ruby-glib2/pkg-descr3
-rw-r--r--devel/ruby-glib2/pkg-plist4
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/ruby-glib2/Makefile b/devel/ruby-glib2/Makefile
new file mode 100644
index 000000000000..c35fe6f31905
--- /dev/null
+++ b/devel/ruby-glib2/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby/GLib2
+# Date created: 24 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glib2
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= x11-toolkits ruby
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/glib
+INSTALL_TARGET= site-install
+
+DOCS= ChangeLog \
+ README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-glib2/pkg-comment b/devel/ruby-glib2/pkg-comment
new file mode 100644
index 000000000000..b89c5841256b
--- /dev/null
+++ b/devel/ruby-glib2/pkg-comment
@@ -0,0 +1 @@
+Ruby binding for GLib2
diff --git a/devel/ruby-glib2/pkg-descr b/devel/ruby-glib2/pkg-descr
new file mode 100644
index 000000000000..920d97c2126d
--- /dev/null
+++ b/devel/ruby-glib2/pkg-descr
@@ -0,0 +1,3 @@
+Ruby/GLib2 is a Ruby binding for GLib2.
+
+WWW: http://ruby-gnome2.sourceforge.net/
diff --git a/devel/ruby-glib2/pkg-plist b/devel/ruby-glib2/pkg-plist
new file mode 100644
index 000000000000..aa02793ba5e3
--- /dev/null
+++ b/devel/ruby-glib2/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITEARCHLIBDIR%%/glib2.so
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%