aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-gnomevfs
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-03-12 19:05:18 +0800
committermezz <mezz@FreeBSD.org>2005-03-12 19:05:18 +0800
commitd518f80dc208ca5cfc3977ffcd7b9980df98eacf (patch)
tree631d8a392e2260b38227e09139ea9c432f755f4a /devel/ruby-gnomevfs
parent6cd4f98b305f25abf152ac61bd5ab8d1977b27a9 (diff)
downloadfreebsd-ports-gnome-d518f80dc208ca5cfc3977ffcd7b9980df98eacf.tar.gz
freebsd-ports-gnome-d518f80dc208ca5cfc3977ffcd7b9980df98eacf.tar.zst
freebsd-ports-gnome-d518f80dc208ca5cfc3977ffcd7b9980df98eacf.zip
-Update to 0.12.0, works with GTK 2.6/GNOME 2.10.
http://ruby-gnome2.sourceforge.jp/hiki.cgi?News_20050306_1 -A few clean up such as correct paths, dependencies and etc.
Diffstat (limited to 'devel/ruby-gnomevfs')
-rw-r--r--devel/ruby-gnomevfs/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/ruby-gnomevfs/Makefile b/devel/ruby-gnomevfs/Makefile
index 4159e8b9ee35..2bcfa3cc180d 100644
--- a/devel/ruby-gnomevfs/Makefile
+++ b/devel/ruby-gnomevfs/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
USE_RUBY= yes
USE_GNOME= gnomevfs2
+USE_REINPLACE= yes
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
@@ -30,6 +31,11 @@ INSTALL_TARGET= site-install
DOCS= COPYING.LIB ChangeLog README
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/ruby -w|/bin/env ruby|g' \
+ ${WRKSRC}/tests/*.rb
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${RUBY_MODEXAMPLESDIR}