aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-mmap/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-08 03:12:08 +0800
committerknu <knu@FreeBSD.org>2001-03-08 03:12:08 +0800
commit1311d96209ea04c633e41b077a0f2bf9dc76db36 (patch)
treef0c5668771ae66bbbcef16a1f72cc27489da6b04 /devel/ruby-mmap/Makefile
parentf091d556c3ae0b6bd4079d367a235af7cf68771a (diff)
downloadfreebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.tar.gz
freebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.tar.zst
freebsd-ports-gnome-1311d96209ea04c633e41b077a0f2bf9dc76db36.zip
Add ruby-mmap, a Ruby interface to manage memory-mapped file objects.
Diffstat (limited to 'devel/ruby-mmap/Makefile')
-rw-r--r--devel/ruby-mmap/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
new file mode 100644
index 000000000000..343ccabe7baf
--- /dev/null
+++ b/devel/ruby-mmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-Mmap
+# Date created: 8 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mmap
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ftp://moulon.inra.fr/pub/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README.en mmap.html mmap.rd
+EXAMPLES= aa b.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>