aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-mmap
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
committerknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
commit9c46f078394d114e50ad01ff921a88b74dda7eb1 (patch)
tree4810246f6e2ebdc6787c76cd4552ffabb88ae682 /devel/ruby-mmap
parent1900d9b4804ade641a7bbef2252af134e5f2ba8f (diff)
downloadfreebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.gz
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.zst
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.zip
Introduce a knob RUBY_NO_RD_HTML and enable it by default on alpha. This
replaces the non-working NOPORTDOCS workaround and fixes build on the alpha, where rd2 coredumps. Tested on: the axp cluster Approved by: kris
Diffstat (limited to 'devel/ruby-mmap')
-rw-r--r--devel/ruby-mmap/Makefile19
-rw-r--r--devel/ruby-mmap/pkg-plist2
2 files changed, 13 insertions, 8 deletions
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
index cf6b2271eb62..26d9acc95340 100644
--- a/devel/ruby-mmap/Makefile
+++ b/devel/ruby-mmap/Makefile
@@ -20,25 +20,30 @@ BUILD_DEPENDS= rdoc:${PORTSDIR}/textproc/ruby-rdoc
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
+
+RUBY_RD_FILES= mmap.rd
INSTALL_TARGET= site-install
-DOCS= Changes README.en mmap.html mmap.rd \
+DOCS= Changes \
+ README.en \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES} \
docs/doc
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} mmap.rd > mmap.html
- cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; rdoc mmap.rb
+ cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; ${RUBY_RDOC} mmap.rb
.endif
-post-install:
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-mmap/pkg-plist b/devel/ruby-mmap/pkg-plist
index 01f7113ef980..f174228f331e 100644
--- a/devel/ruby-mmap/pkg-plist
+++ b/devel/ruby-mmap/pkg-plist
@@ -1,7 +1,7 @@
%%RUBY_SITEARCHLIBDIR%%/mmap.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Changes
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/mmap.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/mmap.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/mmap.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/Mmap.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/Mmap.src/M000001.html