aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-optparse
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-09-07 15:23:43 +0800
committerknu <knu@FreeBSD.org>2000-09-07 15:23:43 +0800
commit9770f1a3791f7fa3eb1b603ae606cfbdf8ad3366 (patch)
treec560e2f165d77beeafb3272d12cdaad524eac5a9 /devel/ruby-optparse
parentc445f4c6847963711cc78c1f76d999f84099dbd6 (diff)
downloadfreebsd-ports-gnome-9770f1a3791f7fa3eb1b603ae606cfbdf8ad3366.tar.gz
freebsd-ports-gnome-9770f1a3791f7fa3eb1b603ae606cfbdf8ad3366.tar.zst
freebsd-ports-gnome-9770f1a3791f7fa3eb1b603ae606cfbdf8ad3366.zip
Update fundamental ruby ports first with bsd.ruby.mk.
Diffstat (limited to 'devel/ruby-optparse')
-rw-r--r--devel/ruby-optparse/Makefile31
-rw-r--r--devel/ruby-optparse/pkg-plist30
2 files changed, 28 insertions, 33 deletions
diff --git a/devel/ruby-optparse/Makefile b/devel/ruby-optparse/Makefile
index dd2405155605..612402472411 100644
--- a/devel/ruby-optparse/Makefile
+++ b/devel/ruby-optparse/Makefile
@@ -9,42 +9,37 @@ PORTNAME= optparse
PORTVERSION= 0.7.5
CATEGORIES= devel ruby
MASTER_SITES= http://member.nifty.ne.jp/nokada/archive/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
NO_BUILD= yes
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
do-install:
- ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/optparse
+ ${MKDIR} ${RUBY_SITELIBDIR}/optparse
.for f in optparse.rb optparse/shellwords.rb optparse/time.rb
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/${f}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_SITELIBDIR}/${f}
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/optparse/ja
- ${MKDIR} ${PREFIX}/share/doc/ruby/optparse/ja
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/optparse/ja
+ ${MKDIR} ${RUBY_DOCDIR}/optparse/ja
.for f in optparse.rlog
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/optparse/
.endfor
.for f in optparse.ja.rd
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/optparse/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/optparse/ja/
.endfor
.for f in cmd-ls.rb cmd.rb getopts.test.en opttest.rb
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/optparse/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/optparse/
.endfor
.for f in getopts.test
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/optparse/ja
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/optparse/ja
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-optparse/pkg-plist b/devel/ruby-optparse/pkg-plist
index d05a1b66a99c..5dbbf8c74ef1 100644
--- a/devel/ruby-optparse/pkg-plist
+++ b/devel/ruby-optparse/pkg-plist
@@ -1,15 +1,15 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/optparse/shellwords.rb
-lib/ruby/site_ruby/%%RUBY_VER%%/optparse/time.rb
-lib/ruby/site_ruby/%%RUBY_VER%%/optparse.rb
-@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/optparse
-share/examples/ruby/optparse/ja/getopts.test
-share/examples/ruby/optparse/cmd-ls.rb
-share/examples/ruby/optparse/cmd.rb
-share/examples/ruby/optparse/getopts.test.en
-share/examples/ruby/optparse/opttest.rb
-share/doc/ruby/optparse/ja/optparse.ja.rd
-share/doc/ruby/optparse/optparse.rlog
-@dirrm share/examples/ruby/optparse/ja
-@dirrm share/examples/ruby/optparse
-@dirrm share/doc/ruby/optparse/ja
-@dirrm share/doc/ruby/optparse
+%%RUBY_SITELIBDIR%%/optparse/shellwords.rb
+%%RUBY_SITELIBDIR%%/optparse/time.rb
+%%RUBY_SITELIBDIR%%/optparse.rb
+@dirrm %%RUBY_SITELIBDIR%%/optparse
+%%RUBY_EXAMPLESDIR%%/optparse/ja/getopts.test
+%%RUBY_EXAMPLESDIR%%/optparse/cmd-ls.rb
+%%RUBY_EXAMPLESDIR%%/optparse/cmd.rb
+%%RUBY_EXAMPLESDIR%%/optparse/getopts.test.en
+%%RUBY_EXAMPLESDIR%%/optparse/opttest.rb
+%%RUBY_DOCDIR%%/optparse/ja/optparse.ja.rd
+%%RUBY_DOCDIR%%/optparse/optparse.rlog
+@dirrm %%RUBY_EXAMPLESDIR%%/optparse/ja
+@dirrm %%RUBY_EXAMPLESDIR%%/optparse
+@dirrm %%RUBY_DOCDIR%%/optparse/ja
+@dirrm %%RUBY_DOCDIR%%/optparse