aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-optparse
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /devel/ruby-optparse
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'devel/ruby-optparse')
-rw-r--r--devel/ruby-optparse/Makefile16
-rw-r--r--devel/ruby-optparse/pkg-descr3
-rw-r--r--devel/ruby-optparse/pkg-plist8
3 files changed, 15 insertions, 12 deletions
diff --git a/devel/ruby-optparse/Makefile b/devel/ruby-optparse/Makefile
index 3b0709caef60..5686fd3f09cb 100644
--- a/devel/ruby-optparse/Makefile
+++ b/devel/ruby-optparse/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby-OptionParser
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby-OptionParser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -21,14 +21,14 @@ NO_BUILD= yes
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
do-install:
- ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/optparse
+ ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/optparse
.for f in optparse.rb optparse/shellwords.rb optparse/time.rb
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${f}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/${f}
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/optparse/ja
diff --git a/devel/ruby-optparse/pkg-descr b/devel/ruby-optparse/pkg-descr
index be0473d5854b..a0f4e3c7fd58 100644
--- a/devel/ruby-optparse/pkg-descr
+++ b/devel/ruby-optparse/pkg-descr
@@ -6,3 +6,6 @@ Features:
* can emit options' summaries
* can add options on the fly
* completion for option/argument
+
+Author: Nobuyoshi.Nakada <nobu.nokada@softhome.net>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=OptionParser \ No newline at end of file
diff --git a/devel/ruby-optparse/pkg-plist b/devel/ruby-optparse/pkg-plist
index c2c979696251..d05a1b66a99c 100644
--- a/devel/ruby-optparse/pkg-plist
+++ b/devel/ruby-optparse/pkg-plist
@@ -1,7 +1,7 @@
-lib/ruby/site_ruby/optparse/shellwords.rb
-lib/ruby/site_ruby/optparse/time.rb
-lib/ruby/site_ruby/optparse.rb
-@dirrm lib/ruby/site_ruby/optparse
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse/shellwords.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse/time.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/optparse.rb
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/optparse
share/examples/ruby/optparse/ja/getopts.test
share/examples/ruby/optparse/cmd-ls.rb
share/examples/ruby/optparse/cmd.rb