aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-p4/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-08-16 02:40:47 +0800
committerknu <knu@FreeBSD.org>2003-08-16 02:40:47 +0800
commitab23820a944c0c3d984061ee40d655e528d2424c (patch)
tree8a8851e979b5afd73f5ec5d24ca7170b098c5d97 /devel/ruby-p4/Makefile
parent69cb054b3e2766f47c5dce370dbb88f96bf12d5e (diff)
downloadfreebsd-ports-gnome-ab23820a944c0c3d984061ee40d655e528d2424c.tar.gz
freebsd-ports-gnome-ab23820a944c0c3d984061ee40d655e528d2424c.tar.zst
freebsd-ports-gnome-ab23820a944c0c3d984061ee40d655e528d2424c.zip
Add ruby-p4 (P4Ruby), Ruby interface to the Perforce API.
Diffstat (limited to 'devel/ruby-p4/Makefile')
-rw-r--r--devel/ruby-p4/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/devel/ruby-p4/Makefile b/devel/ruby-p4/Makefile
new file mode 100644
index 000000000000..1dd2f9b41330
--- /dev/null
+++ b/devel/ruby-p4/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: P4Ruby
+# Date created: 16 August 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p4
+PORTVERSION= 1.3578
+CATEGORIES= devel ruby
+MASTER_SITES= http://public.perforce.com/guest/tony_smith/perforce/API/Ruby/release/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:U}Ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby interface to the Perforce API
+
+EXTRACT_DEPENDS= ${LOCALBASE}/lib/perforce/libclient.a:${PORTSDIR}/devel/p4api
+
+USE_RUBY= yes
+
+P4APIVER= 2003.01
+P4APIDIR= ${WRKDIR}/p4api
+INSTALL_TARGET= site-install
+
+EXAMPLES= example.rb
+
+DOCS= Changes \
+ doc/*
+
+post-extract:
+ ${MKDIR} ${P4APIDIR}
+ ${LN} -s ${LOCALBASE}/include/perforce/*.h ${P4APIDIR}/
+ ${LN} -s ${LOCALBASE}/lib/perforce/*.a ${P4APIDIR}/
+
+do-configure:
+ cd ${WRKSRC}; ${RUBY} p4conf.rb --apidir="${P4APIDIR}" --apiver="${P4APIVER}"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>