aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-sdl/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-27 02:05:55 +0800
committerknu <knu@FreeBSD.org>2001-03-27 02:05:55 +0800
commitd83fec5738c3fb104034699ac89941de2a4d1acb (patch)
tree5d86a1b32688c6508fd9283dbedb2d1e14a167ac /devel/ruby-sdl/Makefile
parent498498a22c498c27c6698e7203df12dee43ec190 (diff)
downloadfreebsd-ports-gnome-d83fec5738c3fb104034699ac89941de2a4d1acb.tar.gz
freebsd-ports-gnome-d83fec5738c3fb104034699ac89941de2a4d1acb.tar.zst
freebsd-ports-gnome-d83fec5738c3fb104034699ac89941de2a4d1acb.zip
Oops. The libc_r weirdness of 4-STABLE and prior prevents this from
working. Mark as broken for systems < 500018.
Diffstat (limited to 'devel/ruby-sdl/Makefile')
-rw-r--r--devel/ruby-sdl/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index a1d67870f231..4f2e88e9e13c 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= devel graphics audio ruby
MASTER_SITES= http://www.kmc.kyoto-u.ac.jp/~ohai/rubysdl/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -23,9 +24,16 @@ LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-CONFIGURE_ARGS= --with-sdl-config="sdl11-config"
+CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
+ --with-cflags="-pthread" \
+ --with-ldflags="-lc_r"
INSTALL_TARGET= site-install
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500018
+BROKEN= "libc_r conflicts with libc on your system. (Ruby/SDL can be used on 5-CURRENT only)"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
@@ -34,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>