aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-slang/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-28 00:52:51 +0800
committerknu <knu@FreeBSD.org>2000-08-28 00:52:51 +0800
commit87bb6d5b26b454f303ea18048a3ae258c6a90612 (patch)
tree8e485234214af003ac54cba7bb701d704a65188b /devel/ruby-slang/Makefile
parentf79ce80cfb927caf5219af96649042f14597269f (diff)
downloadfreebsd-ports-gnome-87bb6d5b26b454f303ea18048a3ae258c6a90612.tar.gz
freebsd-ports-gnome-87bb6d5b26b454f303ea18048a3ae258c6a90612.tar.zst
freebsd-ports-gnome-87bb6d5b26b454f303ea18048a3ae258c6a90612.zip
Back out the previous commit. That one has a problem which occurs on
cross-language master-slave ports. I just wonder how I could overlook this. I thought I tested with Wnn, netscape and so on. *sigh* Yes, I know how I can fix it, but I'd certainly back out first. Reported by: steve Pointy hat to: knu
Diffstat (limited to 'devel/ruby-slang/Makefile')
-rw-r--r--devel/ruby-slang/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/ruby-slang/Makefile b/devel/ruby-slang/Makefile
index 497a78429ff0..729dfdcdd20a 100644
--- a/devel/ruby-slang/Makefile
+++ b/devel/ruby-slang/Makefile
@@ -9,7 +9,6 @@ PORTNAME= slang
PORTVERSION= 0.33.a
CATEGORIES+= devel ruby
MASTER_SITES= http://kondara.sdri.co.jp/~kikutani/
-PKGNAMEPREFIX= ruby-
DISTNAME= ${PORTNAME}lib
DIST_SUBDIR= ruby
@@ -40,6 +39,12 @@ DOCS_JA= README.euc
.include <bsd.port.pre.mk>
+.if defined(PKGNAMEPREFIX)
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}ruby-
+.else
+PKGNAMEPREFIX= ruby-
+.endif
+
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}