aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-textbuf
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-10-11 16:32:54 +0800
committerclsung <clsung@FreeBSD.org>2006-10-11 16:32:54 +0800
commit3aaad8617b8032d27b3b9a5a517cba4f7e5cc609 (patch)
tree017d7c36e396923fe9a7e942f44966306cbc42ff /devel/ruby-textbuf
parent8284544093d3a9bd9175f18c860ee1affd910e46 (diff)
downloadfreebsd-ports-gnome-3aaad8617b8032d27b3b9a5a517cba4f7e5cc609.tar.gz
freebsd-ports-gnome-3aaad8617b8032d27b3b9a5a517cba4f7e5cc609.tar.zst
freebsd-ports-gnome-3aaad8617b8032d27b3b9a5a517cba4f7e5cc609.zip
- unbreak it by removing RUBY_VER= 16 and adding a patch
Approved by: portmgr (erwin)
Diffstat (limited to 'devel/ruby-textbuf')
-rw-r--r--devel/ruby-textbuf/Makefile6
-rw-r--r--devel/ruby-textbuf/files/patch-ext-textbuf-sftextbuf.c18
2 files changed, 18 insertions, 6 deletions
diff --git a/devel/ruby-textbuf/Makefile b/devel/ruby-textbuf/Makefile
index dbde82962182..28905234eea1 100644
--- a/devel/ruby-textbuf/Makefile
+++ b/devel/ruby-textbuf/Makefile
@@ -17,10 +17,6 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= Gapped text buffer extention for Ruby
-BROKEN= Inconsistent dependencies
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
USE_RUBY= yes
USE_RUBY_AMSTD= yes
USE_RUBY_SETUP= yes
@@ -28,8 +24,6 @@ USE_RUBY_SETUP= yes
DOCS_EN= README.en
DOCS_JA= README.ja
-RUBY_VER= 1.6
-
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}/ja
diff --git a/devel/ruby-textbuf/files/patch-ext-textbuf-sftextbuf.c b/devel/ruby-textbuf/files/patch-ext-textbuf-sftextbuf.c
new file mode 100644
index 000000000000..5bf99a4a1d7f
--- /dev/null
+++ b/devel/ruby-textbuf/files/patch-ext-textbuf-sftextbuf.c
@@ -0,0 +1,18 @@
+--- ext/textbuf/sftextbuf.c.orig Thu Mar 15 01:30:08 2001
++++ ext/textbuf/sftextbuf.c Wed Oct 11 09:07:55 2006
+@@ -1158,7 +1158,6 @@
+ OBJSETUP(str, rb_cString, T_STRING);
+ str->ptr = 0;
+ str->len = 0;
+- str->orig = 0;
+ OBJ_FREEZE(str);
+
+ CRITICAL_BEGIN(buf);
+@@ -1199,7 +1198,6 @@
+ OBJSETUP(str, rb_cString, T_STRING);
+ str->ptr = 0;
+ str->len = 0;
+- str->orig = 0;
+ OBJ_FREEZE(str);
+
+ CRITICAL_BEGIN(buf);