aboutsummaryrefslogtreecommitdiffstats
path: root/devel/rudiments
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-25 00:25:53 +0800
committermiwi <miwi@FreeBSD.org>2012-03-25 00:25:53 +0800
commit2d9ae7b6bed8634fc0d970ea04032373951eac1b (patch)
tree7af9be7f313626a0785fbcff8b584bb4d3b28840 /devel/rudiments
parent756fdcf435508cfd558a8b1d1b4bc711faf67e05 (diff)
downloadfreebsd-ports-gnome-2d9ae7b6bed8634fc0d970ea04032373951eac1b.tar.gz
freebsd-ports-gnome-2d9ae7b6bed8634fc0d970ea04032373951eac1b.tar.zst
freebsd-ports-gnome-2d9ae7b6bed8634fc0d970ea04032373951eac1b.zip
- Update to 0.35
PR: 166024 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'devel/rudiments')
-rw-r--r--devel/rudiments/Makefile42
-rw-r--r--devel/rudiments/distinfo4
-rw-r--r--devel/rudiments/files/patch-Makefile38
-rw-r--r--devel/rudiments/files/patch-configure24
-rw-r--r--devel/rudiments/files/patch-src-Makefile11
-rw-r--r--devel/rudiments/pkg-plist8
6 files changed, 40 insertions, 87 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index a5557d26b630..a3c7cb0e0d2b 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= rudiments
-PORTVERSION= 0.34
+PORTVERSION= 0.35
CATEGORIES= devel
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A utility C++ class library for daemons, clients, servers and more
+LICENSE= LGPL20
+
USE_GNOME= pkgconfig
USE_OPENSSL= yes
USE_GMAKE= yes
@@ -23,34 +25,28 @@ CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLINC} \
--with-ssl-libs=-L${OPENSSLLIB} \
--disable-pcre
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
MAN1= rudiments-config.1
-ROOTDIRS= classes css programming programming/parts
-
post-patch:
- ${REINPLACE_CMD} -e 's,/usr/bin/perl,${PREFIX}/bin/perl,g' \
- ${WRKSRC}/doc/programming/insert.pl
+ @${REINPLACE_CMD} -e \
+ '/pkgconfig/s|$$(libdir)/|$$(prefix)/libdata/| ; \
+ /^install:/s| install-doc | |' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|^#!/usr/bin/perl|#!${PERL}|' ${WRKSRC}/doc/programming/insert.pl
+ @${REINPLACE_CMD} -e \
+ 's| -release $$(RUDIMENTS_VERSION)||' ${WRKSRC}/src/Makefile
+
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for dirs in ${ROOTDIRS}
- @${MKDIR} ${DOCSDIR}/${dirs}
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/classes/*.html \
- ${DOCSDIR}/classes
- @${INSTALL_DATA} ${WRKSRC}/doc/css/*.css \
- ${DOCSDIR}/css
- @${INSTALL_DATA} ${WRKSRC}/doc/programming/*.html \
- ${DOCSDIR}/programming
- @${INSTALL_SCRIPT} ${WRKSRC}/doc/programming/*.pl \
- ${DOCSDIR}/programming
- @${INSTALL_DATA} ${WRKSRC}/doc/programming/parts/*.html \
- ${DOCSDIR}/programming/parts
- @${INSTALL_DATA} ${WRKSRC}/doc/*.html \
- ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/*.gif \
- ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @(${TAR} -C ${WRKSRC}/doc --exclude CVS --exclude "Makefile" \
+ --exclude "*.bak" --exclude "*.in" -cf - . | \
+ ${TAR} -C ${DOCSDIR} --unlink -xf -)
+ @${FIND} ${DOCSDIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @${FIND} ${DOCSDIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${DOCSDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/devel/rudiments/distinfo b/devel/rudiments/distinfo
index 30d7115e5377..9122fdba2bb7 100644
--- a/devel/rudiments/distinfo
+++ b/devel/rudiments/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rudiments-0.34.tar.gz) = a0e43bc961a7bbba08560393311076e0293627908de487302db454b273c159df
-SIZE (rudiments-0.34.tar.gz) = 770725
+SHA256 (rudiments-0.35.tar.gz) = ccf177734314c7a01a0fb22786bb0aafc9887a7127f78d9698fedf0a493baa30
+SIZE (rudiments-0.35.tar.gz) = 770791
diff --git a/devel/rudiments/files/patch-Makefile b/devel/rudiments/files/patch-Makefile
deleted file mode 100644
index da30ddd7a1bc..000000000000
--- a/devel/rudiments/files/patch-Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
---- Makefile.orig 2011-04-22 05:20:05.000000000 +0200
-+++ Makefile 2011-11-09 06:21:19.309527011 +0100
-@@ -5,7 +5,7 @@
- PWD=$(shell pwd)
-
- .PHONY: all testprogs clean install-libs install-includes install-bin \
-- install-doc install-man install-pc install uninstall unconfig distclean
-+ install-man install-pc install uninstall unconfig distclean
-
- all:
- cd src; $(MAKE) all
-@@ -27,23 +27,19 @@
- install-bin:
- cd bin; $(MAKE) install
-
--install-doc:
-- cd doc; $(MAKE) install
--
- install-man:
- cd man; $(MAKE) install
-
- install-pc:
-- $(MKINSTALLDIRS) $(libdir)/pkgconfig
-- $(INSTALL) -m 0644 rudiments.pc $(libdir)/pkgconfig/rudiments.pc
-+ $(MKINSTALLDIRS) $(prefix)/libdata/pkgconfig
-+ $(INSTALL) -m 0644 rudiments.pc $(prefix)/libdata/pkgconfig/rudiments.pc
-
--install: install-libs install-includes install-bin install-doc install-man install-pc
-+install: install-libs install-includes install-bin install-man install-pc
-
- uninstall:
- cd src; $(MAKE) uninstall
- cd include; $(MAKE) uninstall
- cd bin; $(MAKE) uninstall
-- cd doc; $(MAKE) uninstall
- cd man; $(MAKE) uninstall
- $(RM) $(libdir)/pkgconfig/rudiments.pc
-
diff --git a/devel/rudiments/files/patch-configure b/devel/rudiments/files/patch-configure
index ec7abd12cfff..82b1a9b4919b 100644
--- a/devel/rudiments/files/patch-configure
+++ b/devel/rudiments/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Aug 9 03:23:18 2004
-+++ configure Thu Aug 26 16:17:40 2004
-@@ -19632,8 +19632,8 @@
+--- configure.orig 2011-12-25 13:46:41.000000000 +0900
++++ configure 2012-02-14 22:39:36.000000000 +0900
+@@ -15737,8 +15737,8 @@
then
HAVE_PTHREAD=""
@@ -11,7 +11,16 @@
if ( test "$cross_compiling" = "yes" )
then
-@@ -19667,9 +19667,6 @@
+@@ -15757,7 +15757,7 @@
+
+ else
+
+- for i in "pthread" "c_r" "thread"
++ for i in "thread"
+ do
+
+
+@@ -15774,9 +15774,6 @@
STATIC=""
HEADERSANDLIBSPATH=""
@@ -21,9 +30,9 @@
eval "PTHREADSTATIC=\"\""
if ( test -n "" )
then
-@@ -20293,9 +20290,6 @@
- INCLUDESTRING=`echo $INCLUDESTRING | sed -e "s|-I/usr/include$||g" -e "s|-I/usr/include ||g"`
+@@ -16244,9 +16241,6 @@
LIBSTRING=`echo $LIBSTRING | sed -e "s|-L/usr/lib$||g" -e "s|-L/lib$||g" -e "s|-L/usr/lib ||g" -e "s|-L/lib ||g"`
+ LIBSTRING=`echo $LIBSTRING | sed -e "s|-L/usr/lib64$||g" -e "s|-L/lib64$||g" -e "s|-L/usr/lib64 ||g" -e "s|-L/lib64 ||g"`
-eval "PTHREADINCLUDES=\"$INCLUDESTRING\""
-eval "PTHREADLIB=\"$LIBSTRING\""
@@ -31,6 +40,3 @@
eval "PTHREADSTATIC=\"$STATIC\""
if ( test -n "" )
then
-
-
-
diff --git a/devel/rudiments/files/patch-src-Makefile b/devel/rudiments/files/patch-src-Makefile
deleted file mode 100644
index 1ebb257c2bc3..000000000000
--- a/devel/rudiments/files/patch-src-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.orig 2011-07-29 12:54:42.000000000 +0200
-+++ src/Makefile 2011-11-08 20:33:40.121527699 +0100
-@@ -341,7 +341,7 @@
- $(RMTREE) .libs
-
- librudiments.la: $(SRCS) $(LOBJS)
-- $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(INETATONLIB) $(NETAPI32LIB) $(DLLIB) -rpath $(libdir) -release $(RUDIMENTS_VERSION) -version-info $(SONAME_VERSION_INFO) -no-undefined
-+ $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(INETATONLIB) $(NETAPI32LIB) $(DLLIB) -rpath $(libdir) -version-info $(SONAME_VERSION_INFO) -no-undefined
-
- install:
- $(MKINSTALLDIRS) $(libdir)
diff --git a/devel/rudiments/pkg-plist b/devel/rudiments/pkg-plist
index d9bfd43d148a..098d36f69dce 100644
--- a/devel/rudiments/pkg-plist
+++ b/devel/rudiments/pkg-plist
@@ -140,8 +140,8 @@ include/rudiments/private/serversocket.h
include/rudiments/private/serversocketincludes.h
include/rudiments/private/serviceentry.h
include/rudiments/private/serviceentryincludes.h
-include/rudiments/private/shadowentryincludes.h
include/rudiments/private/shadowentry.h
+include/rudiments/private/shadowentryincludes.h
include/rudiments/private/sharedmemory.h
include/rudiments/private/sharedmemoryincludes.h
include/rudiments/private/shmfile.h
@@ -287,6 +287,7 @@ libdata/pkgconfig/rudiments.pc
%%PORTDOCS%%%%DOCSDIR%%/invisible.gif
%%PORTDOCS%%%%DOCSDIR%%/programming/baseclasses.html
%%PORTDOCS%%%%DOCSDIR%%/programming/insert.pl
+%%PORTDOCS%%%%DOCSDIR%%/programming/utilclasses.html
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/character.C.html
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/charstring.C.html
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/chat.C.html
@@ -356,12 +357,11 @@ libdata/pkgconfig/rudiments.pc
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/xattr.C.html
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/xmld.C.html
%%PORTDOCS%%%%DOCSDIR%%/programming/parts/xmls.C.html
-%%PORTDOCS%%%%DOCSDIR%%/programming/utilclasses.html
%%PORTDOCS%%%%DOCSDIR%%/reference.html
-@dirrm include/rudiments/private
-@dirrm include/rudiments
%%PORTDOCS%%@dirrm %%DOCSDIR%%/programming/parts
%%PORTDOCS%%@dirrm %%DOCSDIR%%/programming
%%PORTDOCS%%@dirrm %%DOCSDIR%%/css
%%PORTDOCS%%@dirrm %%DOCSDIR%%/classes
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/rudiments/private
+@dirrm include/rudiments