aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sdl12/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-04-20 17:24:28 +0800
committertg <tg@FreeBSD.org>2000-04-20 17:24:28 +0800
commitbb3d5d57f23c6c19a1d5658ccd56f5b05ec8c5b9 (patch)
tree588211e16c2d90f9c92683fa29f85b815f2fa021 /devel/sdl12/Makefile
parent2a2526a723e2ee86f99aa8715cb1ec9dda0a8fa9 (diff)
downloadfreebsd-ports-gnome-bb3d5d57f23c6c19a1d5658ccd56f5b05ec8c5b9.tar.gz
freebsd-ports-gnome-bb3d5d57f23c6c19a1d5658ccd56f5b05ec8c5b9.tar.zst
freebsd-ports-gnome-bb3d5d57f23c6c19a1d5658ccd56f5b05ec8c5b9.zip
Use our libc_r instead of linuxthreads.
Reviewed by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'devel/sdl12/Makefile')
-rw-r--r--devel/sdl12/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 0c6772f8d8d6..ca82f50350e0 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -13,9 +13,7 @@ DISTNAME= SDL-${PORTVERSION}
MAINTAINER= sobomax@altavista.net
-#This port doesn't love FreeBSD pthread :(
-LIB_DEPENDS= lthread.2:${PORTSDIR}/devel/linuxthreads \
- esd.2:${PORTSDIR}/audio/esound
+LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
@@ -25,12 +23,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
LOCALBASE="${LOCALBASE}"
-CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
- -D_THREAD_SAFE
+CFLAGS+= -D_THREAD_SAFE
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
- @ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
+ @ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
.for file in BUGS COPYING CREDITS README WhatsNew docs.html