aboutsummaryrefslogtreecommitdiffstats
path: root/devel/simgear
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2005-02-21 04:34:57 +0800
committerdes <des@FreeBSD.org>2005-02-21 04:34:57 +0800
commit737f5a97b79092df0e40bd74a016a07419ab0c2d (patch)
treee30b713abc5efcbefd7a15eb3609e12428fdb066 /devel/simgear
parentba9930f43b1ff1970bc973e40c9206bcfc78607c (diff)
downloadfreebsd-ports-gnome-737f5a97b79092df0e40bd74a016a07419ab0c2d.tar.gz
freebsd-ports-gnome-737f5a97b79092df0e40bd74a016a07419ab0c2d.tar.zst
freebsd-ports-gnome-737f5a97b79092df0e40bd74a016a07419ab0c2d.zip
Upgrade to 0.3.8.
WARNING: does not respect PTHREAD_{FLAGS,LIBS}. I could not find a clean way to patch it in. It should still work fine for the common case, though.
Diffstat (limited to 'devel/simgear')
-rw-r--r--devel/simgear/Makefile5
-rw-r--r--devel/simgear/distinfo4
-rw-r--r--devel/simgear/files/patch-aa11
-rw-r--r--devel/simgear/files/patch-ab28
-rw-r--r--devel/simgear/files/patch-simgear::screen::extensions.cxx11
5 files changed, 5 insertions, 54 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 8088eba4c2da..f37f6177e668 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= SimGear
-PORTVERSION= 0.3.7
+PORTVERSION= 0.3.8
CATEGORIES= devel games
MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/
@@ -28,6 +28,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.mk>
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index e7a708431360..b402cfa7d720 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,2 +1,2 @@
-MD5 (SimGear-0.3.7.tar.gz) = d920855efb6ed72f97dad4b76914bfa8
-SIZE (SimGear-0.3.7.tar.gz) = 990939
+MD5 (SimGear-0.3.8.tar.gz) = d535880954b8d9393f55cc51ee045c60
+SIZE (SimGear-0.3.8.tar.gz) = 992609
diff --git a/devel/simgear/files/patch-aa b/devel/simgear/files/patch-aa
deleted file mode 100644
index e81569c7af44..000000000000
--- a/devel/simgear/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- simgear/xgl/xglUtils.c.orig Tue Jan 21 23:22:54 2003
-+++ simgear/xgl/xglUtils.c Tue Jan 21 23:24:28 2003
-@@ -4,7 +4,7 @@
- #include <string.h>
-
- #if !defined( WIN32 )
--# if !defined( HAVE_STL_SGI_PORT ) && !defined( __MWERKS__ ) && !defined( __APPLE__ )
-+# if !defined( HAVE_STL_SGI_PORT ) && !defined( __MWERKS__ ) && !defined( __APPLE__ ) && !defined( __FreeBSD__ )
- // Avoid malloc with STLport and MSL
- # include <malloc.h>
- # endif
diff --git a/devel/simgear/files/patch-ab b/devel/simgear/files/patch-ab
deleted file mode 100644
index 2e9ac18fdfe5..000000000000
--- a/devel/simgear/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- configure.orig Mon Mar 3 14:01:49 2003
-+++ configure Mon Mar 3 14:01:59 2003
-@@ -5063,13 +5063,13 @@
- base_LIBS="$LIBS"
-
-
--echo "$as_me:$LINENO: checking for pthread_exit in -lpthread" >&5
--echo $ECHO_N "checking for pthread_exit in -lpthread... $ECHO_C" >&6
-+echo "$as_me:$LINENO: checking for pthread_exit in ${PTHREAD_LIBS}" >&5
-+echo $ECHO_N "checking for pthread_exit in ${PTHREAD_LIBS}... $ECHO_C" >&6
- if test "${ac_cv_lib_pthread_pthread_exit+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lpthread $LIBS"
-+LIBS="${PTHREAD_LIBS} $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-@@ -5117,7 +5117,7 @@
- #define HAVE_LIBPTHREAD 1
- _ACEOF
-
-- LIBS="-lpthread $LIBS"
-+ LIBS="-pthread $LIBS"
-
- fi
-
diff --git a/devel/simgear/files/patch-simgear::screen::extensions.cxx b/devel/simgear/files/patch-simgear::screen::extensions.cxx
deleted file mode 100644
index 488fa5cfca30..000000000000
--- a/devel/simgear/files/patch-simgear::screen::extensions.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- simgear/screen/extensions.cxx.orig Tue Nov 9 13:31:54 2004
-+++ simgear/screen/extensions.cxx Tue Nov 9 13:32:10 2004
-@@ -113,7 +113,7 @@
- if (libHandle != NULL) {
- fptr = dlsym(libHandle, func);
-
-- char *error = dlerror();
-+ const char *error = dlerror();
- if (error)
- SG_LOG(SG_GENERAL, SG_INFO, error);
- }