aboutsummaryrefslogtreecommitdiffstats
path: root/devel/simulavr
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2005-07-31 06:03:01 +0800
committerjoerg <joerg@FreeBSD.org>2005-07-31 06:03:01 +0800
commit5003196acb752c007dfff945d6b872cc20e5db53 (patch)
tree1303b6107a9563d97eb83de0ffee242a9a620955 /devel/simulavr
parent6f9fca5dfa68e95ea8ffe11326e43221d29a73c3 (diff)
downloadfreebsd-ports-gnome-5003196acb752c007dfff945d6b872cc20e5db53.tar.gz
freebsd-ports-gnome-5003196acb752c007dfff945d6b872cc20e5db53.tar.zst
freebsd-ports-gnome-5003196acb752c007dfff945d6b872cc20e5db53.zip
Upgrade to a new source tarball that has all of our functional private
patches integrated. I give up on trying to convince the doxygen setup of simulavr to peacefully collaborate with LaTeX 3.x, it always ends up in producing a PDF file where it is supposed to produce a DVI file (which the build system then tries to process further). Instead, I hacked the configure and build system to not try building or installing any of its private documentation at all (the man and info pages are still around as they are already present in the source tarball). After all, the original simulavr is no longer being developed but has a successor named simulavrxx, so in future, I'll rather concentrate on making a FreeBSD port out of that one.
Diffstat (limited to 'devel/simulavr')
-rw-r--r--devel/simulavr/Makefile14
-rw-r--r--devel/simulavr/distinfo4
-rw-r--r--devel/simulavr/files/patch-configure25
-rw-r--r--devel/simulavr/files/patch-doc::Makefile.in22
-rw-r--r--devel/simulavr/files/patch-sim-no-vcd-inline38
-rw-r--r--devel/simulavr/files/patch-src::avrcore.c12
-rw-r--r--devel/simulavr/files/patch-test_asm22
-rw-r--r--devel/simulavr/pkg-plist84
8 files changed, 40 insertions, 181 deletions
diff --git a/devel/simulavr/Makefile b/devel/simulavr/Makefile
index 466598f66497..ec4956e457b0 100644
--- a/devel/simulavr/Makefile
+++ b/devel/simulavr/Makefile
@@ -7,26 +7,20 @@
PORTNAME= simulavr
PORTVERSION= 0.1.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
# special name only this time, don't let this go into ${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION}.1
+DISTNAME= ${PORTNAME}-${PORTVERSION}.2
MAINTAINER= joerg@FreeBSD.org
COMMENT= A simulator for AVR microcontrollers
BUILD_DEPENDS= ${LOCALBASE}/avr/include/avr/io.h:${PORTSDIR}/devel/avr-libc \
- avr-ld:${PORTSDIR}/devel/avr-binutils \
- doxygen:${PORTSDIR}/devel/doxygen \
- latex:${PORTSDIR}/print/teTeX
+ avr-ld:${PORTSDIR}/devel/avr-binutils
-BROKEN= "Does not build (latex generates pdf instead of dvi)"
-DEPRECATED= "${BROKEN}"
-EXPIRATION_DATE=2005-09-22
-
-USE_BZIP2= yes
+#USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/simulavr/distinfo b/devel/simulavr/distinfo
index bcbb9224f52b..38145be8bd3c 100644
--- a/devel/simulavr/distinfo
+++ b/devel/simulavr/distinfo
@@ -1,2 +1,2 @@
-MD5 (simulavr-0.1.2.1.tar.bz2) = 7fbf757f285ac9fd2d22604df6a9ee5f
-SIZE (simulavr-0.1.2.1.tar.bz2) = 359233
+MD5 (simulavr-0.1.2.2.tar.gz) = 7fa27cddaa3397046538bf5b916fdc11
+SIZE (simulavr-0.1.2.2.tar.gz) = 457130
diff --git a/devel/simulavr/files/patch-configure b/devel/simulavr/files/patch-configure
index 43a96c34704d..47781a6c9b5b 100644
--- a/devel/simulavr/files/patch-configure
+++ b/devel/simulavr/files/patch-configure
@@ -1,17 +1,16 @@
---- configure.ac.orig Mon Jan 19 00:58:13 2004
-+++ configure.ac Wed Dec 8 22:58:29 2004
-@@ -441,7 +441,7 @@
+--- configure.orig Thu Feb 17 00:00:18 2005
++++ configure Sat Jul 30 23:49:51 2005
+@@ -7166,7 +7166,8 @@
- # If we are compiling with gcc, enable all warning and make warnings errors.
- if test "$GCC" = yes; then
-- ENABLE_WARNINGS="-Wall -Winline -Werror"
-+ ENABLE_WARNINGS="-Wall"
- fi
- AC_SUBST(ENABLE_WARNINGS,$ENABLE_WARNINGS)
-
---- configure.orig Mon Jan 19 00:58:28 2004
-+++ configure Wed Dec 8 22:58:03 2004
-@@ -6804,7 +6804,7 @@
+ echo "$as_me:$LINENO: checking for doxygen" >&5
+ echo $ECHO_N "checking for doxygen... $ECHO_C" >&6
+-dox_ver=`doxygen --version 2>/dev/null`
++#dox_ver=`doxygen --version 2>/dev/null`
++dox_ver=
+ if test "x$dox_ver" = "x"; then
+ echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6
+@@ -7223,7 +7224,7 @@
# If we are compiling with gcc, enable all warning and make warnings errors.
if test "$GCC" = yes; then
diff --git a/devel/simulavr/files/patch-doc::Makefile.in b/devel/simulavr/files/patch-doc::Makefile.in
new file mode 100644
index 000000000000..cf8ea8f3fc41
--- /dev/null
+++ b/devel/simulavr/files/patch-doc::Makefile.in
@@ -0,0 +1,22 @@
+--- doc/Makefile.in.orig Thu Feb 17 00:00:19 2005
++++ doc/Makefile.in Sat Jul 30 23:54:10 2005
+@@ -516,7 +516,8 @@
+ uninstall-local
+
+
+-all-local: html $(TARGET_PS) $(TARGET_PDF)
++#all-local: html $(TARGET_PS) $(TARGET_PDF)
++all-local:
+
+ # Rule for generating postscript output.
+ ps: simulavr.ps $(TARGET_DOX_PS)
+@@ -547,7 +548,8 @@
+ done
+
+ # General rule for installing documentation
+-install-data-local: install-html install-ps $(INSTALL_PDF)
++#install-data-local: install-html install-ps $(INSTALL_PDF)
++install-data-local:
+
+ uninstall-local:
+ rm -rf $(DOC_INST_DIR)
diff --git a/devel/simulavr/files/patch-sim-no-vcd-inline b/devel/simulavr/files/patch-sim-no-vcd-inline
deleted file mode 100644
index cd62e62206e6..000000000000
--- a/devel/simulavr/files/patch-sim-no-vcd-inline
+++ /dev/null
@@ -1,38 +0,0 @@
-2004-03-11 Theodore A. Roth <troth@openavr.org>
-
- * src/disp-vcd/vcd.c:
- * src/disp-vcd/vcd.h:
- Don't inline vcd_set_clock.
-
-Index: src/disp-vcd/vcd.c
-===================================================================
-RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.c,v
-retrieving revision 1.3
-diff -u -p -p -r1.3 vcd.c
---- src/disp-vcd/vcd.c 1 Dec 2003 05:48:35 -0000 1.3
-+++ src/disp-vcd/vcd.c 11 Mar 2004 18:56:24 -0000
-@@ -696,7 +696,7 @@ vcd_write_pc (int pc)
-
- /* Set the current time. */
-
--inline int
-+int
- vcd_set_clock (unsigned int c)
- {
- clk = c;
-Index: src/disp-vcd/vcd.h
-===================================================================
-RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.h,v
-retrieving revision 1.2
-diff -u -p -p -r1.2 vcd.h
---- src/disp-vcd/vcd.h 17 Nov 2002 00:29:20 -0000 1.2
-+++ src/disp-vcd/vcd.h 11 Mar 2004 18:56:24 -0000
-@@ -47,7 +47,7 @@ int vcd_trace_pc( void );
- /* Interface for disp.c */
- int vcd_write_header( void );
-
--inline int vcd_set_clock( unsigned int c );
-+int vcd_set_clock( unsigned int c );
- int vcd_write_clock( void );
-
- int vcd_bind_io_reg_shortcut( char *io_reg_name, int io_reg_addr );
diff --git a/devel/simulavr/files/patch-src::avrcore.c b/devel/simulavr/files/patch-src::avrcore.c
deleted file mode 100644
index a5e1ce605e7e..000000000000
--- a/devel/simulavr/files/patch-src::avrcore.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/avrcore.c.orig Fri Jan 2 04:01:01 2004
-+++ src/avrcore.c Wed Jan 12 22:31:53 2005
-@@ -1067,6 +1067,9 @@
-
- signal_watch_stop (SIGINT);
-
-+ /* avoid division by zero below */
-+ if (run_time == 0) run_time = 1;
-+
- avr_message ("Run time was %lld.%03lld seconds.\n", run_time / 1000,
- run_time % 1000);
- avr_message ("Executed %lld instructions.\n", cnt);
diff --git a/devel/simulavr/files/patch-test_asm b/devel/simulavr/files/patch-test_asm
deleted file mode 100644
index 56a7749fb4d6..000000000000
--- a/devel/simulavr/files/patch-test_asm
+++ /dev/null
@@ -1,22 +0,0 @@
---- test_asm/test_8515/Makefile.am.orig Thu Aug 14 04:35:06 2003
-+++ test_asm/test_8515/Makefile.am Thu Jun 17 10:22:38 2004
-@@ -51,7 +51,7 @@
-
- all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
- for prg in $(TEST_PRG); do \
-- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
-+ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
- done
-
- clean-local:
---- test_asm/test_8515/Makefile.in.orig Mon Jan 19 00:58:31 2004
-+++ test_asm/test_8515/Makefile.in Thu Jun 17 10:23:08 2004
-@@ -379,7 +379,7 @@
-
- all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
- for prg in $(TEST_PRG); do \
-- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
-+ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
- done
-
- clean-local:
diff --git a/devel/simulavr/pkg-plist b/devel/simulavr/pkg-plist
index 90f8a7aa5ab6..6ff428867d6a 100644
--- a/devel/simulavr/pkg-plist
+++ b/devel/simulavr/pkg-plist
@@ -13,88 +13,4 @@ share/doc/simulavr/README
share/doc/simulavr/README.gdb
share/doc/simulavr/README.opcodes
share/doc/simulavr/TODO
-share/doc/simulavr/html/index.html
-share/doc/simulavr/html/simulavr_1.html
-share/doc/simulavr/html/simulavr_2.html
-share/doc/simulavr/html/simulavr_3.html
-share/doc/simulavr/html/simulavr_4.html
-share/doc/simulavr/html/simulavr_5.html
-share/doc/simulavr/html/simulavr_6.html
-share/doc/simulavr/html/simulavr_7.html
-share/doc/simulavr/html/simulavr_8.html
-share/doc/simulavr/html/simulavr_9.html
-share/doc/simulavr/html/simulavr_10.html
-share/doc/simulavr/html/simulavr_11.html
-share/doc/simulavr/html/simulavr_toc.html
-share/doc/simulavr/internals_html/adc_8c-source.html
-share/doc/simulavr/internals_html/adc_8c.html
-share/doc/simulavr/internals_html/avrclass_8c-source.html
-share/doc/simulavr/internals_html/avrclass_8c.html
-share/doc/simulavr/internals_html/avrcore_8c-source.html
-share/doc/simulavr/internals_html/avrcore_8c.html
-share/doc/simulavr/internals_html/avrerror_8c-source.html
-share/doc/simulavr/internals_html/avrerror_8c.html
-share/doc/simulavr/internals_html/avrmalloc_8c-source.html
-share/doc/simulavr/internals_html/avrmalloc_8c.html
-share/doc/simulavr/internals_html/break_watch_pts.html
-share/doc/simulavr/internals_html/callback_8c-source.html
-share/doc/simulavr/internals_html/decoder_8c-source.html
-share/doc/simulavr/internals_html/decoder_8c.html
-share/doc/simulavr/internals_html/device_8c-source.html
-share/doc/simulavr/internals_html/device_8c.html
-share/doc/simulavr/internals_html/devsupp_8c-source.html
-share/doc/simulavr/internals_html/devsupp_8c.html
-share/doc/simulavr/internals_html/display_8c-source.html
-share/doc/simulavr/internals_html/display_8c.html
-share/doc/simulavr/internals_html/dox.css
-share/doc/simulavr/internals_html/eeprom_8c-source.html
-share/doc/simulavr/internals_html/ext_devs.html
-share/doc/simulavr/internals_html/files.html
-share/doc/simulavr/internals_html/flash_8c-source.html
-share/doc/simulavr/internals_html/flash_8c.html
-share/doc/simulavr/internals_html/gdbserver_8c-source.html
-share/doc/simulavr/internals_html/gdbserver_8c.html
-share/doc/simulavr/internals_html/globals.html
-share/doc/simulavr/internals_html/globals_defs.html
-share/doc/simulavr/internals_html/globals_enum.html
-share/doc/simulavr/internals_html/globals_eval.html
-share/doc/simulavr/internals_html/globals_func.html
-share/doc/simulavr/internals_html/globals_vars.html
-share/doc/simulavr/internals_html/index.html
-share/doc/simulavr/internals_html/insn_decoder.html
-share/doc/simulavr/internals_html/interrupts.html
-share/doc/simulavr/internals_html/intvects_8c-source.html
-share/doc/simulavr/internals_html/main.html
-share/doc/simulavr/internals_html/main_8c-source.html
-share/doc/simulavr/internals_html/memory_8c-source.html
-share/doc/simulavr/internals_html/memory_8c.html
-share/doc/simulavr/internals_html/memory_management.html
-share/doc/simulavr/internals_html/object_system.html
-share/doc/simulavr/internals_html/op__names_8c-source.html
-share/doc/simulavr/internals_html/pages.html
-share/doc/simulavr/internals_html/ports_8c-source.html
-share/doc/simulavr/internals_html/ports_8c.html
-share/doc/simulavr/internals_html/register_8c-source.html
-share/doc/simulavr/internals_html/sig_8c-source.html
-share/doc/simulavr/internals_html/sig_8c.html
-share/doc/simulavr/internals_html/spi_8c-source.html
-share/doc/simulavr/internals_html/spi_8c.html
-share/doc/simulavr/internals_html/sram_8c-source.html
-share/doc/simulavr/internals_html/stack_8c-source.html
-share/doc/simulavr/internals_html/stack_8c.html
-share/doc/simulavr/internals_html/storage_8c-source.html
-share/doc/simulavr/internals_html/timers_8c-source.html
-share/doc/simulavr/internals_html/timers_8c.html
-share/doc/simulavr/internals_html/todo.html
-share/doc/simulavr/internals_html/tree.html
-share/doc/simulavr/internals_html/uart_8c-source.html
-share/doc/simulavr/internals_html/uart_8c.html
-share/doc/simulavr/internals_html/usb_8c-source.html
-share/doc/simulavr/internals_html/usb_8c.html
-share/doc/simulavr/internals_html/utils_8c-source.html
-share/doc/simulavr/internals_html/utils_8c.html
-share/doc/simulavr/internals_html/virtual_devs.html
-share/doc/simulavr/simulavr.ps
-@dirrm share/doc/simulavr/html
-@dirrm share/doc/simulavr/internals_html
@dirrm share/doc/simulavr