aboutsummaryrefslogtreecommitdiffstats
path: root/devel/slglade
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2008-08-26 21:53:57 +0800
committermakc <makc@FreeBSD.org>2008-08-26 21:53:57 +0800
commiteecbb83eae0cd16a7bc41c4f9ff25c5df4e3b2ac (patch)
treeea795c37976f52a7e03c23667904db6626e4f132 /devel/slglade
parentff0f3062883482dc07e32fd748172a6b866ad665 (diff)
downloadfreebsd-ports-gnome-eecbb83eae0cd16a7bc41c4f9ff25c5df4e3b2ac.tar.gz
freebsd-ports-gnome-eecbb83eae0cd16a7bc41c4f9ff25c5df4e3b2ac.tar.zst
freebsd-ports-gnome-eecbb83eae0cd16a7bc41c4f9ff25c5df4e3b2ac.zip
Lglade is a S-Lang module that provides S-Lang bindings
for the libglade library. Used in conjunction with SLgtk, it allows you to design your GUI with Glade (a GTK+ user interface builder), save the interface description in a Glade XML file, and then generate your S-Lang script's graphical interface directly from the XML at runtime. This should reduce the time spent developing SLgtk applications considerably, as it eliminates the tedious job of writing interface-creation code by hand. This is an update for Christopher Stawarz's SLglade module. WWW: http://laurent.perez2.free.fr/comp/slang/modules/modules.html PR: 126652 Submitted by: Alexey Shuvaev Approved by: miwi (mentor)
Diffstat (limited to 'devel/slglade')
-rw-r--r--devel/slglade/Makefile37
-rw-r--r--devel/slglade/distinfo3
-rw-r--r--devel/slglade/pkg-descr12
-rw-r--r--devel/slglade/pkg-plist17
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/slglade/Makefile b/devel/slglade/Makefile
new file mode 100644
index 000000000000..609ce1090163
--- /dev/null
+++ b/devel/slglade/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: slglade
+# Date created: 15 Aug 2008
+# Whom: Alexey Shuvaev <shuvaev@phyisik.uni-wuerzburg.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slglade
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= http://laurent.perez2.free.fr/comp/slang/modules/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= shuvaev@physik.uni-wuerzburg.de
+COMMENT= S-Lang binding for libglade
+
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+RUN_DEPENDS= imdisplay:${PORTSDIR}/x11-toolkits/slgtk
+
+USE_GNOME= libglade2
+GNU_CONFIGURE= yes
+
+post-patch:
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|doc/slglade|share/&|' ${WRKSRC}/doc/Makefile.in
+.else
+ @${REINPLACE_CMD} -e 's/doc //' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.sl ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.glade ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/slglade/distinfo b/devel/slglade/distinfo
new file mode 100644
index 000000000000..65ba15837b70
--- /dev/null
+++ b/devel/slglade/distinfo
@@ -0,0 +1,3 @@
+MD5 (slglade-0.3.tgz) = 9c821c2c9b74c60e3be9f5d6b76ef98d
+SHA256 (slglade-0.3.tgz) = 24205cd48cbfaf81666f42a1420ff34a38f53512c6094d5cb5ded3070b4dc023
+SIZE (slglade-0.3.tgz) = 339329
diff --git a/devel/slglade/pkg-descr b/devel/slglade/pkg-descr
new file mode 100644
index 000000000000..489a7989adcb
--- /dev/null
+++ b/devel/slglade/pkg-descr
@@ -0,0 +1,12 @@
+SLglade is a S-Lang module that provides S-Lang bindings
+for the libglade library. Used in conjunction with SLgtk,
+it allows you to design your GUI with Glade (a GTK+ user interface builder),
+save the interface description in a Glade XML file,
+and then generate your S-Lang script's graphical interface
+directly from the XML at runtime. This should reduce the time spent
+developing SLgtk applications considerably, as it eliminates
+the tedious job of writing interface-creation code by hand.
+
+This is an update for Christopher Stawarz's SLglade module.
+
+WWW: http://laurent.perez2.free.fr/comp/slang/modules/modules.html
diff --git a/devel/slglade/pkg-plist b/devel/slglade/pkg-plist
new file mode 100644
index 000000000000..f4cec635d8f3
--- /dev/null
+++ b/devel/slglade/pkg-plist
@@ -0,0 +1,17 @@
+lib/slang/v2/modules/glade-module.la
+lib/slang/v2/modules/glade-module.so
+%%PORTDOCS%%%%DOCSDIR%%/slgladefun.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/buffer_basic.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.glade
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/get_widget.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/howdy.glade
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/root_widget.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/signal_connect.sl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/texteditor.glade
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/texteditor.sl
+share/slsh/local-packages/glade.sl
+share/slsh/local-packages/slirprc-glade.sl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%