aboutsummaryrefslogtreecommitdiffstats
path: root/devel/splint
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1996-12-12 06:51:22 +0800
committerobrien <obrien@FreeBSD.org>1996-12-12 06:51:22 +0800
commit32ac99ff52380e5bf7be6d8383d8aae95f505563 (patch)
tree5e64c14607726ab2118cde28a4119b29079a6bc3 /devel/splint
parent8f10c6cec6f58f03623d4a00f64fedaa326a08bc (diff)
downloadfreebsd-ports-gnome-32ac99ff52380e5bf7be6d8383d8aae95f505563.tar.gz
freebsd-ports-gnome-32ac99ff52380e5bf7be6d8383d8aae95f505563.tar.zst
freebsd-ports-gnome-32ac99ff52380e5bf7be6d8383d8aae95f505563.zip
LCLint is a tool for statically checking C programs. With minimal
effort, LCLint can be used as a better lint. If additional effort is invested adding annotations to programs, LCLint can perform stronger checks than can be done by any standard lint. Check the LCLint home page at http://larch-www.lcs.mit.edu:8001/larch/lclint/ Closes-PR: ports/1646 Submitted by: Stefan Moeding <moeding@bn.DeTeMobil.de>
Diffstat (limited to 'devel/splint')
-rw-r--r--devel/splint/Makefile26
-rw-r--r--devel/splint/distinfo1
-rw-r--r--devel/splint/files/patch-aa47
-rw-r--r--devel/splint/pkg-comment1
-rw-r--r--devel/splint/pkg-descr8
-rw-r--r--devel/splint/pkg-plist46
6 files changed, 129 insertions, 0 deletions
diff --git a/devel/splint/Makefile b/devel/splint/Makefile
new file mode 100644
index 000000000000..9ec423c5aa5c
--- /dev/null
+++ b/devel/splint/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: lclint
+# Version required: 2.2a
+# Date created: 9 September 1996
+# Whom: moeding
+#
+# $Id: porting.sgml,v 1.2.4.5 1996/06/19 20:28:08 jkh Exp $
+#
+
+DISTNAME= lclint-2.2a.src
+PKGNAME= lclint-2.2a
+CATEGORIES= devel
+MASTER_SITES= ftp://larch.lcs.mit.edu/pub/Larch/lclint/
+
+MAINTAINER= moeding@bn.DeTeMobil.de
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+do-build:
+ @(cd ${WRKSRC}; ${GMAKE})
+
+post-install:
+ @strip ${PREFIX}/bin/lclint
+
+.include <bsd.port.mk>
diff --git a/devel/splint/distinfo b/devel/splint/distinfo
new file mode 100644
index 000000000000..5776fa3c04e6
--- /dev/null
+++ b/devel/splint/distinfo
@@ -0,0 +1 @@
+MD5 (lclint-2.2a.src.tar.gz) = 5eba0bfd1d4d981a3352fce88e7d6e4f
diff --git a/devel/splint/files/patch-aa b/devel/splint/files/patch-aa
new file mode 100644
index 000000000000..3b9f88487677
--- /dev/null
+++ b/devel/splint/files/patch-aa
@@ -0,0 +1,47 @@
+--- Makefile.in.orig Wed Sep 4 20:18:10 1996
++++ Makefile.in Wed Dec 11 21:57:01 1996
+@@ -40,16 +40,16 @@
+ ###
+
+ ### directory for lclint libraries
+-LIBDIR = @installdir@/lib
++LIBDIR = @installdir@/share/lclint-2.2a/lib
+
+ ### directory for lclint standard imports
+-IMPORTSDIR = @installdir@/imports
++IMPORTSDIR = @installdir@/share/lclint-2.2a/imports
+
+ ### directory for lclint binary
+ INSTALLDIR = @installdir@/bin
+
+ ### directory for installing lclint.el[c]
+-EMACSLIBDIR = @installdir@/emacs
++EMACSLIBDIR = @installdir@/share/emacs/site-lisp
+
+ ### this should be the complete path for the directory where this
+ ### Makefile is, with no trailing / or spaces.
+@@ -232,6 +232,7 @@
+ @echo '// Installation complete.'
+
+ doemacs:
++ @mkdir -p $(EMACSLIBDIR)
+ @$(CP) $(LCLINTEMACS) $(EMACSLIBDIR)
+ @$(CP) $(LCLINTEMACSC) $(EMACSLIBDIR)
+
+@@ -243,14 +244,14 @@
+ dolibraries:
+ @echo '// Installing libraries in '$(LIBDIR)
+ @echo " (This will complain if the directory already exists, don't worry about it.)"
+- -mkdir $(LIBDIR)
++ mkdir -p $(LIBDIR)
+ $(CP) $(LCLINTLIB)/* $(LIBDIR)
+ @echo '// Installed libraries.'
+
+ doimports:
+ @echo '// Installing imports in '$(IMPORTSDIR)
+ @echo " (This will complain if the directory already exists, don't worry about it.)"
+- -mkdir $(IMPORTSDIR)
++ mkdir -p $(IMPORTSDIR)
+ $(CP) $(LCLINTIMPORTS)/* $(IMPORTSDIR)
+ @echo '// Installed imports.'
+
diff --git a/devel/splint/pkg-comment b/devel/splint/pkg-comment
new file mode 100644
index 000000000000..ffae0cb0dfa9
--- /dev/null
+++ b/devel/splint/pkg-comment
@@ -0,0 +1 @@
+A tool for statically checking C programs.
diff --git a/devel/splint/pkg-descr b/devel/splint/pkg-descr
new file mode 100644
index 000000000000..05cc0b5b9203
--- /dev/null
+++ b/devel/splint/pkg-descr
@@ -0,0 +1,8 @@
+LCLint is a tool for statically checking C programs. With minimal
+effort, LCLint can be used as a better lint. If additional effort is
+invested adding annotations to programs, LCLint can perform stronger
+checks than can be done by any standard lint.
+
+Check the LCLint home page at
+ http://larch-www.lcs.mit.edu:8001/larch/lclint/
+for more information and complete documentation.
diff --git a/devel/splint/pkg-plist b/devel/splint/pkg-plist
new file mode 100644
index 000000000000..09cd5f38eee4
--- /dev/null
+++ b/devel/splint/pkg-plist
@@ -0,0 +1,46 @@
+bin/lclint
+share/emacs/site-lisp/lclint.el
+share/emacs/site-lisp/lclint.elc
+share/lclint-2.2a/lib/CTrait.syms
+share/lclint-2.2a/lib/unix.lcd
+share/lclint-2.2a/lib/unix.h
+share/lclint-2.2a/lib/posixstrict.lcd
+share/lclint-2.2a/lib/posix.lcd
+share/lclint-2.2a/lib/posix.h
+share/lclint-2.2a/lib/lslinit.lsi
+share/lclint-2.2a/lib/lclinit.lci
+share/lclint-2.2a/lib/bool.h
+share/lclint-2.2a/lib/ansistrict.lcd
+share/lclint-2.2a/lib/ansi.lcd
+share/lclint-2.2a/lib/ansi.h
+share/lclint-2.2a/lib/README
+share/lclint-2.2a/lib/CTraitGen.lcl
+share/lclint-2.2a/lib/unixstrict.lcd
+share/lclint-2.2a/imports/assert.lcl
+share/lclint-2.2a/imports/time.lcl
+share/lclint-2.2a/imports/strings.lcs
+share/lclint-2.2a/imports/strings.lcl
+share/lclint-2.2a/imports/string.lcs
+share/lclint-2.2a/imports/string.lcl
+share/lclint-2.2a/imports/stdlib.lcs
+share/lclint-2.2a/imports/stdlib.lcl
+share/lclint-2.2a/imports/stdio.lcs
+share/lclint-2.2a/imports/stdio.lcl
+share/lclint-2.2a/imports/stdarg.lcs
+share/lclint-2.2a/imports/stdarg.lcl
+share/lclint-2.2a/imports/signal.lcs
+share/lclint-2.2a/imports/signal.lcl
+share/lclint-2.2a/imports/setjmp.lcs
+share/lclint-2.2a/imports/setjmp.lcl
+share/lclint-2.2a/imports/math.lcs
+share/lclint-2.2a/imports/math.lcl
+share/lclint-2.2a/imports/locale.lcs
+share/lclint-2.2a/imports/locale.lcl
+share/lclint-2.2a/imports/limits.lcs
+share/lclint-2.2a/imports/limits.lcl
+share/lclint-2.2a/imports/errno.lcs
+share/lclint-2.2a/imports/errno.lcl
+share/lclint-2.2a/imports/ctype.lcs
+share/lclint-2.2a/imports/ctype.lcl
+share/lclint-2.2a/imports/assert.lcs
+share/lclint-2.2a/imports/time.lcs