aboutsummaryrefslogtreecommitdiffstats
path: root/devel/stfl
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-08-09 05:03:24 +0800
committersat <sat@FreeBSD.org>2007-08-09 05:03:24 +0800
commit691429a425123611fab42328b1f93532eda67dcb (patch)
tree901c3e2201d0ce77127f0c92c78bfabb69ff6546 /devel/stfl
parentbc4ad4d680932c0f0a4b8154cdfb3f170553fa42 (diff)
downloadfreebsd-ports-gnome-691429a425123611fab42328b1f93532eda67dcb.tar.gz
freebsd-ports-gnome-691429a425123611fab42328b1f93532eda67dcb.tar.zst
freebsd-ports-gnome-691429a425123611fab42328b1f93532eda67dcb.zip
- Attempt to fix build when using ncurses from ports (e.g. on 5.x)
Reported by: pointyhat via kris
Diffstat (limited to 'devel/stfl')
-rw-r--r--devel/stfl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/stfl/Makefile b/devel/stfl/Makefile
index 3ba9a0ab3c3d..765cb9d4726c 100644
--- a/devel/stfl/Makefile
+++ b/devel/stfl/Makefile
@@ -32,8 +32,8 @@ NCURSES_INC= ncurses/
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|\.a|.so|g;/ranlib/d;s|ar qc|${CC} ${CFLAGS} -shared -fPIC -o|;\
- s|sed -r|sed -E|;s|-Os||;/gcc/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|\.a|.so|g;/ranlib/d;s|ar qc|$${CC} $${CFLAGS} -shared -fPIC -o|;\
+ s|sed -r|sed -E|;s|-Os||;/gcc/d;/-MM/s|-I.|$${CFLAGS}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|alloca.h|stdlib.h|' ${WRKSRC}/widgets/*.c
@${REINPLACE_CMD} -e 's|ncursesw/|${NCURSES_INC}|' ${WRKSRC}/stfl_internals.h
@${ECHO_CMD} 'prefix = ${PREFIX}' > ${WRKSRC}/Makefile.cfg