aboutsummaryrefslogtreecommitdiffstats
path: root/devel/stlport/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-12-22 23:28:18 +0800
committernetchild <netchild@FreeBSD.org>2003-12-22 23:28:18 +0800
commit993568264873b6a73bfb9b06dc7db8587f76ef7c (patch)
tree71e16ed8c6cad491ad16e862e1f2adafe5b8902d /devel/stlport/Makefile
parentdee0fedaeebc29896307c271d947a2f5583adf3d (diff)
downloadfreebsd-ports-gnome-993568264873b6a73bfb9b06dc7db8587f76ef7c.tar.gz
freebsd-ports-gnome-993568264873b6a73bfb9b06dc7db8587f76ef7c.tar.zst
freebsd-ports-gnome-993568264873b6a73bfb9b06dc7db8587f76ef7c.zip
Second part of the stlport-icc fix for 4.x. [1]
This patch modifies some gcc parts too, but basically it makes the port respect CFLAGS. Because of bugs in combination with gcc 3.x and some optimization options the CFLAGS are hardcoded (better safe than sorry). I've tested the gcc part of the fix on 4-stable and two 5.x systems. Submitted by: Marius Strobl <marius@alchemy.franken.de> [1] Approved by: maintainer timeout (for devel/stlport)
Diffstat (limited to 'devel/stlport/Makefile')
-rw-r--r--devel/stlport/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 5dd7c2f5c875..ae8bfcfb0075 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -8,7 +8,7 @@
PORTNAME= stlport
PORTVERSION= 4.5.3
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= http://www.stlport.com/archive/
PKGNAMESUFFIX= -${COMPILER}
@@ -28,9 +28,10 @@ PATCH_WRKSRC= ${WRKDIR}/STLport-${PORTVERSION:S/.b/b/}
USE_GMAKE= yes
COMPILER?= gcc
MAKEFILE= ${COMPILER}-freebsd.mak
+MAKE_ENV+= CC=${CC} CXX=${CXX}
MAKE_ARGS+= INSTALLDIR=${PREFIX} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-PLIST_SUB= COMPILER=${COMPILER}
+PLIST_SUB+= COMPILER=${COMPILER}
INSTALL_TARGET= install_unix
INSTALLS_SHLIB= yes
@@ -40,8 +41,13 @@ BROKEN= "Not supported on systems prior to FreeBSD 4.4"
.endif
.if ${COMPILER} == icc
-CC= icc
-CXX= icpc
+CC= icc
+CXX= icpc
+CFLAGS= -O -ip -axiMKW
+CXXFLAGS= ${CFLAGS}
+.else
+CFLAGS=
+CXXFLAGS=
.endif
.if ${COMPILER} == gcc && ${OSVERSION} < 460000
@@ -73,9 +79,7 @@ post-build: test
.endif
test: do-build
- cd ${WRKSRC}/../test/eh && ${SETENV} CC=${CC} CXX=${CXX} \
- ${GMAKE} -f ${MAKEFILE} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LIBS=${PTHREAD_LIBS} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LIBS=${PTHREAD_LIBS} CC=${CC} CXX=${CXX}
+ @cd ${WRKSRC}/../test/eh && ${SETENV} ${MAKE_ENV} \
+ ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check_d
.include <bsd.port.post.mk>