aboutsummaryrefslogtreecommitdiffstats
path: root/devel/subversion16/Makefile
diff options
context:
space:
mode:
authorbmah <bmah@FreeBSD.org>2003-04-05 02:06:54 +0800
committerbmah <bmah@FreeBSD.org>2003-04-05 02:06:54 +0800
commit245b26b565d5e0316f81d027537ab8218d23c9a3 (patch)
tree448267ec730d91b0bd2671ac9492be6fb370e175 /devel/subversion16/Makefile
parente3406ad237eec6c05cc67d0b93f4ed9bb4e9756f (diff)
downloadfreebsd-ports-gnome-245b26b565d5e0316f81d027537ab8218d23c9a3.tar.gz
freebsd-ports-gnome-245b26b565d5e0316f81d027537ab8218d23c9a3.tar.zst
freebsd-ports-gnome-245b26b565d5e0316f81d027537ab8218d23c9a3.zip
Mostly-maintainer update as follows:
Various fixes found by portlint -A. Hook up the info file to the info directory. Bump PORTREVISION. Submitted by: Craig Rodrigues <rodrigc@attbi.com> (MAINTAINER)
Diffstat (limited to 'devel/subversion16/Makefile')
-rw-r--r--devel/subversion16/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 0b8d67f6dc6f..dfab6c2d3d43 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.20.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/3440/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -21,17 +22,20 @@ LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
RUN_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
BUILD_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+
WRKSRC= ${WRKDIR}/subversion-${PORTVERSION}
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-ssl \
+CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
--with-apr=${LOCALBASE} \
--with-apr-util=${LOCALBASE}
-MAN1= svn.1 svnadmin.1
-MANCOMPRESSED= no
+MAN1= svn.1 svnadmin.1
+MANCOMPRESSED= no
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
@@ -45,6 +49,7 @@ post-configure:
@${REINPLACE_CMD} 's/swig-py-lib//g' ${WRKSRC}/Makefile
post-install:
+ install-info ${PREFIX}/info/svn-design.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
cd ${WRKSRC}/doc/book; \
${MAKE} INSTALL_DIR=${DOCSDIR} \