aboutsummaryrefslogtreecommitdiffstats
path: root/devel/subversion17
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-02-03 00:40:08 +0800
committerohauer <ohauer@FreeBSD.org>2014-02-03 00:40:08 +0800
commitf707592fb59461047c5eb3fe52dcb85200e01927 (patch)
treeedd76019d0f44972d6f49286f8413bd20dca2bdf /devel/subversion17
parent44313d9453ee8170905c6a36987e263a27b2eff8 (diff)
downloadfreebsd-ports-gnome-f707592fb59461047c5eb3fe52dcb85200e01927.tar.gz
freebsd-ports-gnome-f707592fb59461047c5eb3fe52dcb85200e01927.tar.zst
freebsd-ports-gnome-f707592fb59461047c5eb3fe52dcb85200e01927.zip
- fix apache module building (r341335 regression) [1]
- add all necessary KDE dependencies to KDE_KWALLET (r331808 regression) [2] - fix shebank (the old way!) [3] PR: ports/186167 , Tang Jianfeng <tangjfn@gmail.com> [1] PR: ports/186361 , PeterK <fbsdq@peterk.org> [1] PR: ports/185494 , Raphael Kubo da Costa <rakuco@FreeBSD.org> [2] PR: ports/184295 , Matthias Andree <mandree@FreeBSD.org> [3] Approved by: lev (implicit)
Diffstat (limited to 'devel/subversion17')
-rw-r--r--devel/subversion17/Makefile2
-rw-r--r--devel/subversion17/Makefile.common10
-rw-r--r--devel/subversion17/files/patch-Makefile.in15
3 files changed, 9 insertions, 18 deletions
diff --git a/devel/subversion17/Makefile b/devel/subversion17/Makefile
index ee63306055c9..125daaf74aa1 100644
--- a/devel/subversion17/Makefile
+++ b/devel/subversion17/Makefile
@@ -199,7 +199,7 @@ post-install: ${MKREPOS_TARGET}
@${MAKE} -C ${WRKSRC} install-tools ${MAKE_ARGS}
.endif
@${MKDIR} ${STAGEDIR}${DATADIR}
- @(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
+ @(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' --exclude '*.bak' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/devel/subversion17/Makefile.common b/devel/subversion17/Makefile.common
index 0a1442238267..aa557b758034 100644
--- a/devel/subversion17/Makefile.common
+++ b/devel/subversion17/Makefile.common
@@ -3,7 +3,7 @@
PORTNAME= subversion
PORTVERSION= 1.7.14
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
DIST_SUBDIR= subversion17
@@ -47,7 +47,7 @@ GNOME_KEYRING_LIB_DEPENDS= libgcr.so:${PORTSDIR}/security/gnome-keyring
KDE_KWALLET_CONFIGURE_OFF= --without-kwallet
KDE_KWALLET_CONFIGURE_ON= --with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE= KDE4=kdelibs runtime
+KDE_KWALLET_USE= KDE4=kdelibs,runtime
MAINTAINER_DEBUG_CFLAGS= -g
MAINTAINER_DEBUG_CONFIGURE_ON= --enable-maintainer-mode --enable-debug
@@ -123,3 +123,9 @@ post-patch:
.if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
+# shebangfix
+ ${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+ | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ -e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+ -e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+
diff --git a/devel/subversion17/files/patch-Makefile.in b/devel/subversion17/files/patch-Makefile.in
deleted file mode 100644
index 97cea24f1752..000000000000
--- a/devel/subversion17/files/patch-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
-========================================================================
-This patch is required to build SVN Apache modules with staging support
-========================================================================
---- ./Makefile.in.orig 2013-10-21 19:51:16.000000000 +0200
-+++ ./Makefile.in 2013-10-21 19:51:31.000000000 +0200
-@@ -209,7 +209,8 @@
- LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
-
- # special link rule for mod_dav_svn
--LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-+LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -inst-prefix-dir ${DESTDIR}
-+
-
- # Special LDFLAGS for some libraries
- libsvn_auth_gnome_keyring_LDFLAGS = @libsvn_auth_gnome_keyring_LDFLAGS@