aboutsummaryrefslogtreecommitdiffstats
path: root/devel/sunterlib/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-18 02:58:23 +0800
committerpav <pav@FreeBSD.org>2004-07-18 02:58:23 +0800
commitddb05b8cdfb482b6d031b2d040ad0be4f0ffe13d (patch)
treed7f52e88b97749991c82ebb09847d050a1222b2b /devel/sunterlib/Makefile
parent5bde136e8a20f283bd9c0d04b3018a8481e775f5 (diff)
downloadfreebsd-ports-gnome-ddb05b8cdfb482b6d031b2d040ad0be4f0ffe13d.tar.gz
freebsd-ports-gnome-ddb05b8cdfb482b6d031b2d040ad0be4f0ffe13d.tar.zst
freebsd-ports-gnome-ddb05b8cdfb482b6d031b2d040ad0be4f0ffe13d.zip
Add sunterlib, The Scheme Untergrund library hosts contributed libraries for
Scheme 48 and scsh. For instance, it includes a module system, semaphores and implementations of SRFI-10, SRFI-34 and SRFI-35. PR: ports/69073 Submitted by: Björn Lindström <bkhl@elektrubadur.se>
Diffstat (limited to 'devel/sunterlib/Makefile')
-rw-r--r--devel/sunterlib/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/sunterlib/Makefile b/devel/sunterlib/Makefile
new file mode 100644
index 000000000000..e35549aeb194
--- /dev/null
+++ b/devel/sunterlib/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sunterlib
+# Date created: 14 July 2004
+# Whom: bkhl@elektrubadur.se
+#
+# $FreeBSD$
+#
+
+PORTNAME= sunterlib
+PORTVERSION= 0.7
+CATEGORIES= devel scheme
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bkhl@elektrubadur.se
+COMMENT= Contributed libraries for Scheme 48 and scsh
+
+RUN_DEPENDS= ${LOCALBASE}/lib/scsh/scsh-install-pkg:${PORTSDIR}/devel/scsh-install-lib
+
+NO_BUILD= yes
+
+do-install:
+ (cd ${WRKSRC}; ${LOCALBASE}/lib/scsh/scsh-install-pkg --prefix=${PREFIX}/lib/scsh)
+
+.include <bsd.port.mk>