aboutsummaryrefslogtreecommitdiffstats
path: root/devel/swig11
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-11 17:51:15 +0800
committerknu <knu@FreeBSD.org>2001-06-11 17:51:15 +0800
commitda4419270be73cca13943d5d95a73ca42bf07692 (patch)
tree161a76c25f83da22b0b4b2185e56a0cb48617a8d /devel/swig11
parent83b561db00372b3e3602b95f0f2695c719c6c6c3 (diff)
downloadfreebsd-ports-gnome-da4419270be73cca13943d5d95a73ca42bf07692.tar.gz
freebsd-ports-gnome-da4419270be73cca13943d5d95a73ca42bf07692.tar.zst
freebsd-ports-gnome-da4419270be73cca13943d5d95a73ca42bf07692.zip
My previous fix was bogus. Fix build with Python 2.1 this time.
Diffstat (limited to 'devel/swig11')
-rw-r--r--devel/swig11/Makefile3
-rw-r--r--devel/swig11/files/patch-ah8
2 files changed, 6 insertions, 5 deletions
diff --git a/devel/swig11/Makefile b/devel/swig11/Makefile
index e211c85645de..6882b7411f0c 100644
--- a/devel/swig11/Makefile
+++ b/devel/swig11/Makefile
@@ -24,9 +24,10 @@ VER= 1.1
USE_PERL5= yes
USE_PYTHON= yes
+PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME:U}${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${LOCALBASE}/include/tcl8.3/ \
diff --git a/devel/swig11/files/patch-ah b/devel/swig11/files/patch-ah
index 139e4541fb7b..d460a34586f9 100644
--- a/devel/swig11/files/patch-ah
+++ b/devel/swig11/files/patch-ah
@@ -3,12 +3,12 @@
@@ -2445,3 +2445,3 @@
-dirs="$PYINCLUDE $PYINCLUDE/python1.5 $PYINCLUDE/python1.4 $PYINCLUDE/Py $prefix/include/python1.5 $prefix/include/python1.4 /usr/local/include/python1.5 /usr/include/python1.5 /usr/local/include/python1.4 /usr/include/python1.4 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
-+dirs="$PYINCLUDE $PYINCLUDE/python2.0 $PYINCLUDE/python1.5 $PYINCLUDE/Py $prefix/include/python2.0 $prefix/include/python1.5 /usr/local/include/python2.0 /usr/include/python2.0 /usr/local/include/python1.5 /usr/include/python1.5 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
++dirs="$PYINCLUDE $PYINCLUDE/python2.1 $PYINCLUDE/python1.5 $PYINCLUDE/Py $prefix/include/python2.1 $prefix/include/python1.5 /usr/local/include/python2.1 /usr/include/python2.1 /usr/local/include/python1.5 /usr/include/python1.5 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
for i in $dirs ; do
@@ -2460,3 +2460,3 @@
echo "configure:2461: checking for Python library" >&5
-dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python1.5/config $PYLIB/python1.4/config $PYLIB/python/lib $prefix/lib/python1.5/config $prefix/lib/python1.4/config /usr/local/lib/python1.5/config /usr/lib/python1.5 /usr/local/lib/python1.4/config /usr/lib/python1.4 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
-+dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python2.0/config $PYLIB/python1.5/config $PYLIB/python/lib $prefix/lib/python2.0/config $prefix/lib/python1.5/config /usr/local/lib/python2.0/config /usr/lib/python2.0 /usr/local/lib/python1.5/config /usr/lib/python1.5 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
++dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python2.1/config $PYLIB/python1.5/config $PYLIB/python/lib $prefix/lib/python2.1/config $prefix/lib/python1.5/config /usr/local/lib/python2.1/config /usr/lib/python2.1 /usr/local/lib/python1.5/config /usr/lib/python1.5 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
@@ -2467,6 +2467,6 @@
PYINCLUDE="$PYINCLUDE -I$i"
@@ -17,9 +17,9 @@
break
fi
- if test -r $i/libPython.a; then
-+ if test -r $i/libpython2.0.a; then
++ if test -r $i/libpython2.1.a; then
echo "$ac_t""$i" 1>&6
@@ -2474,2 +2474,3 @@
PYINCLUDE="$PYINCLUDE -I$i"
-+ PYLINK="-lpython2.0"
++ PYLINK="-lpython2.1"
break