aboutsummaryrefslogtreecommitdiffstats
path: root/devel/swig13
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-09-22 12:50:44 +0800
committerknu <knu@FreeBSD.org>2000-09-22 12:50:44 +0800
commit5b21aa51640a4bdebc27ae4c86238b4639d405d7 (patch)
treed6474105d6226a50e021867ada2c75b71f5b0201 /devel/swig13
parent520d8c06c601caa1d1531f894fe18a22aa4c3d3d (diff)
downloadfreebsd-ports-gnome-5b21aa51640a4bdebc27ae4c86238b4639d405d7.tar.gz
freebsd-ports-gnome-5b21aa51640a4bdebc27ae4c86238b4639d405d7.tar.zst
freebsd-ports-gnome-5b21aa51640a4bdebc27ae4c86238b4639d405d7.zip
Utilize bsd.{ruby,python}.mk.
Diffstat (limited to 'devel/swig13')
-rw-r--r--devel/swig13/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index b366abfc5330..42f5c9b55353 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swig
PORTVERSION= 1.3a4
+PORTREVISION= 1
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \
@@ -16,11 +17,14 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
- ${LOCALBASE}/bin/tclsh8.2:${PORTSDIR}/lang/tcl82 \
- ${LOCALBASE}/bin/ruby:${PORTSDIR}/lang/ruby
+BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR} \
+ ${LOCALBASE}/bin/tclsh8.2:${PORTSDIR}/lang/tcl82
USE_PERL5= yes
+USE_RUBY= yes
+RUBY_NO_RUN_DEPENDS= yes
+PYTHON_VERSION?= python1.5
+PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
USE_LIBTOOL= yes