aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcl-neo/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-04-13 02:26:49 +0800
committermi <mi@FreeBSD.org>2004-04-13 02:26:49 +0800
commitb42de0abfd391d938bbb5b4b6ce14ae969b9b32c (patch)
treeefa8091c458be2ebf376efac4acfe101e4e27e3d /devel/tcl-neo/Makefile
parent3088336812c548665bf6233880e8b22419d19f17 (diff)
downloadfreebsd-ports-gnome-b42de0abfd391d938bbb5b4b6ce14ae969b9b32c.tar.gz
freebsd-ports-gnome-b42de0abfd391d938bbb5b4b6ce14ae969b9b32c.tar.zst
freebsd-ports-gnome-b42de0abfd391d938bbb5b4b6ce14ae969b9b32c.zip
Make the TCL_VER(sion) a knob, rather than hardcoding the 8.3.
Default to 8.4 (as TclX does now), thus bump PORTREVISION. Thanks to: kris and the bento cluster
Diffstat (limited to 'devel/tcl-neo/Makefile')
-rw-r--r--devel/tcl-neo/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/devel/tcl-neo/Makefile b/devel/tcl-neo/Makefile
index 4e5b78a15da6..3de161433390 100644
--- a/devel/tcl-neo/Makefile
+++ b/devel/tcl-neo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= neotcl
PORTVERSION= 8.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=nws
@@ -28,21 +28,18 @@ WRKSRC= ${WRKDIR}/${SUBDIR}/generic
EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${SUBDIR}/generic ${SUBDIR}/neolibs
MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAKE_ENV+= NEO_LIBRARY=${NEO_LIBRARY}
+TCL_VER?= 8.4
+MAKE_ENV+= NEO_LIBRARY=${NEO_LIBRARY} TCL_VER=${TCL_VER}
DDIR= ${PREFIX}/lib/tcl${TCLV}/Trf
post-build:
- cd ${WRKSRC}/../neolibs && ${ECHO_CMD} 'auto_mkindex . */*.tcl' | tclsh8.3
+ cd ${WRKSRC}/../neolibs && ${ECHO_CMD} 'auto_mkindex . */*.tcl' | tclsh${TCL_VER}
NEO_LIBRARY= ${PREFIX}/lib/neo8.2
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502000
-BROKEN= "Broken pkg-plist"
-.endif
-
post-install:
${MKDIR} ${NEO_LIBRARY}
${CP} -Rp ${WRKSRC}/../neolibs/[a-z]* ${NEO_LIBRARY}