aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcl-trf
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-05-09 01:04:15 +0800
committermi <mi@FreeBSD.org>2006-05-09 01:04:15 +0800
commit23c1f8a7348ec2ad4b2ea164a4fa6484ba91ba99 (patch)
tree1aec86e5d478aa3404dc92c1f50a66d5fb16e2e5 /devel/tcl-trf
parent9e6aee3c083307bce8c801a1c7dd311e0825dc3f (diff)
downloadfreebsd-ports-gnome-23c1f8a7348ec2ad4b2ea164a4fa6484ba91ba99.tar.gz
freebsd-ports-gnome-23c1f8a7348ec2ad4b2ea164a4fa6484ba91ba99.tar.zst
freebsd-ports-gnome-23c1f8a7348ec2ad4b2ea164a4fa6484ba91ba99.zip
While trying to upgrade devel/tcllib several test failures were detected
in the RIPEMD128 implementation. Turns out, the problem was fixed a few months ago by the TRF author in CVS. This commit adds a patch and bumps portrevision. Although the same problem existed in the TRF's RIPEMD160 implementation, it did not affect this port, because it uses the OpenSSL's (or -lmd's) implementations of all digests -- except those, which are considered obsolete and no longer shipped. Like rmd128. Thanks to: Denis Shaposhnikov
Diffstat (limited to 'devel/tcl-trf')
-rw-r--r--devel/tcl-trf/Makefile2
-rw-r--r--devel/tcl-trf/files/patch-rmd12824
2 files changed, 25 insertions, 1 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index 9c487beaacb7..da639302552e 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Trf
PORTVERSION= 2.1p2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel tcl${TCL_VER:S/.//}
MASTER_SITES= http://www.oche.de/~akupries/soft/trf/download/
PKGNAMEPREFIX= tcl-
diff --git a/devel/tcl-trf/files/patch-rmd128 b/devel/tcl-trf/files/patch-rmd128
new file mode 100644
index 000000000000..0936f10bf452
--- /dev/null
+++ b/devel/tcl-trf/files/patch-rmd128
@@ -0,0 +1,24 @@
+Patch obtained from the TRF's CVS... Many thanks to Denis Shaposhnikov
+for finding it.
+
+TRF's RIPEMD160 implementation suffered from the same problem, but this
+port does not use it.
+
+ -mi
+
+--- generic/rmd128.c Wed Aug 9 15:13:18 2000
++++ generic/rmd128.c Mon May 8 12:52:04 2006
+@@ -46,5 +46,5 @@
+ typedef struct ripemd_context {
+ dword state [5]; /* state variables of ripemd-128 */
+- byte buf [CHUNK_SIZE]; /* buffer of 15-dword's */
++ byte buf [CHUNK_SIZE]; /* buffer of 16-dword's */
+ byte byteCount; /* number of bytes in buffer */
+ dword lowc; /* lower half of a 64bit counter */
+@@ -235,5 +235,5 @@
+ } /* k == CHUNK_SIZE => internal buffer was empty, so skip it entirely */
+
+- while (bufLen > CHUNK_SIZE) {
++ while (bufLen >= CHUNK_SIZE) {
+ CountLength (ctx, CHUNK_SIZE);
+