aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcllib
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-02-13 03:55:15 +0800
committermi <mi@FreeBSD.org>2007-02-13 03:55:15 +0800
commitaf88458416648a2512a22f13000f9a0af8d29c5c (patch)
treec38016905b2257c7195f0af94896e9a74e281c50 /devel/tcllib
parentd6790c6a4780cbbb795851a3e561c94caa256bfc (diff)
downloadfreebsd-ports-gnome-af88458416648a2512a22f13000f9a0af8d29c5c.tar.gz
freebsd-ports-gnome-af88458416648a2512a22f13000f9a0af8d29c5c.tar.zst
freebsd-ports-gnome-af88458416648a2512a22f13000f9a0af8d29c5c.zip
Add a patch from the vendor's CVS, which solves the problem of short
textual messages not being transfered to the SMTP server properly when NOT using TLS. Bump PORTREVISION.
Diffstat (limited to 'devel/tcllib')
-rw-r--r--devel/tcllib/Makefile1
-rw-r--r--devel/tcllib/files/patch-smtp35
2 files changed, 36 insertions, 0 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index 3aa1409c404a..d816be918d9e 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcllib
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= devel tcl83 tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcllib
diff --git a/devel/tcllib/files/patch-smtp b/devel/tcllib/files/patch-smtp
new file mode 100644
index 000000000000..ddd8231e4160
--- /dev/null
+++ b/devel/tcllib/files/patch-smtp
@@ -0,0 +1,35 @@
+Solves the problem described in:
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=827436&group_id=12883&atid=112883
+
+--- modules/mime/smtp.tcl 2005/10/07 07:26:40 1.44
++++ modules/mime/smtp.tcl 2006/11/06 21:21:59 1.45
+@@ -1,7 +1,7 @@
+ # smtp.tcl - SMTP client
+ #
+ # Copyright (c) 1999-2000 Marshall T. Rose
+-# Copyright (c) 2003-2005 Pat Thoyts
++# Copyright (c) 2003-2006 Pat Thoyts
+ #
+ # See the file "license.terms" for information on usage and redistribution
+ # of this file, and for a DISCLAIMER OF ALL WARRANTIES.
+@@ -32,7 +32,7 @@
+
+
+ namespace eval ::smtp {
+- variable version 1.4.2
++ variable version 1.4.3
+ variable trf 1
+ variable smtp
+ array set smtp { uid 0 }
+@@ -1123,6 +1123,10 @@
+ while {[regsub -all -- {([^\r])\n} $result "\\1\r\n" result]} {}
+ regsub -all -- {\n\.} $result "\n.." result
+
++ # Fix for bug #827436 - mail data must end with CRLF.CRLF
++ if {[string compare [string index $result end] "\n"] != 0} {
++ append result "\r\n"
++ }
+ set state(size) [string length $result]
+ puts -nonewline $state(sd) $result
+ set result ""