aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcllib
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-01-29 04:13:39 +0800
committermi <mi@FreeBSD.org>2002-01-29 04:13:39 +0800
commit2f4079ce9e577549227a70e1aa95473e57451dfc (patch)
tree93cdd96b9aca74dd627625946798672b3dbb4b20 /devel/tcllib
parentdc286b8e42ce12d60aca53a0663a343d341ee6cf (diff)
downloadfreebsd-ports-gnome-2f4079ce9e577549227a70e1aa95473e57451dfc.tar.gz
freebsd-ports-gnome-2f4079ce9e577549227a70e1aa95473e57451dfc.tar.zst
freebsd-ports-gnome-2f4079ce9e577549227a70e1aa95473e57451dfc.zip
Upgrade from 0.8 to 1.2. Use the included tests once at build time
instead of installing them. Use the included installation routine (which does not install documentation other than the man-pages). Update the WWW -- the project moved to SourceForge.
Diffstat (limited to 'devel/tcllib')
-rw-r--r--devel/tcllib/Makefile31
-rw-r--r--devel/tcllib/distinfo2
-rw-r--r--devel/tcllib/files/patch-test8
-rw-r--r--devel/tcllib/files/tclhttpd.sh16
-rw-r--r--devel/tcllib/pkg-descr26
-rw-r--r--devel/tcllib/pkg-message7
-rw-r--r--devel/tcllib/pkg-plist90
7 files changed, 88 insertions, 92 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index 02b3a6016150..e8c8e501aafe 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -6,33 +6,26 @@
#
PORTNAME= tcllib
-PORTVERSION= 0.8
+PORTVERSION= 1.2
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_TCLTK}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcllib
-DISTNAME= ${PORTNAME}${PORTVERSION}
-EXTRACT_ONLY=
MAINTAINER= mi@aldan.algebra.com
-NO_BUILD= YES
+GNU_CONFIGURE= yes
+ALL_TARGET= test
+MAKE_ENV+= LANG=C
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-MANN= counter.n ftpd.n graph.n html.n javascript.n math.n \
- ncgi.n nntp.n pop3.n profiler.n queue.n stack.n textutil.n \
- tree.n uri.n
-MANCOMPRESSED= no
-
-do-install:
- ${TAR} -xpz --exclude "${PORTNAME}${PORTVERSION}/[RI]*" \
- --exclude install.sh \
- -C ${LOCALBASE}/lib -f ${DISTDIR}/${DISTFILES}
- ${MV} `find ${LOCALBASE}/lib/${PORTNAME}${PORTVERSION} \
- -type f -name '*.n'` \
- ${LOCALBASE}/man/mann/
+MANN= base64.n cksum.n cmdline.n combinatorics.n comm.n control.n \
+ counter.n crc32.n csv.n expander.n fileutil.n ftp.n ftpd.n \
+ graph.n html.n htmlparse.n javascript.n log.n math.n matrix.n \
+ md5.n mime.n ncgi.n nntp.n pop3.n profiler.n report.n queue.n \
+ sha1.n smtp.n stack.n stooop.n sum.n textutil.n tree.n uri.n \
+ uuencode.n
-post-install:
- @${CAT} ${PKGMESSAGE}
+MANCOMPRESSED= no
.include <bsd.port.mk>
diff --git a/devel/tcllib/distinfo b/devel/tcllib/distinfo
index d7b04cd101ea..4adc723cd702 100644
--- a/devel/tcllib/distinfo
+++ b/devel/tcllib/distinfo
@@ -1 +1 @@
-MD5 (tcllib0.8.tar.gz) = 0c198c010090b52043034a7a20179ef7
+MD5 (tcllib-1.2.tar.gz) = a70c5650cb4a201ed714b6f3420c8e38
diff --git a/devel/tcllib/files/patch-test b/devel/tcllib/files/patch-test
new file mode 100644
index 000000000000..20a5d87f0b77
--- /dev/null
+++ b/devel/tcllib/files/patch-test
@@ -0,0 +1,8 @@
+--- all.tcl Mon Jan 21 12:55:22 2002
++++ all.tcl Mon Jan 28 14:30:41 2002
+@@ -122,4 +122,5 @@
+ # import the auto_path from the parent interp, so "package require" works
+ $c eval {
++ set ::argv0 [pSet ::argv0]
+ set ::tcllibModule [pSet module]
+ set auto_path [pSet auto_path]
diff --git a/devel/tcllib/files/tclhttpd.sh b/devel/tcllib/files/tclhttpd.sh
deleted file mode 100644
index 6053456fe639..000000000000
--- a/devel/tcllib/files/tclhttpd.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-case $1 in
-stop)
- if ! [ -f /var/run/tclhttd.pid ] ; then
- echo tclhttd does not seem to be running
- exit 1
- fi
- echo "Not sure if `cat /var/run/tclhttd.pid` \
- (from /var/run/tclhttd.pid) is what you wish killed."
- exit 2
- ;;
-start|"")
- COMMAND_LINE &
- test -n "$!" && echo $! > /var/run/tclhttd.pid
- ;;
-esac
diff --git a/devel/tcllib/pkg-descr b/devel/tcllib/pkg-descr
index 74ffb6a37bc6..724a97862440 100644
--- a/devel/tcllib/pkg-descr
+++ b/devel/tcllib/pkg-descr
@@ -2,23 +2,11 @@ Tcllib is a collection of utility modules for Tcl. The intent is to
collect commonly used function into a single library, which users can
rely on to be available and stable.
-The latest version of tcllib, 0.8, includes the following modules:
- base64 base64 encoder and decoder
- cmdline command line argument processor similar to opt
- counter Event counters, interval timers, and histogram display
- fileutil Tcl implementations of some standard Unix utilities
- ftp FTP client library
- ftpd FTP server
- html HTML generation procedures. This uses ncgi.
- javascript Javascript generation procedures.
- math common math functions like min, max, and others
- mime MIME encoder and decoder
- ncgi new CGI processing module
- nntp NNTP (news) client
- pop3 POP3 protocol implementation
- profiler function level Tcl source code profiler
- struct Tcl implementations of common data structures
- textutil Text processing utilities
- uri URI parsing module
+There are too many modules now to list here. Browse the on-line
+documentation at
-WWW: http://dev.scriptics.com/software/tcllib/
+ http://tcllib.sourceforge.net/doc/
+
+to get the idea.
+
+WWW: http://tcllib.sourceforge.net/
diff --git a/devel/tcllib/pkg-message b/devel/tcllib/pkg-message
deleted file mode 100644
index 6798dfdac6c6..000000000000
--- a/devel/tcllib/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
-
- Some of the parts of tcllib already come with man pages,
- which are properly installed. Some others -- with
- plain-text/HTML pages which are installed next to the
- corresponding TCL code. This is how the Scriptics/Ajuba
- developers intended it to happen, apparently...
-
diff --git a/devel/tcllib/pkg-plist b/devel/tcllib/pkg-plist
index f819b4768d72..e986c328a9c6 100644
--- a/devel/tcllib/pkg-plist
+++ b/devel/tcllib/pkg-plist
@@ -1,59 +1,48 @@
lib/tcllib%%PORTVERSION%%/base64/base64.tcl
-lib/tcllib%%PORTVERSION%%/base64/base64.test
-lib/tcllib%%PORTVERSION%%/base64/compare.tcl
+lib/tcllib%%PORTVERSION%%/base64/uuencode.tcl
lib/tcllib%%PORTVERSION%%/base64/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/base64
lib/tcllib%%PORTVERSION%%/cmdline/cmdline.tcl
-lib/tcllib%%PORTVERSION%%/cmdline/cmdline.test
lib/tcllib%%PORTVERSION%%/cmdline/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/cmdline/typedCmdline.tcl
-lib/tcllib%%PORTVERSION%%/cmdline/typedCmdline.test
@dirrm lib/tcllib%%PORTVERSION%%/cmdline
lib/tcllib%%PORTVERSION%%/counter/counter.tcl
-lib/tcllib%%PORTVERSION%%/counter/counter.test
lib/tcllib%%PORTVERSION%%/counter/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/counter
lib/tcllib%%PORTVERSION%%/fileutil/fileutil.tcl
-lib/tcllib%%PORTVERSION%%/fileutil/fileutil.test
lib/tcllib%%PORTVERSION%%/fileutil/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/fileutil
lib/tcllib%%PORTVERSION%%/ftp/ftp.tcl
-lib/tcllib%%PORTVERSION%%/ftp/ftpdemo.tcl
+lib/tcllib%%PORTVERSION%%/ftp/ftp_geturl.tcl
lib/tcllib%%PORTVERSION%%/ftp/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/ftp
lib/tcllib%%PORTVERSION%%/ftpd/ftpd.tcl
lib/tcllib%%PORTVERSION%%/ftpd/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/ftpd/rfc959.txt
-lib/tcllib%%PORTVERSION%%/ftpd/std9.txt
@dirrm lib/tcllib%%PORTVERSION%%/ftpd
lib/tcllib%%PORTVERSION%%/html/html.tcl
-lib/tcllib%%PORTVERSION%%/html/html.test
lib/tcllib%%PORTVERSION%%/html/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/html
lib/tcllib%%PORTVERSION%%/javascript/javascript.tcl
lib/tcllib%%PORTVERSION%%/javascript/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/javascript
-lib/tcllib%%PORTVERSION%%/license.terms
+lib/tcllib%%PORTVERSION%%/math/calculus.tcl
+lib/tcllib%%PORTVERSION%%/math/combinatorics.tcl
+lib/tcllib%%PORTVERSION%%/math/fuzzy.tcl
+lib/tcllib%%PORTVERSION%%/math/geometry.tcl
lib/tcllib%%PORTVERSION%%/math/math.tcl
-lib/tcllib%%PORTVERSION%%/math/math.test
+lib/tcllib%%PORTVERSION%%/math/misc.tcl
+lib/tcllib%%PORTVERSION%%/math/tclIndex
lib/tcllib%%PORTVERSION%%/math/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/math
-lib/tcllib%%PORTVERSION%%/mime/README.html
-lib/tcllib%%PORTVERSION%%/mime/README.txt
-lib/tcllib%%PORTVERSION%%/mime/README.xml
lib/tcllib%%PORTVERSION%%/mime/mime.tcl
-lib/tcllib%%PORTVERSION%%/mime/mime.test
lib/tcllib%%PORTVERSION%%/mime/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/mime/smtp.tcl
@dirrm lib/tcllib%%PORTVERSION%%/mime
-lib/tcllib%%PORTVERSION%%/ncgi/formdata.txt
lib/tcllib%%PORTVERSION%%/ncgi/ncgi.tcl
-lib/tcllib%%PORTVERSION%%/ncgi/ncgi.test
lib/tcllib%%PORTVERSION%%/ncgi/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/ncgi
lib/tcllib%%PORTVERSION%%/nntp/nntp.tcl
lib/tcllib%%PORTVERSION%%/nntp/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/nntp/rfc977.txt
@dirrm lib/tcllib%%PORTVERSION%%/nntp
lib/tcllib%%PORTVERSION%%/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/pop3/pkgIndex.tcl
@@ -61,33 +50,74 @@ lib/tcllib%%PORTVERSION%%/pop3/pop3.tcl
@dirrm lib/tcllib%%PORTVERSION%%/pop3
lib/tcllib%%PORTVERSION%%/profiler/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/profiler/profiler.tcl
-lib/tcllib%%PORTVERSION%%/profiler/profiler.test
@dirrm lib/tcllib%%PORTVERSION%%/profiler
lib/tcllib%%PORTVERSION%%/struct/graph.tcl
-lib/tcllib%%PORTVERSION%%/struct/graph.test
lib/tcllib%%PORTVERSION%%/struct/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/struct/queue.tcl
-lib/tcllib%%PORTVERSION%%/struct/queue.test
+lib/tcllib%%PORTVERSION%%/struct/matrix.tcl
lib/tcllib%%PORTVERSION%%/struct/stack.tcl
-lib/tcllib%%PORTVERSION%%/struct/stack.test
lib/tcllib%%PORTVERSION%%/struct/struct.tcl
lib/tcllib%%PORTVERSION%%/struct/tree.tcl
-lib/tcllib%%PORTVERSION%%/struct/tree.test
@dirrm lib/tcllib%%PORTVERSION%%/struct
lib/tcllib%%PORTVERSION%%/textutil/adjust.tcl
-lib/tcllib%%PORTVERSION%%/textutil/adjust.test
+lib/tcllib%%PORTVERSION%%/textutil/expander.tcl
lib/tcllib%%PORTVERSION%%/textutil/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/textutil/split.tcl
-lib/tcllib%%PORTVERSION%%/textutil/split.test
lib/tcllib%%PORTVERSION%%/textutil/tabify.tcl
-lib/tcllib%%PORTVERSION%%/textutil/tabify.test
lib/tcllib%%PORTVERSION%%/textutil/textutil.tcl
-lib/tcllib%%PORTVERSION%%/textutil/textutil.test
lib/tcllib%%PORTVERSION%%/textutil/trim.tcl
-lib/tcllib%%PORTVERSION%%/textutil/trim.test
@dirrm lib/tcllib%%PORTVERSION%%/textutil
lib/tcllib%%PORTVERSION%%/uri/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/uri/uri.tcl
-lib/tcllib%%PORTVERSION%%/uri/uri.test
+lib/tcllib%%PORTVERSION%%/uri/urn-scheme.tcl
@dirrm lib/tcllib%%PORTVERSION%%/uri
+lib/tcllib%%PORTVERSION%%/calendar/calendar.tcl
+lib/tcllib%%PORTVERSION%%/calendar/gregorian.tcl
+lib/tcllib%%PORTVERSION%%/calendar/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/calendar/tclIndex
+@dirrm lib/tcllib%%PORTVERSION%%/calendar
+lib/tcllib%%PORTVERSION%%/comm/comm.tcl
+lib/tcllib%%PORTVERSION%%/comm/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/comm
+lib/tcllib%%PORTVERSION%%/control/ascaller.tcl
+lib/tcllib%%PORTVERSION%%/control/assert.tcl
+lib/tcllib%%PORTVERSION%%/control/control.tcl
+lib/tcllib%%PORTVERSION%%/control/do.tcl
+lib/tcllib%%PORTVERSION%%/control/no-op.tcl
+lib/tcllib%%PORTVERSION%%/control/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/control/tclIndex
+@dirrm lib/tcllib%%PORTVERSION%%/control
+lib/tcllib%%PORTVERSION%%/crc/cksum.tcl
+lib/tcllib%%PORTVERSION%%/crc/crc32.tcl
+lib/tcllib%%PORTVERSION%%/crc/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/crc/sum.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/crc
+lib/tcllib%%PORTVERSION%%/csv/csv.tcl
+lib/tcllib%%PORTVERSION%%/csv/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/csv
+lib/tcllib%%PORTVERSION%%/htmlparse/htmlparse.tcl
+lib/tcllib%%PORTVERSION%%/htmlparse/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/htmlparse
+lib/tcllib%%PORTVERSION%%/log/log.tcl
+lib/tcllib%%PORTVERSION%%/log/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/log
+lib/tcllib%%PORTVERSION%%/md5/md5.tcl
+lib/tcllib%%PORTVERSION%%/md5/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/md5
+lib/tcllib%%PORTVERSION%%/report/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/report/report.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/report
+lib/tcllib%%PORTVERSION%%/sha1/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/sha1/sha1.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/sha1
+lib/tcllib%%PORTVERSION%%/smtpd/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/smtpd/smtpd.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/smtpd
+lib/tcllib%%PORTVERSION%%/stooop/mkpkgidx.tcl
+lib/tcllib%%PORTVERSION%%/stooop/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/stooop/stooop.tcl
+lib/tcllib%%PORTVERSION%%/stooop/switched.tcl
+lib/tcllib%%PORTVERSION%%/stooop/xifo.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/stooop
@dirrm lib/tcllib%%PORTVERSION%%
+man/man.macros