aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tijmp
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-12-20 02:09:06 +0800
committerpav <pav@FreeBSD.org>2007-12-20 02:09:06 +0800
commit7f293c549491c04ac423ddb54c6a662ddfd8dc59 (patch)
treed577d54e2d437ccea58ef97b06c5c4ac7b73ee60 /devel/tijmp
parentdaebd52642cffd652bf9cae1425f7593fdda6ee1 (diff)
downloadfreebsd-ports-gnome-7f293c549491c04ac423ddb54c6a662ddfd8dc59.tar.gz
freebsd-ports-gnome-7f293c549491c04ac423ddb54c6a662ddfd8dc59.tar.zst
freebsd-ports-gnome-7f293c549491c04ac423ddb54c6a662ddfd8dc59.zip
TIJmp is a memory profiler for java. TIJmp is made for java/6 and later, it
will not work on java/5 systems. If you need a profiler for java/5 or earlier try the jmp profiler. TIJmp is written to be fast and have a small footprint, both memory- and cpu- wise. This means that the jvm will run at almost full speed, until you use tijmp to find some information. TIJmp uses C code to talk to the jvm and it uses swing to show the the tables of information. So tijmp is written in C (using jvmti and jni) and Java. TIJmp runs in the same jvm as the program being profiled. This means that it can easily get access to all things jvmti/jni has to offer. TIJmp is distributed under the General Public License, GPL. Usage: java -agentlib:tijmp <your-class> WWW: http://khelekore.org/jmp/tijmp/ PR: ports/117615 Submitted by: Ronald Klop <ronald@echteman.nl>
Diffstat (limited to 'devel/tijmp')
-rw-r--r--devel/tijmp/Makefile51
-rw-r--r--devel/tijmp/distinfo3
-rw-r--r--devel/tijmp/pkg-descr20
3 files changed, 74 insertions, 0 deletions
diff --git a/devel/tijmp/Makefile b/devel/tijmp/Makefile
new file mode 100644
index 000000000000..ba8e28386175
--- /dev/null
+++ b/devel/tijmp/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: tijmp
+# Date created: 8 October 2007
+# Whom: Ronald Klop <ronald@echteman.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tijmp
+PORTVERSION= 0.4
+CATEGORIES= devel java
+MASTER_SITES= http://www.khelekore.org/jmp/tijmp/
+
+MAINTAINER= ronald@echteman.nl
+COMMENT= Tools Interface Java Memory Profiler
+
+OPTIONS= OPTIMIZED_CFLAGS "Compile with -O3" off
+
+USE_GMAKE= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+JAVA_OS= native
+JAVA_BUILD= jdk
+NEED_JAVAC= yes
+USE_JIKES= no
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= JAVA_HOME="${JAVA_HOME}"
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/lib${PORTNAME}.la \
+ lib/lib${PORTNAME}.so lib/lib${PORTNAME}.so.0 \
+ %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS?= -O3
+.endif
+
+post-extract::
+ @${SED} -i "" -e 's|share/java|${JAVAJARDIR:S,^${PREFIX}/,,}|' ${WRKSRC}/src/tijmp.c
+
+do-install::
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_DATA} ${WRKSRC}/src/.libs/lib${PORTNAME}.la ${PREFIX}/lib/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/lib${PORTNAME}.so.0 ${PREFIX}/lib/
+ cd ${PREFIX}/lib && ${LN} -sf lib${PORTNAME}.so.0 lib${PORTNAME}.so
+
+.include <bsd.port.post.mk>
diff --git a/devel/tijmp/distinfo b/devel/tijmp/distinfo
new file mode 100644
index 000000000000..e42825e5a11c
--- /dev/null
+++ b/devel/tijmp/distinfo
@@ -0,0 +1,3 @@
+MD5 (tijmp-0.4.tar.gz) = 8eecd304f8bb221d94983dd674a880be
+SHA256 (tijmp-0.4.tar.gz) = 083bce9602f71fca1eee3729fa1c89275f9a71c8ec78eee11714681663c22b8b
+SIZE (tijmp-0.4.tar.gz) = 351355
diff --git a/devel/tijmp/pkg-descr b/devel/tijmp/pkg-descr
new file mode 100644
index 000000000000..bcacc857118d
--- /dev/null
+++ b/devel/tijmp/pkg-descr
@@ -0,0 +1,20 @@
+TIJmp is a memory profiler for java. TIJmp is made for java/6 and later, it
+will not work on java/5 systems. If you need a profiler for java/5 or earlier
+try the jmp profiler.
+
+TIJmp is written to be fast and have a small footprint, both memory- and cpu-
+wise. This means that the jvm will run at almost full speed, until you use
+tijmp to find some information.
+
+TIJmp uses C code to talk to the jvm and it uses swing to show the the tables
+of information. So tijmp is written in C (using jvmti and jni) and Java.
+
+TIJmp runs in the same jvm as the program being profiled. This means that it
+can easily get access to all things jvmti/jni has to offer.
+
+TIJmp is distributed under the General Public License, GPL.
+
+Usage:
+java -agentlib:tijmp <your-class>
+
+WWW: http://khelekore.org/jmp/tijmp/