aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tvision/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-26 02:36:39 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-26 02:36:39 +0800
commit2e24cb013a4dff5e119d355c91b2622a00311b14 (patch)
tree7a79ec7a9cea96d93a4faead0a8d2d8c0f3fff6d /devel/tvision/Makefile
parentcde2f267c86553ca05e0aa4469ac034e4060371d (diff)
downloadfreebsd-ports-gnome-2e24cb013a4dff5e119d355c91b2622a00311b14.tar.gz
freebsd-ports-gnome-2e24cb013a4dff5e119d355c91b2622a00311b14.tar.zst
freebsd-ports-gnome-2e24cb013a4dff5e119d355c91b2622a00311b14.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39842 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'devel/tvision/Makefile')
-rw-r--r--devel/tvision/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/tvision/Makefile b/devel/tvision/Makefile
index 9980d12c5697..5964e837477e 100644
--- a/devel/tvision/Makefile
+++ b/devel/tvision/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= devel/lang/c++
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
@@ -23,9 +24,9 @@ post-extract:
@${MV} ${WRKSRC}/myendian.h ${WRKSRC}/lib
post-patch:
- @${PERL} -pi -e 's,myendian.h,tvision/myendian.h,g' \
+ @${REINPLACE_CMD} -e 's,myendian.h,tvision/myendian.h,g' \
${WRKSRC}/lib/drawbuf.h ${WRKSRC}/lib/system.h
- @${PERL} -pi -e 's,menus.h msgbox.h,menus.h msgbox.h myendian.h,' \
+ @${REINPLACE_CMD} -e 's,menus.h msgbox.h,menus.h msgbox.h myendian.h,' \
${WRKSRC}/lib/Makefile.in
.include <bsd.port.mk>